FAULT_CODE_OVER_TEMP_MOTOR (feat crash at 47kph)

I got this fault code and subsequent motor cutout for motor temperature:
FAULT_CODE_OVER_TEMP_MOTOR the fault noted the temperature was 74.14

Confirmed my motor settings are set to 100c for motor temp cutoff. which is when I thought it’s supposed to throw the temperature fault code. what causes it to throw the fault code with a lower temp?

Motor Temp Cutoff End: The motor temperature above which motor current is not allowed and a fault is thrown



Fault code:

Current          : 26.0
Current filtered : 26.1
Voltage          : 34.27
Duty             : 0.950
RPM              : 36460.8
Tacho            : 3554304
Cycles running   : 360106
TIM duty         : 7980
TIM val samp     : 2
TIM current samp : 4200
TIM top          : 8400
Comm step        : 0
Temperature      : 74.14

hardware is dual focbox 4.10 only primary had the fault code.

Firmware: 3.65   
Hardware: 410

I tried looking at the code. not 100% sure yet, but it looked like as soon as the FAULT is thrown the existing temperature that was used for the check is written to that Fault message. which… contradicts the apparent settings… leaving me confused.

1 Like

no idea. unless you plan on thrashing your motor to its limits, i simply wouldn’t use the motor temp wire (disconnect it). not sure what others think but I’ve never used the thermistor in my motors


My METR reads the data but it says no temp sensor in the VESC Tool so they seem kinda sus anyways…you’re not gonna burn them unless you are a hefty man (or woman) booking it up a mountain


Can’t you disable motor temp limit in the software somewhere? You’ll feel them start to throttle on their own through losses once they’re hot enough to have the slightest concern. Not a great idea to do long term if they always get boiling, but if they are just warm or fairly hot and you’re getting this issue it should be fine


You probably are having the same problem as me and a few other people, the phase wires inject noise in the temperature sensor wires and the reading becomes really jumpy while riding, this triggers faults without it actually being hot

I’ve made a topic on VESC forum but nothing was done so far

@Trampa you could remember Benjamin since depending the setup this cause a quite jerky and dangerous behavior

The solution for now is increasing the limits so even with the noise they are never reached, but if your motor really gets hot and you need the limits, you are out of lucky



the confusing bit to me is it seems to have triggered with a value of 74.14c . which is below the 80c throttling start, and the 100c cutoff. it just cut out.

I was riding a newer lower / torquier gear ratio, and going full throttle on flatland for a few mins when it happened. so I thought maybe it was a real issue. but motors didn’t seem hot. and the temp in the fault message isn’t beyond the thresholds.

so maybe a quick spurious value if the value gets updated between the check and the fault message being printed. that would speak to the noise idea that @Pedrodemio mentioned…



Not running temp sensors can be helpful and harmful. If you are having issues with noise causing nuisance faults as @Pedrodemio mentioned then it seems the only option. I, for one, would exhaust all options before running with no temp sensor. Reason being, I recently got a similar fault on one motor. When I did the “feel test” I nearly singed my fingers. There was an internal short in the motor as you can see the glowing wire in this video. Just something to be cautious of if running blind. Wouldn’t be a bad idea to periodically check your temps by feel during stops along your ride. This could save you from a full meltdown. Good luck :call_me_hand:


few hundred miles later and it happened again:

The following faults were registered since start:

Current          : 19.6
Current filtered : 18.8
Voltage          : 33.71
Duty             : 0.950
RPM              : 35618.4
Tacho            : 5231903
Cycles running   : 28798
TIM duty         : 7980
TIM val samp     : 2
TIM current samp : 4200
TIM top          : 8400
Comm step        : 0
Temperature      : 70.21

I’m running metr now. i was able to see that motor temps at the time were around 70 - 75 . on the motor that triggered the issue. about 5 degrees less on the other one. so not into the 80c cutoff start nor at the 100C throw alert. but definitely at the higher end of my whole ride.

definitely seems like some glitchy reading / fault. hmm.

1 Like

have you considered twisting the phase and sensor wires?

I have not. What’s that mean?

got me another one today.

The following faults were registered since start:

Current          : 32.2
Current filtered : 31.0
Voltage          : 32.57
Duty             : 0.930
RPM              : 33632.9
Tacho            : 12043889
Cycles running   : 101383
TIM duty         : 7815
TIM val samp     : 2
TIM current samp : 4200
TIM top          : 8400
Comm step        : 0
Temperature      : 71.60

This is happening on my primary motor/focbox.
This primary motor is about to be replaced. it’s rubbing a bit. It has the same problem my other motor did.

Today observing Metr while riding temperatures were higher. and higher by about 5°C on the primary.
they were approaching and brushing up 80°C . when this happened I got a stuttering which I presume is the current throttling from motor temp cutoff start. It’s very stuttered though, and not at all smooth the way the low voltage current cutoff works. IDK if that’s right.

so… temps were higher, but again never looked high enough to jump to the 100°C required throw the fault that did throw once. so still seems like a bug.

Ugh I was wrong. The motor I was replacing is my secondary. The primary is the one throwing the faults.

And on the bench with no load it stutters when approaching high duty cycle. The primary motor does not.

The motor temps do oscillate a lot as the motor spins. On both motors. Perhaps + or - 5 deg. Not enough to be in throttling zone. As measured by Vesc tool real-time data. But only the primary is having issues.

1 Like

it does this in sensorless mode with the sensors disconnected. so perhaps this stuttering is separate problem from the FAULT_CODE_OVER_TEMP_MOTOR

this is the stuttering that’s happening ( in sensorless FOC or BLDC same behavior. )

I noticed my PPM mapping only went to 99.x% not 100%. adjusted it a little. and noticed that the stuttering goes away at 100% throttle but anything just under and it stutters. with the duty cycle jumping around.

Again, this stuttering i’m starting to think is a different problem. from the motor temps.

going to try physically switching the motors to see if the stutter problem stays with the focbox or the motor.

Ok, the stuttering stayed with the focbox. the motor being run over canbus does not show the stuttering.

wondering if I should make a different thread for the stuttering issue.

1 Like

Ugh. I’m stuck on the stuttering problem.

So, initially I believe i observed the stuttering while riding. I believed it was related to motor temperature current throttling, since I’d also had the fault code randomly. So I tried to reproduce on the bench. with no load, no wheels attached, the motor exhibits an obvious stuttering.

  • whichever motor is connected to primary vesc. the secondary controlled via CAN does not stutter, and other VESC
  • in BLDC or FOC sensored or sensorless mode.
  • not when PPM signal reaches 100%. only when it’s lower.

I did not try moving PPM input to the other focbox yet. [bit more intrusive in my current glued up setup. ]

I thought maybe it was related to min current, which both my focboxes have set to 1A, so I set them to the default of 0.1 A. it didn’t change things. so I changed it back.

I did run with belts on to 8in pneumatic wheels. and the stuttering was no longer noticeable. so I’m wondering if this was all a red herring, and i’m not really tracking with this stuttering whatevever the issue is I felt on the road. .

Ok, I did all the ungluing required to move the receiver over to my second focbox. and the stuttering traveled with it. so I think this bench test is just a red herring. and I’m seeing something that’s a side effect of running with no load.

I probably still have unexplained random triggering of motor over temp faults.

However, lengthening the motor wires may lead to radio interference. Give the three of them a twist to prevent this, or tie them together.


Oh, this is probably what you meant. I assume the idea would be to twist the motor phase wires together and separately twist the sensor wires.

seen any pictures of how people have implemented this?

would it do anything on the sensor wires? for that mater how does it help on the phase wires? I’m think of wire twisting to reduce noise being related to running the same signal over two wires twisted together. none of these wires have the same signal.

I’m down to try it. wish I’d understood it before I did my motor replacement.

You could just unplug the temp wire of that motor and use the one it is working right to tlet you know the value…both motors should work the same way…So you will be playing preety safe…I am actually using one motor temp because the other one failed, so I just twisted the Vesc-Tool to ignore the temp on the fucked up motor…Everything it is running great…