Vx2 remote will not move the wheels

I have a dual fsesc 6.6 vesc on my board and am having issues with communication between the board and my vx2 remote. I have changed PPM to Uart in general app settings, have switched the control type to current in the vesc remote tab, fully charged the battery, tried both COMM ports, paired the motors and the remote receivers multiple times and still nothing. I can command the motors to move the wheels when I am doing the motor setup wizard so I know there is power going to them. Additionally, when I spin the wheel that the CAN is connected to I get a MPH reading on the remote. On top of all of this, I originally had a v4 vx2 remote and despite reading that it should still work as long as I switch the VRX and VTX wires, I went ahead and bought a v6 vx2 remote and receiver and am still having the same issue. I read somewhere about calibrating the remote and a hall effect issue? Could this be it? I am running out of ideas as to what is happening to my board and I have quite a bit invested into this but don’t know where to go from here. Does anyone know if there is a previous version of the vesc tool software that I could maybe try? I don’t know. Please help.

The VX2 is a POS, if you don’t get it working get a refund and use a better remote. Every second day a thread pops up where a VX2 isn’t working, idk why people even buy that shitty thing considering it’s not even cheap.
Most likely fix will be switch the RX and TX cable on the receiver.

Anyway, here’s something to read, maybe it works, maybe it doesn’t. Either way, I’d recommend you toss the garbage and get a puck or a VX1 or something else.


The amount of people posting about having trouble getting the vx2 to work is straight up infuriating.

I think it’s time we create a dedicated thread for this garbage of a remote.


Can only agree.

1 Like

niceeee. So what remotes do you recommend then? Why would a vx1 be better assuming that the vx2 is the new and improved version of it?

Because you plug the VX1 in and be done with it.

no v4/v6 bullshit
No in-remote settings that need to be dealt with etc etc.

Understandable. Is there anything else I’m missing I should try? I feel like maybe it’s some sort of hardware problem since I’m having the same issue with two separate remotes? I don’t know.

Have you tried this already?

Trampa Wand (expensive), mini RC remote (cheap), Hoyt Puck (kinda expensive), VX1 (relatively cheap). There a wiki for remotes, that’s all from the top of my head.

Edit: Wiki-link

yeah its a v6 remote which is paired for the 6.x fsesc so I made sure the vx and tx wires were in their correct places.

Update I used one of my dads spare RC remotes: a Flysky FS-GT2B which from what i understand is a PPM remote and receiver. I tapped it into channel 2 via the 3 wire plug coming off of the board and confirmed the pins were correct. Changed the input setting from UART to PPM & UART and eventually just PPM. Powered it up, the light on the receiver turned solid meaning it was paired with the remote, and… nothing still in any configuration. I’m starting to suspect that something internally is wrong with my board or something because this just doesn’t make sense. The board still turns the wheels when doing the motor setup so I know they do work but no remote seems to be communicating with the board. Any other ideas?

I cannot agree here. This remote has been very well documented as being unreliable. Hell, I’ve even watched Trampa riders struggle in events because of the remote cutting out.
The other suggestions are great though. There’s even vx1 pro now which so far seems to be great.

v4 and v6 pinout are different, just flipping rx/tx doesn’t always work

don’t flip the rx/tx if u r using flipsky receiver with flipsky esc

go into remote setting and scroll to the calibration and do the setup, there is a vx2 guide video in flipsky youtube channel to show u how to do that

cheap option: vx1 / mini
expensive option: puck / freesk8 remote

vx2 might be newer, but its no way an improved version of vx1. even vx3 still can’t beat vx1

when u changed the input mode, did u redo the vesctool calibration?

I wouldn’t recommend this one as it’s not available for now.

Mine works flawlessly for over a year now. I mostly ride alone though, so maybe it doesn’t handle interference well. That I can’t comment on.

For normal PPM remotes you need to do the input setup first, otherwise they won’t work.

they will restock, its not like it will be discontinued from this point onwards

Well, it’s out of stock for like half a year now afaik? Imo recommending stuff that can’t be bought right now should at least include a warning about the wait time. Many people don’t have spares lying around to use in the mean time.

What happened to me was a vesc tool problem, the vesc tool turned the remote settings off and the vesc wasn’t reading the remote input, it had nothing to do with the remote
The only problem that I have with the remote is the fact that when i use it in the rain sometimes the water leaks in a bit apart from that it works fine i just have to open it to dry it up even with that it never failed on me

[quote=“Algaliarept, post:16, topic:63582, full:true”]
What happened to me was a vesc tool problem, the vesc tool turned the remote settings off and the vesc wasn’t reading the remote input

So what did you do to fix that? use a different version of the vesc tool?

1 Like

by vesc tool calibration do you mean the setup input option?