Help with flipsky vx2 on focbox unity

Im building a demon 2.0 by propulsion boards. I set the vesc up as he did in the video using vesc tool pc and updated the firmware to 5.2. I reached out and he said to have the remote set to FESEC “Im 90% sure I had it set to that and it didnt because I wouldnt have changed those settings if it worked.” But I was at work before I read the email. I spent 5/7 hours buildings programming multiple times yesterday and couldnt get it to work. Another thing is the remote trip is at 99997 and jumps around. I did have it plugged in when i programmed it on the pc because I tried settings it up threw the app and couldn’t get the remote to work and forgot to unplug it when i redid everything on the pc. Is there a way to reset the completely? Im dont want to replace the remote if i dont have to but ive already spent 2150 on it with riptide bushings griptape silicone and lock tight so im too deep to not buy one if that makes sense “suggestions” . Im not home to try his suggestion rn but I was hoping for a second option i wont have a lot of time to test stuff before i have to head to bed for work and would like to have it fixed by tonight. Thank in advance :pray:

Have you tried switching the RX and TX pin on the receiver plug?


So about that I saw a post about it and they had contradicting diagrams. So im not sure what one is right but it came with 2 different ribbon cables. Instead of trying to pull the wires and switch them on the cable that had 7 plugs I cut the end of the plug that had 8 with the different order if that makes sense so it would fit the plug on the focbox. It didnt work it did reset the miles on the remote if i remember correctly but it didnt make the motors spin when i tried to use it.

IF I’m understanding you correctly, you changed out the receiver cable? The VX2 receiver has only 4 leads, and those go to the GND, 5V, RX an TX pins.

Yes they have 4 red white green and orange with 7 slot connector on 1 cable the other cable has the same wires just the orange and green are switch with the same pin out on the receiver side but the focbox side has 8 pin out so i cut the last pin out off so it will fit and have the 2 wires switch if that makes sense so i didnt have to potentially ruin the one that fits out of the box but have the same result if i did switch the wires but it didnt work help

Edit im not sure if its white or black but its the same other than the orange and green are switch

So have you tried switching RX and TX or not? Also please try to format your text a bit and use punctuation, its really hard to read. :slight_smile:

Yes. Not in the conventional way but yes. Also Im sorry Im horrible at punctuation and run on sentences. I get carried away with my thoughts. Im also horrible at spelling so I have to find work arounds for the word im thinking of. Auto correct only works if your in the ball park I cant sound things out. Enough about me ill try to correct that in the future.

I appreciate you sticking threw and trying to help.

Np. :slight_smile:

Is the input set up for your VESC? Because that can be an issue, as the VX2 requires no input setup from the VESC. Just go into the app settings tab “general” and set the app to use to “PPM and UART” and the raw throttle mode to “current control”. Thats it.

It would be the best if you wipe your VESC, then just do the motor detection, change those settings and save, reboot the vesc and the remote (it is already paired, right?) and it should work.

I tried PPM, PPM/UART, UART, I reset the focbox many times trying to figure it out. And clicked the A​:arrow_down: between changing those settings. Thats why I kinda think I messed the remote up some how. Also do you know how to restore the trip? Its at 99997 but literally haven’t put the case together.:rofl::rofl::rofl:

No idea how to restore the odometer, sorry. Is the remote connecting to the receiver in the first place?

Yes. The blue light goes solid. And has the 3 bars in the corner. But I think the board image should show the battery level but its blank/empty if that makes sense.

Well, at least the receiver is not broken.

Are your cables set up like this?

Don’t mind the small loop, I’m using a loop key to switch the esc on.

1 Like

Also which version have you bought? The version for V4 and Unity or the version for V6?

I only have screen shots from a video last night but I believe so. And yes im 99% sure I bought everything as a kit from propulsion boards so I assume its the right one.

okay, have you tried setting the remote to FOCBOX mode? Mine works in that mode. Also is the input currently set to PPM and UART and current control?

Vx2 is super weird sometimes, you might need to flip the green and orange wires if you can’t get it to work

1 Like