Help random cut out with vesc faults

I am wondering if I wired my mini remote correctly. I have a maker x drv4 and my son has maker x dual . Both of us experience cutouts . Usually when you release the remote and reapply it will work again but not always . Just installed metr today so may have some logs soon.
I had to splice the wires in for the mini to the maker x
Black from transmitter to maker x ground
Red from trans to maker x 5v
White from trans to maker x pwm
Yellow and orange not connected to anything

1 Like

Yeah, the wiring appears correct. I hope you’ve set the failsafe. When you turn the remote off with the board turned on, it should go to idle.

This is really odd. Is it always at that moment when the malfunction is happening?

1 Like

Yes failsafe is good. Trying to figure out what the issue is . I am thinking it might be my vesc settings but they seem to be ok. Hopefully I can see what the issue is with the metr .

1 Like

I’d raise Absolute Maximum Current to 150A

1 Like

Tb6380 max amp 80
Metroboard 10s8p 50 mile battery
Max amp 30
Raised max amp to 150a

1 Like

This interface … leaves a lot to be desired. Thankfully, there is good news.

It seems you are already successfully connected via metr.

Connect your mobile device to a wifi network that your laptop or desktop is also connected to. (must be on same LAN) In metr, go to the hamburger in the bottom-left corner and select “Settings”, then scroll to “TCP Bridge” and turn that on.

Now on a real computer with a mouse and large screen, open the variESC Tool and select Connection>TCP>Connect

Enjoy the interface that’s ten times more usable :smirk:


So the tcp bridge is just to be able to use the laptop vesc tool without connecting via usb?
Ah I see never mind :+1::+1::+1:

1 Like

This may be a dumb suggestion, but the only time I’ve had cutouts with the mini remote was when the batteries were getting low.

1 Like

You should consider putting a small bit of foam behind the springs that compress the battery ends. When the minis get dropped they are usually pretty ok, but the impact compresses the spring next to the battery and intermittent cuts can happen.

You can verify by recording metr telemetry and looking for the expected flat line in ppm signal.

Consider some hot glue or silicone to keep the signal/+/- lead secured to the receiver in your board. They can get loose and appear connected. @b264, I’d say this is the only appropriate use of hot glue on a deck, if at all. Our glorious leader, @longhairedboy, has used liquid electrical tape, which is near permanent.


Looks like faults abs over current and got a drv fault also abs fault when cutting out


How are your phase wires connected to the ESC? Do you have a photo?

yeah hot glue on a deck… not so much. Hot glue to hold a connector onto a receiver… totally. hell i usually fill the rest of the jst connctor housing on the esc with hot glue if i have to pull the pins out and solder them on due to stupid connectors being stupid.

hot glue will stick a receiver to fiberglass though.

but yeah, that’s about it. Oh and melting it over the insiode of the chargeport to keep anything from shorting on it. And also melting it across the back of the power button for the same reasons. helps keep the wires from yanking out if something dislodges, too.


I am wondering if I have shit bullet connectors since my board and my sons is doing the same thing . I had to solder all the connectors for both boards. Found one had a bad connection and replaced the contact and then the motor had a better connection

Your settings here look okay {except for Absolute Maximum Current}, but for troubleshooting purposes, try lowering Motor Current Max to 60A and Battery Current Max to 20A and see if the same thing happens. If it’s identical behaviour, change them back

1 Like

I solder them all and don’t use bullet connectors – but those don’t appear to be likely to cause this.

You did the motor detection, right?

I did do the motor detection with no problems .
You solder the phase wires directly to the vesc? I also changed absolute current to 150 with no change and then to 200 with no change

Duty cycle at the time of the cutout and abs over current seems fine. I will change vesc settings and ride now

Lowered settings and still cuts out . Seems to cut out more on braking and sets abs over current fault

Do you have a screenshot of your settings?

If you get another fault, go into the terminal and type “faults” and show us what it says. Powering off clears faults, so don’t do that.

I get a fault and it says abs over current but when I type fault into the terminal it says no fault

Where do you see that?

Powering it off clears faults, was the ESC powered off?