esk8.news esk8 calc donate now

What's wrong with this motor?

Hey Ninjas,

Trying to setup up new 5065 maytech’s. One seems to be working fine, the other one is “jumping” and making strange noises.
No matter what I tried to do, it keeps spinning incorrectly, partially stuck, making strange noises, both BLDC and FOC sensor or sensorless, none of them seems to work correctly.
Tried also changing the VESC ports, switched between 1 and 2, always this motor fails.
The other motor seems to be fine.
Any idea what could be wrong ? is the motor RIP ?

Videos:

https://photos.app.goo.gl/hyRjUPjz589TLJR37
https://photos.app.goo.gl/tDxFTd76C3cMFNQV6

Thanks!

1 Like

If you disconnect it does it spin freely. You can try @b264 test to see if it’s damaged internally. You start by disconnecting the phase wires and holding
Phase A to phase B
Try spining it
Then b to c
Then repeat once more with c to a
Lastly hold A B and C together you should feel a strong solid resistance.
If any of the spins tests mentioned above have a different result you shoild be able to narrow it down to which phase it is by process of elimination done in the test. Hooe this helps .

5 Likes

Try this first

6 Likes

Assuming the motor is Ok, I would try a different current setting for BLDC detection. Start with 1A. Also disconnect the sensor connector at the time.

Although since FOC detection also fails, maybe some thing is wrong with the esc. Try swapping the motors. And see if the fault follows the motor or not.

FOC detections works, bldc fails. I did try to swap the motors of course. But even after successful FOC detection, the motor spins incorrectly. I’ll try @b264 and @BigZwatt suggestions and see if this helps.

Oops my bad, I missed the part where you said you had swapped the motors. I went straight for the video. :face_with_hand_over_mouth:

But how can FOC detection be successful, that should have spun up motor no? :thinking:

Yes, the funny thing is that during that process it seems to be that the motor spins correctly. Could it give some clue for something ?

1 Like

See if the inductance and resistance numbers are close between the good and bad one. L and R

Without any newer info, I believe its the following…

BLDC detection fails because the detection current is set too high. (My SK36374 stutters like crazy unless i set the current below 2A). Your motor is smaller. (Cant say why the other motor handles 5A ok. Isnt 3A the default value btw?)

I still don’t know what you do with the sensors. Using them or not?
If you swap the phase wires without redoing the detection in the hall sensor tab, the motor will jump around like this too!

So

  1. Disconnect the sensors and run sensorless for now
    2 decrease detection current in BLDC and try.
    3 run FOC detection with sensors
    4(not sure if needed) run the sensor detection again?.

Since you already tried every setting, maybe the motor is haunted. Anyhow Im curious about the outcome of this :slightly_smiling_face:

1 Like

This is the outcome of the detection process.
All is well, but when doing throttle the motor jumps.
This happens also in BLDC.

How numbers compare to the good motor

This is for the good motor.

The motor resistance is different. Bad contacts or broken windings are the cause. The motor will probably detect with different values each time you run detection. These issues are hard to fix.

1 Like

Hi Trampa, thanks for the assistance !

Yes, looks like the motor is bad, it was totally new from the box.
I opened it today, but could not see visible defects, no free magnets or anything, the wires on the bottom looks solid (i need to take apart the bottom can part to see more clearly, not sure if it’s doable …) :(,
any other idea ? I’m uploading some photos.


Trampa
I run a Unity

jajajajajajajaja

1 Like

Have you tried running the “bad motor” on the ESC that the good motor spins on? I had the same “jumping” problem on a slave ESC that is partially dead. Thought it was a motor too I was getting weird values but it turned out to be the ESC.

3 Likes

^

1 Like

Which ESC was it ?

Currently I have 1 ESC which is FSESC Dual 6.6 Mini.
I tried to connect the bad motor to both ports 1 and 2 and it acts the same.
The other motor spins correctly on both ports.

Flipsky 6.6. It’s the second time I got a bad ESC from them and I’m not happy with it. Its possible that your ESC has a software glitch and you could try flashing the ESC with a discovery board or a ST-Link. But if you say the good motor is working fine one both ports then I’m not sure. If you haven’t tested the motor by hand and connecting phase wires together to see if there is jumping or resistance then I advise you to do so. Also is the hall sensor plugged in? You can also test hall sensor if that’s f uped.

I tried to short the phases and do a manual test -> looks like there is a resistance on all combos (a,b,c) - hard to tell if its exactly the same resistance though (by hand).
The motor spins fine when spinning it by hand, no cranking noises or anything inside. I also opened it as you’ve seen in previous pictures and there is nothing “special” inside.
I tried all combinations, running sensored, sensorless, FOC and BLDC. FOC detection goes fine, but the motor spins incorrectly when hitting the remote, BLDC detection fails and the motor is doing strange noises. I tried to switch the phases connectivity to the ESC as well. Nothing. Again, the other motor acts just fine - that’s what’s killing me. Perhaps it’s like a rare situation of bad ESC with a specific combination of motor characteristics - I don’t know yet. In my investigation I intend today to check the polarity of the stators in the motor and perhaps check it with another ESC I will get from a friend.