VESC Tool for Firmware 3.40

Guys, I need your help!

Long story short: I need VESC tool that supports firmware 3.40.

I bought a dual Flipsky VESC long time ago and didn’t touch it. I’m now trying to configure it
on a new e-skate, but the current VESC tool I have supports firmware 4.10, my dual VESC is on
firmware 3.40 so it can’t be configured. I can’t update my VESC since I think the last owner tried
to upload a bootloader to this VESC which already had a bootloader and now the VESC can’t
be updated.

Help me, I can’t proceed configure my board :frowning:

A bit of searching would have turned this up.

1 Like

Give this a shot instead:


Thanks, but I didn’t find there what I need.
VESC tool 0.94 have firmwares 3.37 and 3.38. VESC tool 1.04 has 3.50, so I’m stuck in-between.

I’m not sure if I’ll be able to use Ackmaniac tool since I can’t update the firmware.

Suggest you try anyway. I’ve had Ack work where newer vesc tool didn’t.

1 Like
1 Like

Unfortunately, it didn’t worked out. This VESC is bricked and its firmware can’t be updated.
Thanks anyways dude!

@RyEnd and @pookybear thanks A LOT!!!

1 Like

btw, there is a way to update the firmware even if the bootloader is AFU, but it’s pretty intense.

Talk to me baby.

Upload bootloader first. 3rd tab from firmware update then proceed to update firmware

1 Like

Hmm, what about compiling an old version of vesc tool yourself? I know it’s possible, just don’t know how but that’s what we have Google for.

1 Like

Everything you need to know is in these two threads.


Or if you have a working Vesc, use SWD method. So much easier than st link. YouTube swd vedder vesc.


Mmm… What if I try to re-upload the bootloader via the VESC tool?

Thanks, I’ll take look at that!

Haha, yeah, I’d try that first.

Using the VESC tool didn’t help. When you upload a bootloader it gives the following message, which I’m positive this is what the last owner did to this VESC. The question is if the method of using the ST-Link will help?


Right, so if that step fails, it means the bootloader is missing/corrupted and it needs fix’d. Sounds like what pookybear was talking about could work, or the ST-link method.


Alright, I’ll work on it tomorrow and will update accordingly. Thanks guys!