Vesc tool 2.0 hfi help

Ive already enabled foc plot.
When I pull up real time data I deselect 3,4,5,6 and enable dots, disable lines…
When I hit the brake it gives me a short piece of data, but it’s not letting me turn the motor and get real time data


Also once I have the small piece of data I cannot hit the brake again and collect more real time data. I get nothing, have to reboot the program to get new data

1 Like

I did HFI to my wifes board, you do not have to hit the breaks to get the data, you need to apply force to stop the motor from turning… If you follow @Deodand video, everything it is very well explained…

1 Like

but he literally presses “full brake”. Usually when i try it the motor just clicks once and thats it.


Could be that you need to disable the app.
To use the keyboard to control the motor there can’t be any app used at the same time… from my experience.


No app was used, esc doesn’t even have a bluetooth module. Keyboard works to try and spin the motor. I watched the tutorial a few times, wrote down the steps so I wouldn’t miss anything. Anyone else have any ideas?

Make sure heart button is clicked in, app disabled, no ppm plugged in etc. It isn’t faulting is it? Video might be helpful.


Did you click the Anchor or the Stop sign for the brakes? Can’t remember which but one of those engages the brakes constantly which is what you need for the tracking to pick up more data points

Wait…Thats the first time somebody says that. I don’t even remembering hearing it in the tutorial.

Not plugged in like “Pwm/ppm” cable completely disconnected from the vesc or just remote off?

1 Like

Im using a trampa wand. When I clicked the anchor button the heart illuminated. But I didn’t click on it. Im not getting any faults… @Deodand. Also no app running. @AngryTrucker yes, I clicked the anchor, when I did it gave me a quick piece of data, that stays populated on the screen and I cannot clear it or get any new data on screen.

Hi @Deodand ,

Have issue with the HFI once I turn off my remote, I can hear the HFI until I turn my remote back one.
Is there an option I haven’t seen ?

Thank you,

Is this setting something other than 0? if so it will apply braking current (if your receiver is one that quits sending PPM when off, like hoyt) which will run HFI to get smooth braking.


Yes, this setting is at 0

@Deodand Any other settings I should check ?

@ThomasL What remote do you have? Did you set the failsafe?

APS remote. If by Failsafe you mean the wheels get harder to spin once the remote is off, then yes.

You probably need to do something like this

except for your specific remote. Maybe contact the vendor if you need help, and let us know how to do it if you figure it out.

Also definitely try setting the PWM (“PPM”) pulselengths in the VESC Tool under App Settings > PPM > Mapping. Make sure you turn on RT APP on the right side first.

When you turn off the remote, the skate should coast. Anything else is dangerous.

I figured it out.

My remote PPM signal was actually moving all the time once on, from 1.6110 to 1.6250, which created some kind of issue based on the VESC PPM.

On the APS remote, there is a Trim nut to fine tune it (the remote has 2+ years), so you need to fine tune it in the VESC tool, and set the Input Deadband to match the difference between both PPM value (remote and Vesc) (in my case 20%).

No more sound coming from the board once the remote is off, I will try the HFI mode today :slight_smile:


what is the highest reasonable hfi values? Watching the video and trying to get decent plots, I have to have a run voltage of atleast 20V to 25V and a high start at like 40V.

I don’t care about the noise, just don’t wanna mess up my motors.

@b264 @Deodand

The highest I think I have done is 28V

But there are some motors which just don’t like HFI and nothing I’ve found seems to work well, except not using HFI on that motor. :expressionless:

Some motors work freaking amazing with HFI, notably the @torqueboards 6380