TelTail Lights (TTL) - Interactive eSkate Lighting System

All good, will any analog 12v rgb led strip work for the splash carve then? Honestly if the ttl module only did the splash carve it would be worth it to me lol. It looks so good I have to make it work on my board


Yup thats exactly right. The side light ports of the TTL control module have 12v, R, G, and B pins. The 12v is the positive pin and the RGB pins are the negatives for their respective colors. That is the most common format, but it is just best to verify the connections match up before buying a roll or lights.

Its great to hear you like the splash carve mode so much cause that is definitely my favorite mode too :smile:


hey @Ricco. i need a little help troubleshooting. my bluetooth wont pair, says rejected by teltail. I’m using the android app and have the module powered, green power light and blue status light. the blue light seems to be flickering quickly. uart connection is connected to a usplit shared with a davega and the davega is working normally. power to the unit seems to be there, 12v and the rgb strip lights up when i power up the board. idk, any ideas?

edit: usplit has communication lights for both modules, esc yellow flashing. dev1 davega blue flashing. dev3 ttl blue flashing


Can you send a screenshot of the exact message that pops up when trying to connect? That will give me a better idea of what is causing the connection to fail.

One thing you can try to get the app connecting again is (re)run the setup wizard. I have not run into this scenario myself, but running the wizard had fixed some unusual behavior for others in the past, so maybe it will work for your issue.

1 Like

Ok so on further investigation the app is not responding at all. When i go to connect the bluetooth via the settings/bluetooth connections i can see the teltail in the detected connection available. When i select it i get “connection refused by teltail”. And it remains on my list of available connections and unconnected.

When i open the app it is frozen and I can’t select any buttons or menus. After a short while android will pop up an “app is not responding” with a wait or terminate options. If I choose wait it just sits frozen until I leave focus and pops the same msg if I return to the app


Thank you for reporting this. Has the app connected in the past and this just started? Or is this happening on your first attempt to connect? I have not seen this issue before so I do not have an immediate solution, but this gives me some insight into how to debug.

Can you also tell me what android version & device you are running the app on?


There was an issue with one of my devices connected destabilizing the can bus connection and I haven’t finished rebuilding around omitting it yet to retest the ttl.

I have connected to the ttl module with the app previously but that was with a different uart and can bus arrangement on a test bench on a different phone… so im just putting a pin in it for the moment until i can finish getting everything else connected and connected reliably.

With the economy in shambles im down to only working 60hrs a week lol. I swear the news cycle is completely ignorant of what is actually happening in seattle. Seriously though I should be able to get some time in the next week to take another crack at it

1 Like

Ok so I messed around a bit and was able to get the bluetooth to say connected when opening the app. Attempting to read or write the first time made it time out. Sent a crash report and got this msg on screen:

1 Like

So i got it sorted! Something about the device i was using just didn’t like the ttl and a fresh install on a different device got it up and running!

Now question time @Ricco: i seem to be missing something with the remote on input settings. Only having the ttl uart connected to the vesc, can i use the remote (hoyt puck) break tap control setup? Or do i need to have the pwm signal from my receiver terminated to the ttl also?


No I thought “remote” input on the TTL was for 2 channels remotes so the second channel would switch LED modes

brake light brighten signal is from uart iirc, just like ERPM for the led modes.

Ok, so then i should get a state change when using the “flick the brake “ input option? Current I only have the txrxgnd three pin, 12v in, and left&right rgb led connections. I get good response from the leds as far as the ttl accelerometer goes in x and y modes. As well as rpm mode.

What should i be looking for beyond following the published instructions for remote setup?


Sorry I am not much help, in the setup process in the app you choose if you have a remote I think. I honesty forget how it works. We will be informed of how soon here I bet.


Hey @Pecos, it is good to hear switching devices resolved your app connection issues. For the throttle based control of the TTL system, it should work for you with your current setup. You will just need to set the Remote Config menu as I have it below.

Then you will want to set the control actions in the Controls Config menu. A simple test setup is shown below.

After writing those settings, you should be able to turn on/off the lights with a flick of the throttle downward. If the lights dont turn on/off, try increasing the duration the brake is applied. If still doesnt work, a good sanity check to perform is to check that the value for Remote X changes with the throttle on this screen.


Thanks for the breakdown, i ran into the same problem as before where the app has stopped connecting or is rejecting the connection. The app seems to stall if i try to connect with bluetooth turned off then never recovers? Haven’t nailed it down yet but the previous bug report is probably still valid.

Im going to try again tonight and go through my troubleshooting process again otherwise im going to find another device and see about getting the settings dialed before i log off of it so i can just leave it in a set and forget.

Btw a friend of mine wants to mess with the ttl and see if he can make some custom modes and mess with the addressable led modes and such, how opposed to the moding community are you on this? He was looking at the files on gethub and salivating saying he thinks he can make a more feature rich custom setting. It’s all beyond me, im more of a hardware side experience level but it sounds like a fun project to learn on. Might have to get a second one to experiment on XD

1 Like

Ok so using the app I have to uninstall it and reinstall it every time i want it to connect for it to get connected and work.

Secondly the in app control doesn’t work and the motors just click and cog a bit but no motor rotation.

Third the x axis doesn’t show anything when in the connection screen

When i use the in app remote i can easily toggle through the module controls but only with the app interface. Nothing from the remote

1 Like

1 Like

Sorry for not responding in a while. I have been very busy and have not been able to find time to follow up on your issues. I expect to have some time this weekend for some debugging though.

Thanks for all the info you have provided. It is very helpful for trying to recreate the scenario on my side.

Since I believe I recall you are using a dual ESC, can you verify that the TTL is communicating with the ESC side that the remote’s PWM is going to? Regarding the app readout, I mixed it up and Y is the axis that should be moving, but I do see from your video it is not changing either. That could also happen if the remote throttle input type is not set to “PWM” in the TTL settings, but I believe you checked that after my last response.

Regarding the TTL app’s remote feature not working, I believe that is caused by an incompatible motor control setup on the ESC. I will have to play with the latest FW and determine what settings are compatible and incompatible with the TTL app remote. That way I could specify the compatible setting on my site.

Regarding your friend’s interest in tinkiering with the code, that sounds great! That’s exactly why I had published the code on github in the first place, but just never got any interest from users to edit the code. I admit I dont really know how to use Git properly for merging changes from other contributors into the master, but I definitely willing to learn if anyone has changes they want to propose.

1 Like

No worries about the response time, no apologies necessary.

The ttl and pwm remote are connected to the same esc (secondary one btw). There may be underlying issues with the esc firmware so i am going to do another test.

The ubox 5.3 and 6.0 firmware have stability issues and threw me, and in the last tumble i damaged my puck and have to repair the pot (parts just got in today). Followed some good advice from havenever and rolled back to 5.2fw and it seems to be significantly more stable so im going to retest everything once I’ve got the puck back together. I think the 5.3 fw is complete garbage and the 6.0 fw seems more predictable to a point then is resetting to default settings randomly and dropping out one vesc fsr basically rendering it dangerous to use.

If it wasn’t for havenever running basically the same setup for months now on 5.2 stably i would have just shitcanned the ubox. Fool me once kinda deal.

Im meeting up with my friend to hash out a game plan Friday. a really powerful custom mode is what id like to work on with him - I noticed that in the custom mode x axis reaction with a constant color output, the brightness of the leds is static (on or off and not proportional to the amount of x acceleration). This was one of the things he was going to look at and see if we could tweak it a bit to make it more dynamic and possibly see if he can come up with a method to incorporate addressable led outputs with this type of mode.

are there any specific roadblocks you ran into that prevented you from having a splash carve mode with the addressable strips? I am super novice, I don’t understand the systems well enough yet to know what is feasible or not :slight_smile:

@Ricco i ran into something weird, using the usplit - ttl, metr, davega plugged into the secondary ubox uart port ( primary ubox uart is turned off when using the built in controller receiver) 12v power is disconnected and not provided to the ttl and my led strips turned on when I powered up the esc. Is the uart power connection back feeding the leds? Could the usplit be providing power to the ttl and back feeling the led strips?

Because the remote switch and reverse throttle flick and app aren’t working i was attempting to control the ttl on/off state by switching the 12v on and off. If that’s not a valid control scheme im kinda lost here. Any ideas on how to control this thing? Im tearing my hair out trying to get any one thing to work.

I can provide a momentary 12v signal, use your fob type relay, or provide a latching 12v signal. My preference would be to use a momentary 12v signal to control the module but I don’t see how to go about it

1 Like

This may be a setup issue specific to the ubox since I have tested on the two dual ESCs that I have, and in both cases, as long as the PWM is plugged into the master ESC (the one CAN forwarding the throttle to the other), then the “Remote Y” value in the app read correctly. Is this how you have it setup with the ubox?

I was also unable to recreate the crashing issue on either of the android devices I have. To debug the app crashing and pwm control issues, can you tell me what android version you are running and what ubox version you have?

This is likely a bug introduced in later FW / App updates that never got caught. I believe you are the first user to actually really dig into the custom mode, so there haven’t been any eyes on it till now lol

If I recall correctly, the biggest issue was finding a good way to implement the individual LED strip on/off functionality while maintaining the generic structure that I setup for the digital modes. It has been a while since I worked on that portion of the FW so I cant remember the exact details. But it certainly is possible to implement, just with some restructuring.

Do the strips light up very dim when this happens? It is possible that the UART tx/rx signals of the uSplit are back feeding into the TTL, but it wouldnt make sense for the strips to light up.

A momentary push button wired like in the image below can work to control the lights. That is, however, if your “remote configuration” settings are set to PWM and Momentary. Really the biggest issue faced here is the app crashing since that prevents alot of debugging and experimentation with the settings. So I hope to fix that first.