Oscillating Motor Speed/Power delivery induced wobbles

I created this thread to help specifically @Venom121212 , @Athrx and myself but I assume this problem plagues more people than that.

This happens across all dual motor I have built across Ackmaniacs 3.103, Vedder 3.62/65 and 5.1 using sensored FOC (with traction control). At approximately 80-95% duty cycle, 1 motor, generally the slave motor, will slow down or speed up seemingly randomly and then proceed to overshoot and overcorrect inducing a pretty mean wobble until I speed up / slow down. I have now tried: Changing FOC sampling rate from 20khz to 35khz with no success, lowered duty cycle current limit start to 80%, and the only thing I have left to try is using either traction control or PID gains to try and reduce the overshoot/over correction causing wildly different wheel RPMs. If I’ve missed something please point it out, no ideas are bad ideas.


Have you swapped escs to see if the problem is still there?

1 Like

Yessir, through reference 4.12, maytech 6.6s, and v4 neoboxes (They still work good :flushed:).

For me, 85% duty cycle current limit start seems to have worked
Using trampa vesc 6’s, uart remote

That made my problems just occur sooner in the duty cycle (65-75%) and I don’t really like limiting my speed more that I have to since you can lose your brakes if you go above the maximum limited speed.

I think you are taking about erpm limit braking issues. I bombed hills over 100% duty cycle and it handled it probably fine. Don’t think it liked it but didn’t cut out on me.
Setting only the current limit start lower means there is now a huge 10% buffer between absolute max duty cycle and the point from where vesc starts throttling current.

Same as thermal throttling, just that you get the power back as soon as you slow down, instead of cutting out immediately at top speed, then giving full power back at 94% duty cycle, then cutting out again…

Some seem to absolutely want that top 2-3km/hr bonus but what can i say…


To be clear, i am talking about this:


Oh I okay I’ll try messing with this then.

1 Like

Just set it at 85% on all sides, with the other changes you made before reversed to default and it’s very likely to solve every issue you have, minus a few km off your top speed

Good lord that sounds dangerous… Happy to be using FW 3.62 lmao

@Athrx talking the same thing in the crashes thread:

and @CiscoV seem to be suggesting the same type of problem in unity setup?


Caps and bold that current limit start shit for me please. Seems most stop reading right before that and reduce max duty cycle.


If that’s to me. i just pasted a url. I think the original post needs the caps and bold.

1 Like

So has this issue always been there? or did some particular firmware version introduce the behavior?

It’s been around since acks 3.103 so I imagine it’s always been a problem just more noticeable since we’re pushing our boards harder than what was possible with reference 4.12s.

1 Like

So I ran two boards for a while and I geared for torque with top speeds of 28mph - 32mph which I also regularly hit and pegged.

fw 3.65
sensored FOC mode
dual vesc over CAN
PPM control
switching frequency 20kHz
duty cycle current limit start 100%
max duty cycle 95%
Traction Control disabled.
190kv motors
10s battery
16:62 gear ratio
150mm and 145mm wheels.

I never noticed these issues. and I’m wondering what conditions lead to that differentiation. it seems like I should have triggered the issue.

1 Like

cross linking post seems relevant:


[careful not to slide off into the trampa part of that thread]

Should look up when this default value changed (if ever)

I’m still confused why this problem gets associated more with fw5.1 when this thread seems to suggest it’s been around for some time. (all time? )


The “duty cycle current limit start” setting was introduced in fw5.0

Not sure when the alluded to fixes to max speed performance happened that made that setting necessary.

1 Like

I only jumped back into VESC proper at FW5.01… I got sucked in by the lure of HFI, and I was too stubborn to back out and admit I’d made a grievous error…

but honestly Unity FW 23.46 had a highspeed wobble coefficient that we never figgered out

so there’s that

wher is ackamanic?