Noob needs help! potential hardware or software issues?

Hey all, I’ve recently purchased someone else’s DIY build. Rode it for a couple of short trips as it was, all seemed OK until I had a bad crash (not the boards fault), the board SEEMED ok after and certainly got me home (TBH major concussion so I have no actual memory of this so not 100% how it rode :confused: )

Anyway I decided whilst recovering to give it a bit of a service, tidy up and improve some wiring, reroute and add antispark connectors etc. I’ve had a play with the software side of things, basically restarting from scratch. I have a few issues and questions, and think I have the basics down, but don’t rule out absolute noob mistakes! (I’ll try stick on topic for now to keep the thread on track, unless anything becomes potentially relevant) My main issue at the moment is my patchy control via remote. It’s running 2x Trampa Vesc mk3s on a Trampa wand. I’m testing on a custom profile to limit speed and power. The 2 connection dots blink away and suggest good connection and the board responds to forward and smart reverse commands, but not so much the brake! When I release the trigger, instead of coasting, it seems to continue at its current pace, even when I brake the delay can be as much as a second or 2 before it stops which is absolutely terrifying even at low speed! It has cruise control, but was not on. Would love to know how to permanently disable this actually). Second obvious and possibly related issue is seen when wheels are off the ground. Light throttle sometimes starts up one motor and not the other, motors can also cut in and out even with a steady throttle. Video here:


esk8 motor fault finding

Curiously this freezing issue didn’t seem to present once I removed the gear drives, I re adjusted the backlash off a bit just in case, but no change. gears and motors feel like they spin solid and freely by hand.

I don’t know if its hardware or software related, so any ideas appreciated. Thanks in advance.

spec: dual Trampa vesc mk3s, flipsky 63100 140kv motors, 12s7p 21700 battery, moon gear drives Other issues/ potentially relevant info: No faults flagged in the vesc terminal section Motors are rated max current 100A online, but motor config reads them around 60A each? I did update vesc firmware, but don’t have a cable to do the wand yet, could a mismatch be an issue?

Connect thru USB and use up/down keyboard arrows in VESCtool to see if it spins fine.


Why? Only because the tool told you to? Sometimes it gives bad advice. On a board that worked, I would not start changing stuff unless you are adding a new item which needs newer firmware.

Unfortunately it’s too late now, but for others reading…

1 Like

Was the firmware updated on both devices?

Did you check faults on both sides?

To troubleshoot I’d remove the canbus cable and run motor detection through USB on both sides individually. Use the keyboard / buttons on the bottom left to spin the motor up at say 5 amps and see how it responds. See if both sides give roughly the same motor detection values. Check faults. Turn on the heartbeat and run “foc_openloop 60 1000” in the terminal until you thermal throttle (roughly 70-80C).

If all tests well, try to ride with a cheap remote like the mini to rule out damage to the wand during the fall.

Then try the wand


As a long term wand user. I think this is 100% a wand issue.

Try out another remote before you do anything else.

Also, cruise control cannot be disabled as far as I know?

Try to check the connections dots while actual riding.
Maybe try to sit on your board and ride it, with your remote as close to your receiver as possible. If this works you know you remote is the issue.

Would suggest getting an flipsky NRF or Trampa NRF with external antenna.
Flipskies need a reflash though


yep pretty much. As with most other things in life, having the latest firmware is usually the recommended course of action. New firmware often brings additional functionality, safety and reliability features. what’s the point in owning something that has the potential to evolve if you’re not going to use it. Also in this case I’m not sure it was working before I updated, like I said, it was involved in a crash, I was unable to ride so took the opportunity to use to time to make some improvements. in hindsight checking full functionality first may have been best before changing anything else, but it worked enough to get me home.

Luckily I have spare wand internals, but In this case swapping remotes yielded the exact same result. I do have a Trampa NRF with external antenna. I’ve ordered cables to update firmware on this as well as the wand just in case to hopefully rule out a mismatch of firmware across different components.

Thanks. Firmware reads as being the same on both sides. I’ve removed the can connection and run motors independently. 1 OK 1 not so much. I thought I’d cracked it when I found a pushed back pin on one of the motor sensor connections, but made no odds. I’ve now mixed and matched different components to narrow down the issue. Using keyboard controls, both motors seem to spin up just fine on one of the vescs, which in my mind should rule out a motor issue. The second vesc doesn’t like either motor. It runs motor detection and finishes with expected results. by the motor never span. doesn’t respond to keyboard controls either. this suggests something wrong with the vesc or maybe even wiring from it (look ok and continuity tests confirm connection for the sensor cable). I labelled and made sure the motor cables went back into the right coloured cables, could this make a difference though if I’m wrong? I thought not. Is there anything else i can test or check before writing off the vesc as faulty? could it still be a software issue?

Oh yeah vescs can do some whack stuff

That was my board lol.

Reset everything, restart, do detection with remote off, the sides are not communicating properly and there’s a million things that can affect that.

You’d want to put motor amps at 120 and -80 (if i remember right), then play with vesc remote ramping times until you can react safely to what the board is doing.

Oh and pull the batteries out and back in the remote as well, that one does sketchy shit overtime as it does not reboot, just sleeps. Make sure you don’t have a pcb with the green potentiometer in

Edit: one motor stopping can be related to a disconnected sensor wire somewhere as well

1 Like

except this is VESC, and this is never guaranteed


Ahh cool! you’re the original builder? might be a good contact to have then. Thanks for the tips.
what’s the deal with the green potentiometers?

Further fault finding has revealed ONE of my sensor link cables has a switched pair. black and yellow, going to “temp” and “H1” on the vesc. Initial trials suggest my problem vesc works OK with the non switched cable link, so that could very well be my issue. I’ve not touched that though, so must have been like that in the previously working board?! any reason why someone might want to reverse those 2 wires before switch them and put it all back together?

1 Like

That wire if i remember right is swapped on the trampa sensor extension cables (pain in the ass to modify), so it all works out correctly in the end. Your motor will not spin if you get the wires wrong and will show -100→ 400+°C if the temp is attached to a hall wire. Could always check with a multimeter what each wire gets. 3v+ to 1-1.1V for halls, switching as you spin the motor. Temp is a thermistor, rest is ground and 5v

I’m not sure how many hands it’s passed through by now but it seems to cause a fair bit of injuries. Everyone wants the full power straight off, spin out or forget that stopping is slower than acceleration (rwd brakes only…) and faceplant into something. Welp…

Green potentiometers are the original ones. I used to wear one out within a month each time (hence the replacement pcb’s) and a fault appears on the remote. All babied, no mud, no water, no falls, still shite. Brown ones will survive a nuclear bomb by comparison, didn’t wear one out in 6 months before sold.

Kinda miss it now tbh

Edit: just seen… vesc autodetects motors at around 60A? They were 118 and 119 when new, manually set at 120. Check the connections too while you’re taking stuff apart, sounds like corrosion

1 Like

cheers, yeah looks like you were running double extensions, and 2 of them were crossed and therefore cancelling each other out, I obviously mixed them up when stripping it. I’ve repined them and they pick up ok now, so fingers crossed.
They still reading around 60A, although I did previously get a higher number more in line with what I was expecting, so may well be an issue, seems weird that they’re both now consistent and almost identical though. All the connectors I’ve bothered to un heat shrink so far are gold plated bananas, so no way for them to corrode and connections look tight. soldering looks good too. could be corrosion in the motors themselves, I’ve pulled one of the cans back to take a peak, and there are some noticeable rust spots on the iron of the stator that I guess could be affecting it. problem is removing the loctite-ed gear to allow complete removal for cleaning. Anyone got any tips there? brute force or heat it up? Didn’t wanna risk transferring heat into the motor unless there’s a better way?

1 Like

Probably not worth pulling them apart. Depending on how you value your own time, it might be cheaper to buy a new pair and new gears, rather than pulling motors apart to find out they’re buggered, or there’s nothing wrong with them and the issue is somewhere else.

If all the connections are fine, you reset the vescs and the auto detection still shows them at around 60A, i’d be inclined to blame the vescs.
Can you show the results page off the vesc tool app?

Update: I’ve since found loose and broken connections on my sensor extension cables, so have remade the double extensions into single, more reliable extensions. This has helped with more reliable motor setup and detection as it wasn’t always picking up the sensors.
motor results below are both around the 60A range still.
After seeing a few videos of the setup of these particular motors though, they all seem to record about the same, so I’m inclined to believe that this is probably just correct. The screen grab below is from Flipskys own youtube channel
flipsky results
I’m not sure what most of the other results indicate, so can’t decipher much from those, so have to assume all ok unless anyone here more knowledgeable can say otherwise?
Controlling motors via desktop with arrow keys confirms both motors spin brake and reverse as expected with no stuttering or odd behaviour. Control via remote though is still a total mess. motors are erratic, they can start stop independently ramp up super quick and overrun on their own accord, so im still no better off in terms of usability.

Yes, your detection results are fine.
At 140KV the winding resistance would be quite high and 24mOhms and 57A makes sense.

Does it happen when the remote is right next to the receiver?
Do you have a second receiver to test?

Note: It’s still not a flawless experience in vesc tool though. Firmware reads the same, but sometimes i get an error when initiation motor detection along the lines of “all vescs must have the same firmware to complete”. Trying a second time though, works ok. seems to be a bit buggy all round still, so although I haven’t changed any vesc wiring I’m still not 100% there’s not a hardware issue in there somewhere either.
I’m still waiting on my SWD connection cable from Trampa to connect and update firmware on the wand (and NRF dongle I think), not sure if this is likely to create more issues or less though at this point.

Is there anywhere I can find previous vesc firmware versions to rollback to and try?

Thanks. I’m testing remote with dongle hanging out of the box to reduce any potential interference and remote just a couple of feet away. I have 2 remotes, (which acted the same) but only the one receiver to try, so can’t rule that out. Feels like I need double of every component right now to even begin to solve this.

1 Like