Metr Pro UNITY bluetooth module

Should but haven’t tested yet.

Edit: just tried but wont connect to focbox tool 1.3 over tcp bridge

Hopefully they will fix it soon. This is one of the best features and one of the reasons I bought.

Maybe its on my side but I doubt it. Using a Macbook with windows 10…

Edit: no my windows pc wont connect either.

TCP Bridge should work, I will fix if it doesn’t. Where do I get focbox tool 1.3?

There you go

  • Tcp bridge not working
  • Unity mobile app not able to write settings via BT
1 Like

Thanks @McErono! Please update to Metr Pro firmware 4.7

  • Unity mobile app not able to write settings via BT :white_check_mark: FIXED
  • Tcp bridge not working This actually was working, but please try again after updating and maybe describe exactly how it is not working?

thank you! will do!

on 4.6 I start the tcp bridge in metr, open up focbox tool, IP/port, connect - nothing happens. „not connected“ tried on two different win10 machines.

Never had a problem on my other build with a metr pro module but its been a while.

Unity mobile app is working now! :+1:

and TCP bridge is as well! was my fault. As I said its been a while and I forgot I had to open a mobile hotspot, silly me :sweat_smile: sorry!


Modules arrived here in Canada. Installed just now and everything seems to be working. Tomorrow will test on the road.

Thanks @hexakopter and @rpasichnyk.


Great to hear you received it now. Enjoy your ride.

Does the module work for vesc flipsky 4.12?

Yes, the standard Metr Pro works with flipsky

1 Like

@rpasichnyk Will these continue to be produced? Since Enertion will likely not be releasing the Nexus app (ever?) I am even more interested in getting one of these.

Of course, we never stopped producing those👍


Hey :slight_smile:

I’ve been having some issues with my module. It’s the unity version.

Some time after turning on my board and riding, the METR freezes and I don’t get any stats at all from the module.

Only way to get it sending stats again is by powering off the board and then on. Restarting METR app doesn’t work. Also note that the same issue happens shortly again after doing that fix :stuck_out_tongue_winking_eye:

I haven’t been riding for a loooong time so I’m not able to tell exactly when it started, however I noticed the issues started after I moved from iPhone to Android which was on the 9. August 2019.

I got the module back when it was released and had no issues at the time. I know @wapkoen have also been experiencing the same issue as me.

I’m using the V 4.12 of METR (pretty sure it used to work with that version) and V 23.45 on Unity (pretty sure I also experienced the issue with V 23.44 however I also experienced having no issues what so ever on that version???)

So basically I don’t remember updating anything so I just think it came from out of nowhere. That makes no sense though, so I must have done something lol.

For now I’ve tried updating to V 4.16 METR and giving all permissions to the metr app (only had to disable battery saver mode for that app)

Have anyone experienced the same? And does anyone know what it could possibly be caused by or any ideas on troubleshooting?

Seriously all help is appreciated :pray: I’m tired of having fucked up ride stats…

Thanks for reading till the end and have a great day everyone! :slight_smile:

Does it look like this bug? UNITY 23.44 baud 250k + PPM bug
Can you try it on the bench? Full break with remote should mess with telemetry.
Please also send logs to

1 Like

@rpasichnyk Thanks a lot! Will do all the things once I get home in about a week :slight_smile: however the baud rate was set to 115200 in the Unity app.

In the Unity app you can only change the baud rate of the external JST 7pin UART port. Not the internal one the Metr Pro UNITY is connected to.

1 Like

Just tried to do the Full break thing and the telemetry still works absolutely fine afterwards.

Don’t know if it had anything to do with my app was outdated…

Will try to replicate the “bug” and send you the logs once the whether gets better.

Thanks a lot for looking into this!

1 Like

I went ahead to try and send the logs and clicked on "extract files* as to what to do when clicking show logs. How can I change it to something more useful?