Help me solve my seemingly unsolveable problem.

I’m not sure what else to do. This issue now happened on 3 vescs (Neobox v6, focbox 1.6 and unity) and 3 sets of Motors (meepo hubs, wowgo hubs and flipsky 6374s) tested with the Flipsky vx1 and the Mini remote.

So far Firmwares i encountered with the problem are 5.01, 5.02 and 5.03.

It has NOT happened with the UnityFW as well as with Ackmaniac 3.103

Recently there was the Duty cycle current limit start debate so we had to set it to 0.85ish else it could lock the motors or something. (it plays a role later)

My issue:

After i setting up my vesc i try everything out and go full throttle on the bench. Everything works until the motors hit their max duty cycle. The trigger obviously isn’t at the end yet but when i keep pushing my motors start to crackle, it only happens as long as i push it beyond a certain level.

Best to watch my demonstration here:

It’s fine up to 94.x before it happens

The weird thing is that it seems to only happen when the duty cycle current limit start is set BELOW the duty cycle (which is exactly what we are supposed to do!)

If i set it higher, the crackling does not happen. I could leave it there but i somewhat value my life and i don’t want to streetface.

The only things changed is DCCLS (duty cycle current limit start) ,
battery current max and “app to use”

Here are the real time graphs to show what happens.

The big red and Blue spikes are when the crackling occurs.


This was my previous obervation of the behavior.

Does not happen on UnityFW.
Happens on 5.02 (detection on PC)
Happens on 5.01 but later (detection on PC)
Happens on 5.01 (detection on metr)
Does not Happen on 5.01 (detection on Vesc tool android)

@trampa

9 Likes

Sorry to those who have already read about my problem but i will not ride any of my boards until this is solved.

2 Likes

This sounds similar to the issue my buddy ran in to when setting up a xenith.

He just kept rerunning motor detection and it eventually worked he claims but I think he wasn’t can forwarding to the other half of his xenith and applying settings.

Have you been using the can forward when applying your DCCLS?

1 Like

“no” as i always program my vescs individually since the vesc tool doesn’t like pressing the can forwarding button.

Same goes for programming via metr. I do vesc 0 first, then vesc 1.

For the unity afaik can forwarding is only supposed to be used in 4wd?

Problem can my replicated when using only 1 vesc.

1 Like

Can you separate one vesc and use the arrow keys on the computer? (I think up/down is current, left-right is duty cycle and will violently accelerate so don’t do that)
I have a small suspicion on that remote…
Also show the ppm live signal if possible

1 Like

i think they never worked for me. Been a while since I’ve last tried.

on both tho? vx1 and mini show the issue

coming right up

2 Likes

I was told vesc tool treats all dual escs as 2 separate escs canned together internally and have been doing it.

Scanning the canbus using vesc tool on my unity and stormcore 60d both show up another esc.

2 Likes

Shoot, I remember experiencing the same crackling issue when under full throttle when I was setting up my direct drives a while back, but I don’t remember what fixed it. (If I ever fixed it with that exact HW combination) I think I ended up lowering max motor amps? Now that I think about it, that was with a used vesc I bought, so maybe updating the bootloader and then reflashing firmware once again is something that might work…

Wish I could help more, sorry.

3 Likes

Activate the keyboard button on the right edge to get keyboard controls. Also remotes ruled out it seems

1 Like

Yep. Only difference with unity/stormcore is some settings are shared so editing/writing one side and then scanning the other side will show the new value on both

2 Likes

i think it was the Unity tool tellling me this.

same

ok, guess it’s because of the vesc implementation.

1 Like

Same as always, Motor just stutters a few mm left and right. Motors are sensored.

up and down does nothing.

Maybe i can try the controller support

Restart and don’t connect remote (keep it powered off)

1 Like

nope

Vesc tool android? Control tab on the home page. That always worked

While you’re there go to terminal and print threads as well. Check the fault stop counter. Anything bigger than 0 means something happened

1 Like

just clicks once

E: had to redo motor detection.

Went to duty and put it at D: 1.000

so 95% duty cycle. Sound smooth with DCCLS at 1 and 0.85

1 Like

When it clicks it means another input method is connected and it won’t listen to yours. If the remote is disconnected (receiver plugged out), control method put as ppm and uart and the vesc is from a fresh restart i don’t know what’s happening

2 Likes