DV6 troubleshooting

Hi, I have this problem with my Makerx DV6. It doesn’t allow me to calibrate without updating the firmware. I wanted to update it to version 5.3 but couldn’t find it anywhere on Makerx website. They only have the PRO 5.3 listed. Tried it, didn’t work. I don’t want to update to 6.0 firmware since I’ve heard someone bricked their DV6 with it. Anyone have any ideas. Any help is greatly appreciated.


Use an older vesc tool. Or the newest 6.0 one that lets you choose the fw or so i’ve heard.

If you download the latest tool you can select the firmware version you want to install

1 Like

If you loaded the DV6 Pro firmware onto a regular DV6, you will need to manually download and install the correct 60 firmware or it will not work properly / may destroy the esc

Here is a link to hardware 60 version 5.3 for the regular DV6


can you explain how this is different to using the menu in newest VESC tool?

or was your instruction for manual uploading meant for if still using VESC tool 3.01

Dv6 isn’t on the list of available hardware. Only the pro one

thats the same problem im having

The makerx dv6 uses hw6.0 firmware. The dv6 pro has custom firmware. For the stock dv6 manually select hw6.0 firmware.


Just to tie all this info together

Follow these steps exactly:

  1. Download the VESC_default.bin file from here. That file is the HW60 firmware version 5.03 which is the correct firmware for the MakerX DV6 (non pro version). Do not run the pro firmware on the regular DV6, it will read current incorrectly and may destroy the ESC.
  2. Open any VESC tool and connect to the DV6
  3. Go to Firmware → Bootloader → All
  4. Go to Firmware → Custom File → Load the downloaded VESC_default.bin file from above. Click All
  5. Let the firmware load and reboot the ESC.
  6. Connect again and go to the Firmware tab. Verify that both sides are showing

Fw: v5.03 Hw: 60


Fw: v5.3 Hw: 60

If it’s showing anything else, or showing DV6 PRO, then start over and try again.

Both the archive download crash and the “old firmware” warning in the input wizard are now fixed in the beta tool which can be downloaded from the VESC project site for windows, android or linux. You can use the beta tool to keep firmware 5.03 on the ESC and still run the input wizard.



@MichaelWA doesn’t come on the forum too much, but I joined him on a test ride today and everything seemed good, so he must’ve figured it out. :ok_hand::joy:


Yes, apparently what I did was the same as those steps that you said. So everything is fine now. Thank you so much for your help.

1 Like

Latest issue we’re having: just connected the motor sensors, detection ran perfectly. When throttling with the remote, we’re getting some weird behavior. Any idea what causes this?


Are your sensor wires plugged into the correct sides of the esc?

1 Like

We’ve matched the sensor wires to plug in with the same sides as the corresponding motor phase wires. We actually had that issue a bit ago and swapped em.

During detection, only 1 motor shows a hall sensor… could it be a shitty connection somewhere on one of the sensor wires?

I’m assuming it could be any number of things, but the only time i’ve seen that behaviour is when the sensors were plugged into the wrong sides.

Is it possible that you passed detection but it may have just been a shitty result? Have you tried running detection multiple times?

1 Like

Yeah, we tried running it a few times, no dice…

I’d be checking all the wiring to make sure nothing is crushed/pinched/shorted.

Short of that I don’t really have a lot else to offer sorry

1 Like

Wire doesn’t show any obvious crimping or damage. Lame. First time I’ve run into sensor issues like this.

Lol lucky you. There’s good reason i just don’t even bother with them


Yeah I guess I’m lucky lol, only issues I’ve had are when they’re plugged into the wrong side.