DAVEGA X: Restarting, freezing, white screen

This is to follow up on this post. If you have experienced any restarts, freezing, or white screen, please share your experience here. Video recordings and photos are much appreciated. Thanks guys.

cc: @pookybear, @Ace, @dk-odense, @ThomasL

Also, to have some idea about how frequently people are affected by the problem, if you have a DAVEGA X and have done more than 100 km on it, please add a vote on this poll.

9 Likes

Let me start.

VESC type: Unity
symptoms: restarts, white screen
frequency: once per ~2 km travelled
triggered by:

  • shocking the VESC (going over a bump); this seems the most common reason
  • high VESC current input/output (accelerating or braking aggressively)
  • none of the above (unknown reason)

I tested several different DAVEGA X units. For most I was getting restarts. For one I was getting the white screen though.

On given ride, it seems to happen either frequently or not at all. I also noticed it happens more often in hot weather (may be a coincidence though).

The problem went away when powering the DAVEGA from external 5V supply (4 rechargeable AA batteries).

12 Likes

I just switched DavegaX’s 5v and gnd to the ppm port. Will test as soon as socal is back to its well known sunny state.

2 Likes

I posted this on the usplit beta thread as well.

DaVegaX / uSplit findings:

1st half of ride:

  • No disconnects.
  • No freezing.
  • No white screen.
  • Solid metr recordings. No interruptions.

2nd half of ride:

  • Turned off remote. Left board on. Switched modes on metr (I noticed from before when switching modes in between rides, this triggers the freezing).
  • No freezing
  • No white screen
  • No disconnects
  • Same solid metr recordings. No interruptions.

I noticed before my ride, DaVegaX had a few intermittent “red” blinks. I assume it was trying to receive signal from Vesc/usplit.

Switching the 5v and gnd to PPM port looks very promising. I will test some.more.

4 Likes

Thanks for the update! That doesn’t make any sense though. The 5V on the communication port and 5V on PPM are the same rail. At least on my focbox, there’s continuity. Either the problem is intermittent and you were just lucky on this ride, or it has to do with the connectors on your VESC.

2 Likes

Hi Jan,

For me, changing the cable did the trick. I still get sometimes the white screen once accelerating or braking, but not anymore on bumps.
Did yesterday a 35km ride, no issue until 200 meters from home, with 15% battery left.

PS: Got to send you back the package, it came back to Prague, guess I messed up the address.

1 Like

Yea. I’m not convinced about this fix yet. I’m using vesc6.

Not sure if it matters but I have the 5v and gnd plugged in to the master while its tx and rx are connected to usplit then to slave. I could try moving it to the same Vesc?

Update 2:
I went for another quick ride. Same results as my first test. No resets, freezing nor white screen.

All I did w both 5v and gnd connectors was unpin them from the “stock” housing and switch it to 3jst one to fit into the PPM terminal.

I never had trouble w the OG DaVega. It only started w DavegaX. Same setup/hardware.

Next test is to switch it to slave where all of my peripherals (usplit and metr pro) are connected.

Interesting. Could you try returning to the original setup and see if the issue has maybe mysteriously disappeared? It might have been just a bad connection. Cable not plugged all the way in or something like that.

At any rate, I’m glad it’s working for you now. :+1:

2 Likes

I’m a puzzle head. Very curious as to why it was doing it. So I will switch it back to how it was when it wasn’t working. I’ll keep you posted.

2 Likes

These results are making me think that you have found a flaw in the uSplit layout. Switching the power to the slave ESC’s PPM connector like you suggested is a good test before returning to the uSplit. If both of the tests using 5v from the PPM connectors show good results but the issue returns when on the uSplit, it will be pretty safe to say that’s the issue :stuck_out_tongue:

1 Like

I’ll post results in the usplit beta thread once I switch it back. :+1:

Edit:
@SeanHacker is not having trouble w his tho. So I’m trying to rule out user error here.

1 Like

I never had any issues in the first 100km. I probably did close to 400km before I noticed any issue.

I first noticed I would get the white screen occasionally after putting my board motors mounts down onto an escalator. But never while riding.

Then a month or two later I would very occasionally get white screen on a ride. Then it became more often, then almost every ride, then 3 or 4 times per ride. I would need to stop and reboot my board to make it go away.

3 Likes

I went for a ride this weekend. DavegaX froze twice. Yes, it is still connected to PPMs 5v.

Separate issue:
Here is one of the pic of my buddy’s DavegaX.

I have also noticed that changing battery capacity from like 90% to 100%, it freezes. Same results w changing the mAh. This is on version 1.3. I thought somehow when we downloaded the update, it got corrupted. I deleted v1.3 after we got back from our ride, redownloaded it and same results. Power cycled in between.

Factory reset and reset settings didn’t help. I’ll post more findings when I get a chance.

2 Likes

Yeah, unfortunately, I don’t think that connecting to PPMs 5V should make any difference (unless there’s something wrong with the connector). It must have been a lucky coincidence that you didn’t get the freezing before. If you could try powering it from something else than VESC (e.g. 1S LiPo or directly from the battery pack using a buck converter) that will likely resolve the problem. Anything that outputs between 3V and 5V should work.

BTW, when you say “freeze”, what exactly does that mean? Is that a white screen or the picture remains on the screen but it stops updating?

I know of memory problems and I’m working on it. In fact, I already have a bootloader 2.0 implemented where the problems have been addressed. I want to do more testing on it before I make it public but if you (or your buddy) didn’t mind being a guinea pig for it please let me know. (You can always easily downgrade without loosing the data if something is not working as expected.)

BTW, did that memory error happen while riding? I haven’t seen that happen while riding. Only when doing things in menu.

Freezing or does it throw an error? If the latter, please send the error details. I have had this reported before. I thought I have fixed it. Maybe not.

Nah, that shouldn’t happen. It’s more like the 1.3.0 is more demanding on memory so the memory errors are more likely to happen than in the previous versions.

Thanks for the report and apologies for the problems. The software issues (memory errors, bugs in changing battery capacity) will definitely be fixed. The hardware issues (freezing), I unfortunately can’t do much about. I still think this is actually a problem in the power supply, i.e. a VESC problem.

The next generation of DAVEGA will have a built-in buck converter so it will be possible to power it directly from the battery pack which should resolve these issues. No ETA for it yet though.

Yes, picture remains on the screen. Numbers are stick. Red blinking light.

Sure. I’m more than happy to try it.

Yes, it happened a few times while riding. In fact, we got annoyed power cycling it every single time so we just left it like that until we were done w our ride.

It gave me an error of “I apologize for the inconvenience. Take pic and send.” Somewhere along those lines.

1 Like

Oh, that’s actually not freezing then. It merely looses the UART connection with the VESC. You should still be able to access menu and/or switch screens at that point.

Are you saying that if you power cycle, that fixes this?

What kind of VESC is that?

Perfect. I’ll send you the files and instructions later.

Right, makes sense. If you can reproduce the problem, would you please send me the pic. Thanks!

Yes.

Trampa VESC6. OG

Will do.

2 Likes

That loss of UART connection is interesting. I wonder if it’s the DAVEGA power cycle or the VESC power cycle that fixes it.

Here’s what I can do. I can add a “RESTART” menu option that will allow you to power cycle DAVEGA without power cycling your VESC. If that doesn’t re-establish the UART connection it would indicate a VESC side problem, in which case you’d need to talk to Trampa about it.

It’s a simple update. I should be able to release it as v1.3.1 tonight.

2 Likes