WTF happend with my unity? (overvoltage error)

Used my board yesterday but a belt snapped so did a long walk of shame home but motors was disconnected. Opened the enclosure and there was no water inside (always do this) so cleaned of the rest of the board.

Today I put it back together and charged the battery (12s4p 20700b full for the first time and now I suddenly get this error when turning on my unity

but my pack is at 50v not 61?!

Multimeter measurement

What the fu have happend? Any one got any advice to fix this? Have disconnected the pack a few min with no luck.

Jason took another shit i tell you. My theory needs still be prooved but i believe this is it


that he would have implement this to activate at random in the code? Seems like a far fetch :stuck_out_tongue:

1 Like

Might have found a workaround I will try tomorrow

I hope for the best and that the input will adjust when starting to drain the battery or ells I am screwed on low battery protection lol

1 Like

Starting to piss me of real good now…
Anyone know a workaround?! Please!

@Deodand Help? What happened here?

1 Like

Just a FYI plugged in a 4cell lipo that was at 14.xx volts and it shows up as 21v.
Bumped the board on my way home so might be hardware related to if lets say a resistor came lose but impossible to say without some knowing of the circuits

Yeah seems like one of the resistors on the voltage divider to measure voltage is somehow changed? Really strange I’d take off the silicone and wipe down the PCB make sure it’s all clean.


Will do. You don’t have any info on what resistors are used for voltage dividing and what values they should be? :slight_smile: Could check them all to see if they are correct after cleaning
Good to hear that I’m not alone with this idea

Was nice and clean but cleaned it with IPA but still no change :confused: Was considering that a solder is lost but then it should not show any voltage at all. Might need to check all resistors one by one and hope to find one out of spec.

Hate that I sold my focboxes now lol

1 Like

R24 should measure 2.2 kOhm
R23 should measure 39kOhms


thank you!!! Seems like R23 is at 4mohm :open_mouth:
What resistors are these? Just messed with smd components a few times. Will se if my local supplier got in stock

1 Like

They are 0603. Can buy them here:

Are you sure on that? If raw battery voltage were going into that pin the MCU would probably blow. The GPIO pins are only tolerant to 3.3V.


if that res was very high impedance, the mcu would see close to 0V. so the mcu should be fine. change that resistor


Measured a bunch of times now and its 12mohm so definitely broken. Higher Ohm should mean that the MCU sees less volts if I’m not mistaken (rookie on this lol) so really odd that it shows 61v but might be that its so far out of spec that the MCU goes nuts. Will pick up a new resistor tomorrow they ‘‘only’’ had 9559 in stock at my local electronics shop so should be all good lol. Will report back here what happens when its swapped will do it first thing when I get home tomorrow.

Thank you all for the help so far much appreciated!

Curious to find out what happens too. Deodand basically designed that whole thing so he’s pretty qualified on troubleshooting it.


yea really great that we got him specially now that enertion have gone under.


@Deodand what does c17 do?
Seems that one blew in my unity


Didn’t help :sob: Still the same error. When measuring C23 mounted I get 3mohm now and when measuring the resistor lose it get 39kohm…

1 Like

I assume you meant R23 (not C23)

make sure it’s soldered properly, the resistance would not increase like that unless your meter is low battery or the resistor is badly soldered

1 Like