VESC Profile Question(s)

I’ve tried to read as much as I can and watch set up videos online. The VESC seems to have gone through a lot of changes / improvements in the last two/three years.

I’ve got the Flipsky (mistake but oh well) FCESC 6.6 Dual, Flipsky 6374 190kV dual motors and VX1 remote.

My confusion stems from my batteries (older Panasonic ncr18650bd) in a 12S4P configuration - per this this forum should be weak. I was planning to run them at 5 Amp continuous per another discussion. The tutorials / videos show how to run through connecting to both VESCs, in general accept the defaults, pair the remote and you’re good to go. Which I’ve done. But the acceleration is pretty dramatic as is the breaking. Generally speaking, throwing my 14 yr old son from the board… :grinning: The default Voltages from the Wizard seem high? Battery Current Max: 99.0 A. Battery Current Max Regen: -60 A.

So I’ve read to set up a profile, but the help I’ve seen is using the Android VESC Tool App. I don’t have Andoird (iphone user) and my receiver is not BLE so wouldn’t work with the app anyway if my reading is right. So I’m connecting via mico USB cable. and using Windows 10 VESC Tool.

I tried changing the Positive / Negative Ramping from the Wizard choices to help smooth out the acceleration / braking but didn’t have any impact. 0.4s Positive / 0.2s Negative.

Are there other settings I can adjust to help make it easier for a newer rider to ride?


lower the motor current and regen, so the acc / brake is weaker

also, change that batt current and regen, so it fits ur battery setup. vesc tool is stupid in this section.

do note, current type settings u do on the vesc tool is “per side”, so if u know the total cont amp of ur battery, u need to cut that in half when writing in vesc tool.


Yeah, those current settings are a little high - The vesc tool wizard assumes a much more performant battery cell than the NCR18650PF.

You should set your battery max to 10A (10A per side, 20 total, AKA 5A/cell), and your regen to -5 or -8.

Motor current should be 20-30, both max and min (brake).

The motor current affects low-speed acceleration and braking, the battery current affects acceleration and braking at higher speeds, so you can tweak these for your preferred feel.

You could probably bump the current up to 7.5A/cell (15A/side, 30 total), but I wouldn’t go much further.

1 Like

If you need a PC/mac tutorial on setup watch this video:

just make sure to use the right firmware for your VESC but they should explain that

1 Like

Yea thanks. That was one of the videos I watched but they pretty much just accept all of the defaults - maybe they changed traction control to on. But it’s a good starting point.

"The motor current affects low-speed acceleration and braking, the battery current affects acceleration and braking at higher speeds, so you can tweak these for your preferred feel.

You could probably bump the current up to 7.5A/cell (15A/side, 30 total), but I wouldn’t go much further."

That is very useful info - thank you. It’s the low speed acceleration and braking that were the big issues.
I’m planning on sticking to 5 Amps at the moment based upon a previous discussion with @Battery_Mooch as these batteries list at 10 Amps continuous but seem more realistic for 5 Amps…

The PF cells?
Yea, 5A at the most IMO.


I’m running the same flipsky esc and was advised from someone way smarter than myself to use a specific VESC version for this esc to ensure more reliability and safety long term.

I believe 3.65 is the version, I can try and track it down - but mines been running solid for a year or so now

I’m running the VESC Tool 3.0 Version Windows 10… that was the latest available online.

Ok I’ve done some digging and I just found out where I originally got these older files :slight_smile:

tool 1.28 and firmware 3.65 is what I was suggested to run for this ESC from some smart folks last year. Now I don’t recall exactly why this is the version suggested, but it works for me!

I think it was @A13XR3 suggestion per @Gamer43 testing that sent me this way?

Anywho, you may be fine and I’ve just started a mountain over an ant hill here.

1 Like

Actually, not the PF cells. These are the ones ending in BD. Not much of a difference but thought I would mention it.

1 Like

Ahh…okay, thanks.
Same recommendation.

1 Like

So I tried these settings. The back right wheel doesn’t turn when off the ground and upside down, and when on the ground no load, the board sputters and barely moves. So I’m a bit confused on what to adjust?

First, you should set the “absolute max current” to WAY higher than 50A. 150, 200, 250, basically as high as it will go. That’s the current reading at which the vesc will stop and throw an error code, so you want that to be as far away from the normal operating range as possible.

I’d suggest running through the motor and sensor detection process again, and make double-plus-extra-sure that you hit “apply” at all the appropriate points.


Yes, that absolute max current set at 50A in older versions was source of many troubles, even with all settings set pretty low to suit a 20A capable battery and low power motor. You would think that 50A was comfortable as an absolute max, but when riding over bumps or small pebbles, you could see (afterwards, in the logs) that there were some very transient peaks around 60A, and that was enough to trigger a fault in the VESC.
I suspect those peaks where due to very short transitions from motor being loaded to being briefly unloaded, and loaded again, with the controller losing its bearings trying to compute the right current to feed the motor over a few milliseconds.
Boosting that value stopped the faults, and those tiny peaks, while probably still happening, were totally unnoticeable.

1 Like

Thanks. I decided to rerun the motor set up and stick with the defaults. I’ll try to read up more on how to use this VESC tool, but the changes I was making produced horrible results… I can’t understand why lowering the values would result in one wheel not turning when powered? I can envision it spinning slowly , but not at all? Very confusing - not very intuitive to modify.

It really shouldn’t. There’s almost certainly something else going on to cause that issue.