VESC not connecting to PC when sensor wires attached

Weird little problem I am having right now. So I bought some TB motors a while back, and just decided to finally put them on one of my builds. For whatever reason, whenever I plug the sensor wires into the TB vesc 4.12, I cannot connect to my PC. If I remove the sensor wire and then try to connect, it seems to work perfectly. Obviously I would like to use the sensored motor config, so this could be a very big problem for me.

Has this happened to anyone else?

This is the circuit.
2x TB motors
2x TB VESC 4.12
2x Flipsky VESC sensor wires

Do you plug it thru an adapter or directly from the motors?

edit: ohh, I see that you do. Test those extensions for continuity/shorts first.

Check that your 5V and ground from the sensor wires is not mixed up.

i thought those torqueboard motors use a non-standard sensor pinout so to encourage you to buy a torqueboard sensor cable to connect to your esc.

you might be able to finaegle the connectors out of the flipsky plug housing and switch it around. don’t listen to me though, wait for someone who has done this to reach out

@Andy87 They all seem to be matched up (assuming they didn’t somehow mix up the 5v and gnd inside the motors where I cant see them).

@sesat Oh that would be super lame, but now that you mention it, I feel like I remember reading something about that on the old forum. I could change the order if the wires if I knew what the pinout on the VESC was.

@tipsy Okay i’ll give that a look too. I doubt it is the problem, since both VESCs are individually having the same problem, but you never know I guess.

1 Like

So you get the issue even with one VESC in the system? For both of them?

I can connect to the master VESC if I unplug the sensor wires from it. If I try to do any sort of motor detection, only the one without the sensor wires will do anything. The slave VESC fails the detection if I leave the sensor wire in. If I leave both sensor wires plugged in, I cannot connect to the VESCS at all. Only when I take both sensor wires out, can I connect and complete a detection. However, this means that I am unable to use sensor mode.

Edit: The same is also true if I reverse the master and slave.

Try setting it up like two seperate single drives with the sensor plugged in and see if there’s difference between the two sides.
Unplug the one not being used from power and canbus.

I just tried that, but the issue persists.

It should be written on the pcb usually.

1 Like

So you have the same problem on both vescs and with both motors? If yes I guess there is really something mixed up with your wiring.
Maybe you can post a picture of your setup as well? Might be helpful.

I have 2 x TB motors, 2 x TB VESC 4.12, and the TB sensor wire extensions. No problems connecting in any configuration. I seem to recall at least one of the wires switching positions in the extensions, which confused me a bit. Unfortunately the end that attaches to my motors is already sealed in heat shrink tubing. I would email TB your question. They are usually quick to respond.

i found this post where @wafflejock identified which sensor wire was which using a digital multimeter

1 Like

True true true true true, I am dumb. I looked at the other side of the PCB. Here are some pictures.

Oddly, gnd seems to be in the wrong position. the black wire from the sensor wires appears to go into an unlabeled pin instead of the gnd. The gnd instead is the orange wire.

I almost want to try switching these, but I feel like it might cause trace amounts of electrical mayhem.

Looks like you plugged the sensor wires into your swd port (blue).
You need to plug it into the red place.

I couldn’t find the right picture in a minute, but I think you get what I mean.

Edit: maybe this from the tb side helps more.

The red one should be sensor port.

1 Like

Its the port labeled P1.

1 Like

Oh man I am so stupid. Didn’t drink enough coffee today I guess. I had so many wires and other garbage around that port that I didn’t even see the correct one.

@tipsy @Andy87 @sesat @bourbon_norm @mmaner Thanks for your help! Once again the community here has proven to be awesome!

Sorry for wasting you time today! I’m going to go hide from the embarrassment in a corner somewhere now. :upside_down_face: