Vesc: Erasing Buffer Failed / Motor Detection Timeout

Hi all, I’m having issues with what seems to be one side of my Vesc.

I can update the firmware only on the local connection, but every time I try to update the firmware on the other side, it keeps saying “Erasing Buffer Failed.” Also, I’m doing this through Can forwarding because I broke the usb on the other side.

However, both sides have updated firmware at 5.3. So I tried running motor detection and everything seems to go fine, but it always times out.

The board was working just fine. No idea what happened.

Power cycle the ESCs and restart the VESC tool for starters

Are you CAN forwarding and updating individually or updating both at the same time with auto scan?


Can you tell me how to power cycle the ESCs besides turning them off and unplugging them, which is what I’m doing…

I have been updating individually. That seemed to work better. So I would select the local ESC, update, then choose the other ESC and update again. The local does fine. When I select the other, it gives me the error code.

Thanks so much.

Disconnect from power completely and wait a bit for all the caps to drain

If you only update one side sometimes that cases issues with it not being able to communicate correctly, although I think that was fixed? I always update both together or individually with CAN disconnected and only had issues with the fsesc dual 6.6 plus

1 Like

Alright, when I disconnected it, I was able to update the firmware and do a motor detection.

Now, the issue I ran into was that when I try to run the board, wheels aren’tt spinning like it should. It sputters and sounds like its struggling. It spins, but not strongly. And my davega is flashing red and blue saying its an “over current” issue.

Paste screenshots of your motor current settings screen


Here they are:

Battery Current Max looks like it hasn’t been set and 99A is unlikely to be a good setting. But I don’t think that’s causing the problem.

1 Like

suggestions for battery current max?

Show the battery & what size wires are connecting the ESCs. Or just set it low at 20A if you don’t know any details

1 Like


I would set that at 35A (+35A more on the other motor) for 70A total. It can do a bit more, but you risk sag, overheat, and shortening the lifetime.

Plus one 12AWG wire is about at its limits there

1 Like

Man, I don’t even know anymore. Now the other vesc wont even show up. Frustrated. Thanks for the help.

Maybe if you get up on the discord we can do some troubleshooting with ya!

1 Like

Cool. Thanks man, I just posted there.

I got the bluetooth working and I can upload firmware and run motor detection on each vesc independently by switching to each UART port. However, they dont seem to talk to eachother. When I use my remote, it will only give power to whichever side my remote is connected to. Any suggestions?