esk8.news esk8 calc donate now

Unity won't turn on

Well, I’m pretty sure my unity is dead.

I was riding at about 25mph accelerating very lightly when there was a sudden jerk/stop. I was able to pull back and brake a little, but when I came to a full stop my remote stopped showing battery and since opening it up I have discovered the unity won’t turn on at all.
I am using a BMS switch and not the onboard unity switch, its bypassed. The bypass key is still in fine/working order.
The unity doesn’t appear to turn on at all. I have tried 2 different batteries and neither will turn it on, there is no Bluetooth connection and no LED. I have taken off the silicone case and there appear to be no damaged components at all.

I am pretty much done with reliability issues. I fell and broke my leg when my FSESC 6.6 failed, but those were 2000km old and I was running them overclocked, so I really am not surprised one failed. I then bought a 6.6 Mini and it failed in a week. I thought “Fuck it, just get a unity” and I also replaced the motors, and now this is dead too. I felt it after it failed too, warm but really not hot. The motors were still pretty cool too.

I really have no hope I will get support on this from enertion, so given that what should I do? Is there anything obvious I haven’t tried to diagnose it, and is there someone who can repair it and won’t take 3 months?

4 Likes

Have you tried using the unity switch and bypassing BMS?

1 Like

The voltage read on the XT60 output is like 45V, and I also tried a known working 10S battery. The unity had its bypass on while i tried both, but I don’t have the original unity switch to hand. Do you think using it will change anything? I am shorting the correct pins. It had worked normally for a week.

Have you verified your bms switch is open?

2 Likes

Yes, the BMS has a connected voltmeter which only turns on while the power is on. It measures like 2V when its off, and 45 when on.

Also, I have tried a known good 10S3P different entirely battery, which is toggled via loopkey, and the unity still won’t turn on.

Yeah I was thinking of using the unity switch just to rule out that the jumper You are using is good. Just process of elimination

3 Likes

Seems like you checked the most logical options. You have any other escs that can boot up to try on your pack as a sanity check?

Ah right I should have explained, I have tried using a second jumper and it still didn’t work :frowning: I just cut up a 4 pin and made a pretty solid connection but no juice

2 Likes

I just plugged in an old hub esc to the 10S battery and its turning on, I don’t have hubs to actually hook up to it but I guess it means it IS outputting 37.5V (This is the second battery I also tried with the unity) the esc doesn’t take 12S though so I probably shouldn’t try it with my other battery.

The unity is using an XT60 -> 90 adapter which I thought may have been the issue too but its not, because the 10S battery plugs directly into the unity without an adapter.

Thanks so much for your help though :slight_smile:

2 Likes

Good mention of the adapter and ruling it out

At this point, Iwonder if the internal anti spark has failed.

Yea, perhaps a pcb level failure causing it to be always off. It does weird me out the way It broke though.
Light acceleration, then it CUT and braked a little, so I pulled back and braked, that worked, but when I came to a full stop (Just rolling, I only pulled the brake between 20->15mph) it was dead. What’s perhaps also more weird is my remote was actually still showing it was connected, but when I restarted the power it didn’t come on again. No pop or poof like my old one, and no visibly damaged components :frowning:

1 Like

I’ve just seen this single component next to a capacitor, maybe its failed? But its really hard to tell if it has, and if this would stop it turning on

2 Likes

Tried asking someone who designed, manufactured and supports the product? @Deodand

1 Like

Not my area of expertise but it definitely looks like something blew. And it’s in the vicinity of voltage contacts leads me to believe this is your problem

This isn’t out of the ordinary. I’ve had ESCs trip off from main power but they were still powered from the regen. Once regen isn’t supplying power, that’s it

Well, given this has happened a good number of times, I gotta stand firmly with @b264 on the “Single PCB escs are a bad idea” side

1 Like

Not yet, just keep buying the used OG FOCBOXes until the new single-ESC options start showing up on the market

1 Like

FTFY

2 Likes

I’m not hoarding if I’m using them. I have 4 here now and two boards that both need two. So basically, I’m out…

2 Likes