Unity, Hoyt, metr, throttle stuck on. it was "current no reverse"

I just had a weird thing happen. my board when given throttle locked on full throttle until i turned the unity off I got it on vesc tool to inspect the PPM signal… and then the problem went away.

  • I have a board with a unity and hoyt remote and metr
  • unity fw 23.46
  • have a suspect remote I was testing.

then these steps.

  1. pair suspect remote.
  2. use vesc-tool desktop to turn ppm control mode to off.
  3. use realtime app data and mapping page to test suspect remote.
  4. finish testing.
  5. pair original remote.
  6. go to ride board. realize didn’t set ppm control mode back.
  7. use metr expert mode to set PPM control type back to current no reverse with brake.
  8. fwd on remote is unresponsive. hitting reverse board takes off and stays going into the wall. ( think hoyt was in R mode. )
  9. catch board and power it off.
  10. turn board on on the bench, try again. same thing.
  11. repeat again. same thing.
  12. quit metr. connect to vesc-tool
  13. turn ppm mode back to off.
  14. check mapping with realtime data. remote was in flipped R mode and had level 1 mode enable.
  15. flip R mode.
  16. enable mode 3 on hoyt.
  17. mapping looks fine.
  18. enable PPM mode current reverse with brake.
  19. everything works fine.
  20. can’t reproduce.

What could have caused this throttle stuck on behavior? it’s a tad terrifying .

does hoyt have any kind of cruise control I could have auto triggered or? is there a vesc PPM mode I could have set wrong that could make it do this?

1 Like

@mmaner, what was it inside the puck that broke that caused Drakaina to do that same thing last year in Colorado?

2 Likes

we’ve experienced two causes: 1. the early bamboo pucks had a two prong throttle pin that was prone to breaking when dropped. Since the advent of the midnight pucks, this has been beefed up but with a really solid drop or crash, it can still break. We offer replacement parts in the online shop now. 2. the solder joint from the potentiometer to the PCB can be broken (and easily resoldered/repaired) but this generally results in dropouts rather than a runaway throttle.
Crack open the remote and hit us at hoytskate@hoytskate.com with hi res images for review/support.

6 Likes

@fessyfoo If this is the one you got with the Lacroix I can tell you that the piece mentioned above piece was replaced with an up to date one.

yes, ALL midnight pucks should have the updated throttle pin.

2 Likes

this was not the bamboo one you gave me. but nice to know pin was updated.
it’s the first one I ever got which I got through lacroix. it’s midnight puck.

what’s this break look like?

will do. thanks.
I’m unable to reproduce this now though having gone in with vesc-tool and toggled PPM mode to off and back to “current no reverse with brake”. makes me think that was somehow related.

funny bit. that doesn’t please the wife.

board shot across the room. leaving tracks. then pinned against the door and squirmed around leaving more marks. and in two spots… melting yes… melting into the vinyl tiles… didn’t discover that till we tried to clean it up. sheesh.



2 Likes

reach out to hoytskate@hoytskate.com with quality images and vid. we’ll get you sorted.

1 Like

Thanks. doing that now.

but i’m unsure it’s the hoyt at all. as I mentioned, i can’t reproduce. it’s been fine ever since.

then clearly not our fault. lolz. you know we’re here for you to either figger it out or resolve any issue with our product. And any resolution is 100% public so anyone with an issue can proactively resolve. Be well, jeff@hoytskate.com

2 Likes

Dude. Same shit happened to me a while back but with 23.45fw metr pro and hoyt remote.
23.45fw was the issue in my case

1 Like

yeah. that unity fw has a very specific bug related to throttle stuck on. fixed in fw23.46

1 Like

Yup. Thing is weird and honestly I would be scared of it myself lol

1 Like

Ok. PROBLEM_SOLVED

Metr ruled out. Hoyt ruled out. unity ruled out.

PPM mode “current no reverse” is the culprit.

I must have accidentally set things to “current no reverse” (not with brake) from the metr. setting this exactly reproduces the symptoms.

And this is simply because the input mapping for the throttle in "current no reverse " mode means you’re at half throttle in the center position

safe start probably prevented that from happening until I pulled back to full brake on the throttle.

Only allow the motor to start if the commanded power has been zero for several cycles after boot, after faults and after configuration updates

Mystery solved. I can have confidence in the board again.

Watch out for accidentally setting that ppm mode “current no reverse”. It would have been bad not to have reverse anyhow. :smiley: :stuck_out_tongue: turns out it’s worse before that.

4 Likes