Unity 'apply updated config' problems

Hi guys,

So I have been using my unity for ages with 23.43fw with no issues.

I broke my own rule and updated it today to 23.46.

This forced a new setup of course, but using my s9 and laptop I cannot write settings, the apply updated config button is clicked and just fades and just sits there. Nothing is written to unity.

Anyone had this or knows a fix please?

Also tried my desktop PC, and 2 cables, no joy.

If I knew how I would go back to 23.43



1 Like

For completeness, I unplugged the davega and its writing now.

Now to try and fix a less than perfect motor detection…


Try the detection with the belts off. It’s worked for me in the past.

the same thing happens to me…until one time it just worked after about an hour trying. one thing i did was made sure all apps were closed in the background. I don’t know if that even fixed the problem or not. pigeon logic maybe :thinking: also on 23.46


I tried without the gear drive installed and same, so stripped and cleaned the motor (red maytech 6374) as being open had a bit of crud in there, and noticed one of the sensor magnets had a tiny chip on the side, detection was better but not right.
It seems to work ok though (on the bench, will try on the road later.

did you ever find a fix for this…I’m having the same issue.

Have you tried all the suggestions above?

you could also try these settings though to me they seem to spell death

1 Like

it detects everything just fine…the problem for me is when i press apply updated config…it turns gray and hangs there.

using the app of the pc tool?

i actually have that same problem.
@EnertionBoardsUSA or @Deodand
Might be able to answer the question.
Though I am unsure if they have anything to do with the app.

I have had some luck, by reinstalling the app

1 Like

using unity UI on android phone.

1 Like

Sounds like metrPro might fix our issues.
@pookybear I know you had / have this setup.

Can you confirm if we can update our POS unities using the metr pro module?

it should work

1 Like

I can connect ok…but after setting it up when i press the apply updated config button…it hangs.

Yes I understand. I have the same issue.
Chances are this is a commutation issue.
the usual fixes are on/off the app, your phone, unity etc, uninstall the app and so on

MetrPro uses a different app / module so either way itll change whats not working

1 Like

I work around this by pressing apply settings and then read settings if it hangs until it actually applies and give the green ok at the bottom.

edit: It’ll take like 4 or 5 tries before it sticks.

1 Like

I never had metro pro on my unity. My first one was from last year. 1st batch. Sold it when I acquired vesc6s. Back then internal metr pro was still being designed. So I never had a chance to try it.

1 Like

I never found a fix, I have to unplug davega for it to take.

1 Like