Speed not increasing when increasing ERPM in VESC tool

I had my ERPM set to what I believe was 65000. This would get me 16 mph on my board. I wanted more speed, so I boosted ERPM to 85000 (confirmed by writing motor configuration then reading), yet the motor doesn’t spin any faster, still the same as before. What’s going on here? Using FSESC 4.20 on fw version 3.103 and Ackmaniac VESC tool. Is there another parameter I’m missing?

The formula for figuring out max motor RPMs is motor kV * voltage. It can’t spin faster than that unless you use fieldweakening, which has a series of drawbacks.

If you want more speed, you can change your motor pulley, wheel pulley, wheel size, use a different motor or a higher voltage battery. You can calculate all that with the calculator at the top of this site.

1 Like

That makes sense, the max unloaded speed I was getting was 16 which is close to the theoretical max of 17.4, probably gonna have to throw on a bigger pinion gear

1 Like

Yeah changing the motor/wheel pulley/gear is your best bet if you want to keep the 150mm tires.

The max eRPM setting in the esc is a limit, so increasing it beyond the kv*voltage unfortunately won’t make it spin faster.

1 Like

Don’t use the erpm limits in the VESC Tool or the ESC Tool for an esk8, those are dangerous. Use duty cycle if you want to limit the speed.

2 Likes

Why is it dangerous to adjust ERPM limits? How does the duty cycle affect the speed?

Cuts off all control — brakes as well as throttle — while the erpm limits are exceeded.

1 Like

The speed affects the duty cycle.

The current affects the speed.

1 Like