[SOLVED] Weird motor problems

Hey guys :slight_smile:

So I’ve got a problem: I’ve recently noticed a bad clicking startup on my motors… It only happens when accelerating and isn’t there when i get rolling a bit faster. Since then i swapped the hanger and put some new belts in (since one motormount was loose, but that’s another story). Conclusion: It’s not beltslip.

The startup feels like unsensored motors but they are sensored and the vesc tool detects the sensors.
Motor detection works fine.


  • Trampa 6364 136kv sensored motors
  • 2x flipshite 4.12 vescs (originally running in split ppm but now I’ve added a can-bus cable for the metr pro to work)
  • 12s6p 30q battery
  • APS mini remote
  • Trampa 2017 pro belt drive

belt is tightend and wheel pulley alinged when wheel is put on, don’t worry

These flipsky vescs have been surprisingly reliable on 12s for the last 200km’s or so

Video of the bad startup and clicking sound:

Moving windings? Is that normal?

Moving stator is not good, seems like you will need to take the motor(s) off, check how is the stator fixed on the mounting plate… Might need motor disassembly.

EDIT: Also, how is the motor mounted to the mount? Are the standoffs secure enough?

1 Like

Yeah that’s what i thought…

via the 4 standoffs around the motor pulley

@malJohann had the problem that one of inner bolts shared.
Could be a similar problem with your motor maybe.
Morpheus | Backpack MTB | Refined Commuter


i’ll check that when i get home. Could be the reason for the stator movement…

not shure if that’s the reason behond the bad startup tho

It is, your sensor PCB moves. Magnets also move. VESC goes NANI?!

1 Like

yeah just thought about that too

Moving hall sensor board with some tweezers…
Weird thing tho: the stator is not rubbing against the magnets and the can isn’t loose like in @malJohann s motor.
Also both motors have this problem and I think it’s pretty unlikely that the screws broke at both motors

Did you run the motors without the belts, to ensure it is really the motors?

1 Like

Motor detection without anything attached

Clicking still there

These screws were pretty loose…but not broken
Yeay, easy fix? Could tighten them with locktite or disassemble the motor further. What do u guys think?

So I just rethightend the screws and the hall sensor PCB doesn’t move anymore :smiley:
Now I’m gonna do a motor test to verify and then put a shit ton of locktite on these screws

1 Like

I have had that happened to me and it turned out to be a loose phase wire connection between vesc and motor “bullet”. Check all of them and make sure they’re properly seated

Edit: they can become loose even when they have heat shrink wrap insulation


Already checked that of course and actually that’s pretty unlikely because of very tight 5.5mm bullets and this fabric tape I put around them

1 Like

Haha. Yup. Mine were also tigh “or that’s what I thought” but While riding I managed to put enough strength on the phase wires that one of them became undone to the point that it was still making contact but motor would have the same behavior as yours during take offs

1 Like

Who knows. Maybe even a cold solder joint :man_shrugging:t2:

Just trying to help lol

1 Like

So I just ran a motor detection and ist sounds excellent again now :slight_smile:

Motor problem solved :grin:


:pray: I wasn’t so wrong :joy:
Glad you found the problem.

1 Like

Same screws, I’m surprised this is such a common problem.

1 Like

I always tighten and check all motor screws, from all brands…actually I often check if the whole board it is ok…for safety resons overall…