esk8.news esk8 calc donate now

Please help a noob with Unity

Hello guys, I’m about to pull my hair out trying to get my DIY setup to work, and I have run out of ideas. Hoping to get some help. I have a 12s4p 30Q battery pack, with a focbox Unity. I’m using two Flipsky 190kv 6374s and a Flipsky VX2 remote, and I’m basically stuck at setup. I have the latest Unity UI software connected via USB and I used it to update my Unity. I am unable to get my motors to spin correctly. I run the motor test, the software successfully detects my hall sensors and the motors spin throughout the test. But when I push on the remote, the motors spin in opposite directions. I tried to change the direction of spin in the software, but when I hit apply configuration, it doesn’t seem to actually do anything, this includes if I move the amps slider around. The settings don’t apply, when I press read current config they just go back to before. So I tried moving the wires around, and the motor just doesn’t spin and makes weird noises. Now I’m seeing something new entirely. The motors spin in the same direction but very very slowly, if I apply throttle very suddenly the motors would spin fast but would make very loud noises and vibrate vigorously, sometimes one motor is jittering while the other one is spinning like crazy. The HUD in the app also doesn’t detect the motor doing anything when it is spinning. I tried to only have one motor connected to see if the problem was one of the motors, but the app tells me calculation error and to measure L or L2 first depending on which side was connected. I tried to use the FocBox Tool software instead but it would not connect via USB. Says my vesc is too old. Someone help me please, I don’t know what to do.

1 Like

Wall of text, please break it up so that Mr Unity can help you.

@Deodand

2 Likes

Make sure your hall sensors are connected properly. That means at all points. Motor side, any adapter cables, unity side, even check the unity ports to make sure they’re not loose.

Also, post screenshots of your motor detection.

I imagine you’ve calibrated your remote as well? Which remote? What firmware?

1 Like

Unless I didn’t saw the update, The flipsky VX2 is not compatible with the Unity, or if it is it as to be setup in the complete unity tool, because you need to activate the UART.

2 Likes

Is is a vx2 or vx2 pro?

It sounds like you aren’t getting your configs to write correctly. You are on PC with USB connected? Have you updated the firmware? Please start there if you haven’t.

1 Like

I got the vx2 pro, it is compatible with unity through UART, otherwise the motors would’ve never moved.

I have the latest version of unity UI, 1.4 I believe. updated firmware through the app, yes USB connection.

Interesting, I’ve heard of this kind of problem with BLE but not over USB. Is it possible to try using a different PC? Perhaps you could try writing the config from the full tool then read params back and see if that is working? Once you get motor config writing correctly from tool everything else should work.

see that’s the thing, the full tool refuses to connect, as I’ve stated before. Says my Vesc is too old

Here are pictures of the program. The HUD doesn’t change when throttle is applied.

The thing is you need the full tool to deactivate the ppm and run on uart only, and you won’t be able to activate the second uart in the UI tool.

Not really, we don’t know the type of data and how the unity is processing it. And your motor aren’t really working well.

Are you using the connection tab, or just clicking on the connection icon in the right menu?

I’m sorry are you talking about the BLDC tool? There is no connections tab on that. Just Serial Connection on right hand side

wait I’m the tool here, I got the BLDC tool instead of the focbox tool somehow. Will try that and see if there is a difference.

the focbox tool is the one you want, it as a similar interface to the VESC_tool

Turns out, the focbox tool was the key to all this. My motors spin properly now, no more problems. Thanks so much. The Focbox UI app was the problem, doesn’t work at all.

5 Likes

Not sure why it wasn’t working for you sorry. Were you using metr out of curiosity?

I’m sorry what is metr? the UI app wasn’t working for me. I got the BLDC tool somehow thinking it was the Focbox tool, and that obviously did not work. But I think everything is okay now haha.

I wonder if maybe the UART remote was causing the app not to want to write config. If you ever get a chance can you try writing config on the UI without remote plugged in?

1 Like