One Motor Not Spinning After Successful Motor Setup

Hello there,

I currently am running a mountainboard with dual motors (TB 6374) and 2 Torque Boards ESC (Vesc based) and i have been running this system for about 2 years now with no problem until today when i updated my ESC firmware using the VESC Tool.

I ran through the regular motor detection (seems like the new version of VESC Tool only has “Setup Motors FOC”), and everything seemed okay since i got a successful motor detection (both motors were spinning) but when i go to test everything out only one of the motors will spin when i press the throttle.

-Yes i am connected through CAN because the VESC Tool recognizes both of the ESC’s sucessfully.
-I am not running sensored mode.
-I tried to connect the non-spinning motor to the other ESC and the motor works so i know its not a motor issue.

I made a video for a better understanding of the problem:

Any ideas on whats wrong here?

I’ve had that happen before, not sure what causes it but redoing remote calibration sometimes fixes it, reuploading the firmware on both always works after restarting the program a couple times


@ZachTetra So you think i should re-bind my remote to my reciever?

I tried uploading the firmware individually on both, but what do you mean by restarting the program a couple times?

I am using a GT2B right now, but i also have a VESC Wand i just purchased i am trying to setup (thats why i wanted to upgrade firmware to begin with)

Here is the video i made for a better understanding of whats going on:

Oh shit that’s real strange…hmmm. If anyone would know, maybe @Trampa can shed some light

Try switching which is master and slave? I’ve never seen that issue before

Are those the old TB vescs?

I’ve had this issue before having a vesc blow

1 Like

More suggestions …

  1. Check VESC ID of each ESC, make sure they are different.
  2. Make sure you didn’t overwrite both ESC with the same app parameters.
  3. Another option is to reset both to factory settings, try to reconfigure each alone, make the master control be PPM and UART while the slave PPM should be “off”.
1 Like

Manually do detection to each one alone via usb…canbus cable disconected from vescs at that time…On the vesc you choose to have the PPM, set it up…After everything, you disconnect the vescs (wait for 20 secs before unplugged)… Then plug everything back to normal, got to settings a just choose which one it is master and slave…Each time you do detections, jut down the app and open it again for each motor…

@the13thzac These TB vescs are from June of 2018

-I’ve also tried to switch between which vesc would be the master or slave and it dident make a difference.


  1. VESC ID of each ESC’s are both different

  2. What do you mean by same app parameters? I made sure the master was the master and the slave was the slave.

  3. I’ve reset to factory settings by upgrading the firmware multiple times, tried to reconfigure each alone, and made master control be PPM and UART while the slave PPM should be “off” without any changes :frowning_face:

O recently had the same issue, I just didn’t used the newest firmware. I had to check a setting in vesc tool, something like communication for both via can. Worst case you could maybe try split ppm.

@Komamtb I tried several different ones (almost 75% of them) all giving me the same results.

-Do you know what firmaware you ran to get it to work?

-And please can you send me a screenshot of where that communication for both via can would be? because i read on the @Trampa website the instructions specifies to not split the PPM communication to both VESC’s when programming.

I used Tool 1.04 and maybe 3.4 fw. Maybe here.

Or here

I was fairly frustrated, so can’t call exactly.


Just tried this and pretty sure just broke both of my VESCS…

Now i cant get a motor detection and the VESC is making an exremely loud noise when i press the forward/reverse feature in the VESC tool.

Im pretty sure the VESC tool just fried both of my VESCS. I did everything according to the instructions posted on the vesctool website. this is ridiculous. i dont even want to purchase another vesc because i am afraid if i use this software again the same thing is going to happen. i dont understand why i cant downgrade back to the old vesc tool where this was easier and i dident have to use this “FOC Motor Detection”… it just fried 2 of my perfect vescs :rage:

Well the tool can’t frie a vesc. Do you have red LEDs blinking? With these same two vescs, I sat for 3 days to make them work :smiley:


Lol today marks the 4th day ive been up past 3am trying to get this to work :sweat_smile:

But the LED’s blinking are not in sync when i was doing the detection earlier.

Now i cant even do a motor detection because it says “detection timed out”

I cant even do anything with these vescs anymore besides use them as a paper weight.

This new vesc tool firmware update bricked my vescs. This is great.

Not sure what to do at the moment as there is nothing i can do to get either of my vescs to work now. it is clearly a software issue because everything was working flawless before i did any of this firmware update.

You probably just wrote the standard parameters and deleted the motor detection. Before changing values, press READ configuration first. Then change the value and press WRITE. So try to do the detection again.

If the Wizard doesn’t work there is either a FW issue or a Hardware issue. Your devices are third party ESCs and not genuine VESCs, so I don’t know how reliable CAN works. You can check if you can log into the slave via the master, using CAN forward. If that works, the CAN chip is working.

If CAN is working and you still have trouble, you can set the IDs manually and manually activate CAN forward. You can also do a manual motor detection for each motor. No one forces you to use the Wizard.

Last thing to mention. A lot of third party ESCs don’t have a 60v tolerant CAN chip. These devices need to be powered simultaneously, otherwise the CAN chip blows up in a dual configuration.


Nope, i dident delete the motor detection, i followed the instructions on the vesc tool website step by step as you can see in the video i made above.

3rd party or not, i used these exact dual vescs on this exact same setup using vesctool 0.95 with no issues. this 3rd party vesc is from TB which is a reliable source and i never had any issues with the vescs purchased from there so we can get that part out of the way as the CAN chip functions properly.

As far as firmware issue, ive tried every single FW there is to offer but it wont change anything. I just purchased 2 new TB vescs in the meantime to see if that is the issue with hardware(although it really should not be as everything was working 100% before the software update).

Im not sure how to set the ID’s manually and manually activate CAN forward.

Also i am not sure how to do a manual motor detection with the new vesc tool binding the dual motors and this forum has no information on it either as i tried tirelessly searching for answers. the wizard was much easier before when it would say when to plug in the master and when to plug in the slave. this is extremely difficult with the lack of information on how to use the software, can you please share some details on how to do this? I am extremely worried at this point :pleading_face:

try this How to: Ackmaniac ESC Tool

manual setup is the same as the one with CAN, only that you only do 1 vesc at a time.

Turn off everything, Remove the CAN cable, plug usb in your Master Vesc, do a setup and save.

Connect usb to slave vesc and do the same thing again, save everything.

Turn everything off, connect CAN and open the tool again. But first, check if you can even set up one vesc.

1 Like


Thank you so much! One of my vescs came back to life! I used the Ackmaniac ESC Tool and it was exactly what i was looking for!

Im convinced that during the “FOC motor wizard” on the newest vesc tool software somehow broke my both motor and vesc because now one of my motors (on the same side as the broken vesc) wont spin as freely as it used to as it has some resistance similar to when a motor burns out. As well as my vesc, after setting up using the Ackmaniac ESC Tool one of the vescs had a blinking red LED rather than green. But i know this isnt from using the Ackmaniac Tool, it was from last night when i kept trying to use the FOC motor wizard one of the motor detections made my motor make the weirdest noise like all the magnets came loose or something (not what really happened but you get the idea).

In the mean time, i purchased 2 new vescs and a new motor so i can get back up and running.

Any idea on what the red LED blinking even after motor setup can be mean on the VESC?

1 Like

Not 100%. What you could do is look in the faults Tab if you see anything (or enter “faults” in the termina) Although i think the vesc clears the faults after a power cycle. Worth a shot.

have you done the shorted phases test yet?

For the RED blinking vesc, can you still connect to it properly?

1 Like