esk8.news esk8 calc donate now

New build won't go over 5mph

So I recently pickled up 4 Maytech superfoc 6.8’s from them and incorporated them into a 4wd solution. Got the build finished and all buttoned up so I program the VESC’s for my appropriate specs. Go to test ride it and when it reaches about 5mph (slower in most cases) it completely shuts off. I can cycle the power and it will go again but as soon as it hits around 5 it dies again. It is consistent and happens every time.

First thought is it’s a VESC problem. Let me back up, When I went to first program the VESC’s the firmware was on 3.61 or something like that. The newest is 5.1. After many repeated attempts (all of them ending with the VESC tool telling me that the firmware was successfully updated - it wasn’t) at trying to update I ended the evening with two VESC being updated and the other two not. I kept getting errors mainly with the tool telling me either the firmware was too old and wouldn’t run the wizards, or flat out refuse to connect to the VESC.

Today I used the VESC android app and it seemed to have updated all four VESC successfully (after several firmware read errors). I was even able to run the motors and app wizards on all four VESC’s. Yet I still get this problem with not being able to go over 5mph. The battery is 10s4p and brand spanking new, not even one cycle through it yet (it’s fully charged according to voltmeter).

I’m sure some screenshots would help you guys but which ones do I snapshot? I can’t find one that shows amperage cutoff value.

2 Likes

Fault codes?

That pretty much sounds like an overcurrent fault

Is it still sluggish without any load?
ie. Flip it upside down on a bench and go full throttle

Speaking of throttle, did you do your App Input properly? Split ppm on a 4WD can be tricky

Are you receiving any errors or fault codes? It should show up like overcurrent something something

Where in the app do I look for those?

No, I don’t get any errors while running the wizards. Both go through the run detection and throttle calibration just fine.

Throwing it upside down and going full throttle just results in the thing going full speed.

1 Like

In the app I have no clue, used it once

@Jujo doesn’t that sound like overcurrent under load?

1 Like

I don’t usually use the app either, I prefer the PC version of the tool. I like seeing more data, even if I don’t know what all of it means.

But I can’t connect with pc. The tool says “invalid port, not recognized” or some stupid shit

What battery and motor settings did you input?

1 Like

Exactly my thinking. It’s been a hot minute since I’ve run vesc since I’m still a Unity bitch, but @kchxaz I wouldn’t rule out the possibility that you might have a bad usb connection? Try a different cable and take things slow. I remember I turned off the vesc a second too soon after uploading the firmware and I had to unfuck myself

2 Likes

Stlink for the win :rofl:

10s(4p)
10.000aH
15t:36t
750g medium motors (4 x 6355)
120mm wheels
Then ran detection which passed

That doesn’t tell me your settings

For example:

Motor current max: ?? amps
Motor current max regen: -?? amps
Battery current max: ?? amps
Battery current max regen: -?? amps

1 Like

EACH VESC??

Not the cable. I use the same cable to flash custom ROM’s (firmware) on my bootloader unlocked android. Only the “best” cables can do this, so I’m pretty sure it isn’t that. I blame the USB on my lap top but with the mouse USB receiver plugged in it works fine, so that’s out, I think.

1 Like

No! I just pulled it off another post, didn’t wanna write

Fixed it

Yeah, I know. Those values are right there in the PC VESC tool (which is why I prefer it) but if they are in the app version I have no idea where they are. But the app is the only thing I can connect with right now.

Try changing the USB cable. I would not continue forward until you are consistently and reliably able to update the firmware and ensure that the parameters your setting are being retained

1 Like

If you haven’t entered any of those settings, that’s your problem. Default settings could kill your board if they aren’t what you need

1 Like