Help with Flipsky fsesc6.6 plus and VX2 Remote

I have been running this with no problem for the last 3 years. All the sudden, I installed the new VESC tool and upgrade the firmware to 6.02. Now my VX2 remote does successfully pair. But I get no motor response.

Check the app, its on UART, Played with “current and current no reverse”. Still nothing. Also checked the wiring of the receiver. Some say the orange and green wire is reversed. Tried switching that. Nothing. Has anybody encountered an issue like this? It was all working until I changed to the newest VESC tool and the newest 6.02 Firmware. Very frustrating :sob:

3 Likes

This is unlikely to be anything physical, just sounds like firmware. Are you seeing current and current no reverse in the vesc remote tab? That’s where uart remote settings are. Screenshots of vesc tool and pictures of your setup will be helpful too

2 Likes

Here are pics of my setup. I am working on a DeWalt powered mountain board that uses 6 batteries. I am currently working on custom building each battery with Molicel 42A’s. Hence 10s6p. Here are some screen shots. Thanks for your help in advance. I have no idea what went wrong.













6 Likes

did you run the wizard for the remote ?

Did you click setup input and set it to Nrf and current instead of off?

Are you certain you’ve enabled UART on the correct vesc channel? If you connect with a BLE dongle over Bluetooth, it will always be the other channel on canbus that the remote is connected to.

under “vesc remote” you’ll need to make sure that control type is selected to current. It took me a while to realise that “vesc remote” is where the throttle curve is tuned from with this remote.

I have put 6.02 on one of these, with the same remote and can confirm that it does work.

2 Likes

Tell me if this is right. Usually with this VX2 remote I never have to enter a wizard. In my experience they always have worked after motor setup. Thank you for you input.

I think it is supposed to be UART correct? Pardon my ignorance. I am not as skilled when it come to the programming. I am sure it is set on UART on the app.

I haven’t hooked up the dongle yet but I do have it for this esc. If I did it the old fashion way, would I just remove my usb cable an connect to the can side and also select UART and “current” under “vesc remote” ? Thank you.

Yes you’re right, VX2 is UART. I’m 99% sure UART is what it should be set to instead of NRF

Also correct, and I haven’t read whatever Jesus said because he’s muted for my sanity but it’s safe to assume it’s trolling.

When you say you do have it for this ESC, do you mean you own one but haven’t installed it, or that it’s installed but it’s not the method you use for connecting to it?

What I believe Tim is saying is that if you connected to a VESC (we’ll call it ESC 1) using a BT dongle, then ESC 1’s UART port must be occupied by the dongle. Therefore ESC 2 must be the one with the VX2 receiver. In that case, when you connect by BT, the ESC that shows as local will be ESC 1, and you should set the control settings on ESC 2. But in your screenshots you’re connected by USB anyway so this looks like it’s not a concern.

To make a long story short
It looks like you might be connected to the wrong USB port. Idk if that would fix everything


1 Like

Small followup; VX2s and similar are a bit of a mess to me. I’ve broken and fixed setups with VX2 and VX4 a few times and never known what caused either. If possible, try to take notes as you go for what you changed, you could fix the original config problem but have caused a new one

Particularly stuff like switching the UART TX/RX pins, that could bite you in the ass if it’s not switched back

2 Likes

When I had the same thing it didn’t work any way other than on the slave one and connecting to it not through the can, then trying “set up input” on the start screen and went through it for nrf and I’m pretty sure that that is through the uart as well.

1 Like

Thanks for the tip. I am going to have to put this into motion after work today. Funny thing is thought with this pin switching thing. I have never had to worry about that. I saw a thread somewhere that it needed to be switched for the vesc6.6 but never had to do that on the last 4 that I have had. I think I will switch it back to the original.

I see. I own the bluetooth dongle but have not connected it. I just didn’t want to throw in another element so I withheld on connecting it. Might have to try it if I can’t get anything to work. I will reconnect to the other usb port on the other side and make sure the settings are correct. Hmm… I just thought you can access either ESC from either one or the other. It is definitely worth a try. Thanks for your input so far. I hope to try this after work today.

The USB port may not be significant to be honest, you can access settings for the other VESC over CAN. Basically it’s not that you need to apply settings directly to the main ESC, you just need to identify correctly which ESC is which

1 Like

With the UART, the tx pin of one component connects to the rx of the other. The labelling might confuse some people, but tx is transmit, rx is receive. The rx pin on each device receives what is transmitted from the tx pin of the other. No firmware update should ever change that. It’s pretty much the same as serial data.

I do like the drill battery idea. I’ve been meaning on making a mini board with this method too because I often am flying for work and sometimes take power tools with me anyway.

1 Like

Tim, Mr Shiteside, It’s all good! I understand what you are saying now. You were right. I did not identify the correct vesc channel for the port. I don’t know if this is what your are saying but looking at Tim’s diagram of the vesc. I just matched up Comm1 to the USB 1. I must made sure that I was UART was selected on the correct vesc and also “current” and it worked. Argh!!! Thank you so much the both of you to help on this. I have been baffled for the last 5 days. I would like to post another day on just settings tutorial as I am still learning all these parameters. Is there a detailed description somewhere on setting the nitty gritty such as erpm, brake regen, current max? I have a decent understanding but would like to learn more.

Thank you once again, much appreciation for you fellow board members. :+1:

2 Likes

Good stuff! Yeah the details of forwarding control signals can be messy if you make one mistake, not my favourite part of the hobby

I don’t know of a specific tutorial off the top of my head. Benjamin Vedder’s YouTube channel is good, just dense. On here I think threads about VESC firmware (like when it updated to 5.3 or 6.0) might be useful, but I haven’t checked through them in a while. Then maybe just search “VESC settings” here and a few threads should show up of people looking for help. I don’t think any of them are organised as full tutorials, it’s more troubleshooting individual problems, but going over enough of them should cover a lot of problems at least

1 Like

Thank you all!

Not sure, think there is actually something I’ve seen here - good luck finding it though.

I would set motor currents to about 90 amp as a starting point. ABS overcurrent as high as it goes which is either 150 or 160.

Braking, maybe -65 amp but preferance and gear ratio play a part here, adjust as required.

I set the fault reset time to 80ms instead of the default 500, so you don’t get chucked off if a fault occurs.

Under vesc remote, I think I use exponential on those remotes with about 15% curve. Maybe 10% curve braking. I’ve found it hard to get good torque and not get over sensitive throttle at about the 40kmh mark. Also reducing deadband from 15% down to about 8% was fine for me. I’m sure a lot of this depends on the board. My board with this remote and ESC is on 97 thanes with a 2.4 reduction.

Erpm calculates by diving the number of pole pairs. I can’t remember the math enough to quote on, but it’s relatively simple. ERPM / pole pairs might equal actual motor rpm, something along those lines.

1 Like