HELP NO BRAKES! also can't detect sensors on one motor.

so on a ride one day, one of my motors started feeling like it was running as sensorless FOC, and I got worried.

after opening the board and playing around, fe-uploading FW and doing motor detection again and swapping the motors to different vesc sides, I’m just at a loss as to how to get the sensors working again. it seems to be just the one motor.
Screenshot 2022-01-20 5.23.10 PM
so idk how to fix this hall sensor issue, and I’ve checked the wire and from the outside it doesn’t look broken anywhere, and I’m not about to open up the motor.

is there any way to get a motor running without hall sensors and a motor with hall sensors to play well together? the temp sensor is still there on the motor that won’t detect hall sensors and they’re the same motor, same kv. also I gotta make sure I have brakes, and my previous fixes haven’t been working. throttle and reverse works, but no brakes, even with super high (negative) braking currents

Swap the motors left-to-right. Does the problem follow the motor?

You can manually check the hall sensors for operation by supplying 5v across the 5v and ground pins on the sensor connector, and then checking for continuity between the three hall pins and ground. They should toggle from open to closed one at a time as you slowly turn the motor.


have done that, yes it follows the motor

Rip hall sensor


that’s what I feared, but is there a way I can bodge this into working until I buy a new motor?


1 Like



idk if my HW supports it (DV6+) and I can’t seem to find a guide on setting it up, and I haven’t had much success with HFI.

HFI will run great. Tune it and you’ll be schmovin, especially with 1 motor still having functional sensors.

1 Like

I can get forward and reverse working again fine with one motor on sensorless FOC, but the sensorless motor doesn’t start up on the bench until higher current is applied, and brakes don’t work at all. when I brake on the road I can feel it trying to brake, but I get no brakes until under like 5km’h.

the braking issue is exhibited by both motors, even after fresh FW, fresh motor detection on both sides and PPM calibration

95% of the times a motor has come up as “sensorless” for me, it was a connector/wire issue, the sensors were actually fine. I have even gone as far as replacing the hole sensor wire harness with new silicone cables and crimped a new connector in place. The shitty cables manufacturers usually rig our motors with are really not designed for the abuse we put them through…for me it’s worth a shot, even if you have to completely disassemble the motor and do a continuity test on the sensor wires.

1 Like

If you want to run the motor sensorless you have to do a sensorless detection again, that will fix some of the problems. HFI works pretty well, for ASS you need special sauce OG VESCs from Trampa for it to work perfectly, or so I was told.

Also open the motor up and check what’s broken, mostly it’s just a cracked solder joint or a ripped cable. And if you fix it, dump some epoxy on the connections, or at least some nail polish.

1 Like

What about my brakes?

I can get forward and backward working fine, I’ve done sensorless detection.

I just want my damn brakes.

1 Like

I’ve checked the cable all the way to the motor, I don’t have the means to be opening up motors though (mostly the upper body strength)

so I got 5.3 installed thanks to @jaykup 's custom file. motor detection went about the same as on 5.2, ppm calibration too. it seemed like the brakes worked on bench, but then I held brake and tried to move the wheels, they make a really gross loud whine and move pretty easily, but stiffer than unbraked.

WTF, fresh FW, fresh detections, I’ve checked all the connections for a bad solder job or disconnected plugs, idk what this could be.

I just want my brakes back.

1 Like

What input mode is it set to? Have you tested others?

ppm, other what?

I mean Current Bidirectional, Current Smart Reverse, Current No Reverse w/ Brake?

Do they all behave with the same problem?

Also have you rolled the firmware backwards?

smart reverse has no brakes but stutters like it’s trying to brake, reverse works but only under a certain RPM, tested that on the road

current no reverse with brake makes the horrible noise when braking and manually moving the wheels on the bench

I have yet to try bidirectional or duty cycle, I guess I could give up regenerative braking for safety

On a board, you only have regenerative braking so I’m not sure that’s sustainable.