esk8.news esk8 calc donate now

Hall sensor issue : need help

Hi,

I keep getting “Sensor detection failed” with two TRAMPA VESC 100/250 and two QSMOTOR 2000W Mid Drive motors (ETOXX PSYCHOFRAME set-up).

I changed sensor connector on both connectors, like that :

I took care to solder red, black and white (temp) wires together. I know it doesn’t matter for other wires but I matched the wires of same color anyway.

Motor detection works but I get a hall sensor error for both motors.

Motor temperature sensor gives the right temperature so I’m sure I didn’t mess the temperature and also the ground (black) wires. Please @Trampa confirm I can consider ground is OK too?

It failed first with 3.3V as sensor voltage (factory setting). I tried with 5V and I got the same error.

I can’t figure what kind of soldering mistake I did for both motors!? @Trampa did you have reports of sensor trouble with VESC 100/250 recently?

Jens from E-TOXX didn’t have this kind of trouble and he’s used several QSMOTOR motors.

As you changed the dip switch from 3.3v to 5v it’s not the issue, but the vesc6 I received some weeks ago had the dipswitch in middle position between 3.3 and 5V which did not detect sensors at all. Might double check if the dipswitch is fully in the 5V position.

1 Like

Thanks @Andy87! Actually I’m not sure, is it good this way for 5V or I should push it further?

1 Like

had the same issue on some motors a while back

5v had to be all the way in. had to push really hard

1 Like

Thanks. Looking at the photo you think I should move the jumper further? I have the impression I’m going to break it if I push more…

@Trampa I tried to install FW5.3_BETA51 with VescTool 3.01, mac build, through USB.

Firmware didn’t change and remained 5.2 in spite of the update.

Now FOC detection doesn’t work at all. It does nothing… No noise. No turning motor.

Maybe the Vescs are bricked I don’t know… What a mess… :roll_eyes:

2 Likes

Had this happen with some ESCs that came without a bootloader from the factory. Flashed the bootloader, then the fw again and voila!

2 Likes

Looks about right to me, but Frank can tell you better. Never owned a 100V vesc.
If FW does not update it could be missing bootloader.
If your vesc is now bricked, try to flash via swd port from a work vesc or vesc based esc.

In case you don’t get the sensors to work, you could try your luck with AS5047 encoder. Shouldn’t be too difficult to integrate.

1 Like

I think I can not say “bricked” because I can connect to both of them with USB. But it doesn’t want to upgrade, and having tried to upgrade them has made FOC detection no longer work at all.

I’ll try to inject the bootloader to them. But I remember last time I had to do things like this on a “ESC based on VESC” (because I hope Frank is going to read me :laughing:), it was not very fun.

@Andy87 if you have a VESC6 what do you think about the position of the jumper (photo above). Shall I push more towards 5V? I should make a poll!

1 Like

Bootloader takes like 1 second to install through the firmware section of vesc tool. Don’t worry about that.

2 Likes

You should actually solder, those things you used are not good

4 Likes

You are right bootloader was missing and it was no big deal to fix :relaxed:. I could upgrade and then downgrade to 5.2 as 5.3 did not improve my FOC detection problem but its VESC Tool looks like the Android app on a bigger screen. Thanks for your contribution!

Tomorrow it’s decided I push the sensor voltage forward 5V to death.

If it doesn’t make it then I’ll send those solder tube to hell. I did read they are bad for big wires, but good for small wires.

Solder seal connectors will work. I use them in this instance all the time without fail. That’s not to say that they dont require proper installation. If you dont flow the solder well enough you’ll have problems.

2 Likes

Switch position looks good. If you not sure I would move it to 3.3V back to see what force you need to bring the switch in endposition.
Don’t break the dip switch :wink:

1 Like

You can measure the voltage on the pins. If you read 5V, you are good.
Maybe you need to swap cables over. Hall 1,2,3 are simply mixed up?
Your temp probe should be wired into TEMP and GND!
The TEMP wire should not be soldered to V+!

You can also try VSS, the latest sensorless startup method!
It still needs the temp probe to work! If the motor is salient, it should startup without Hall probes nearly as good as it would with with Hall probes.

1 Like

Thanks for your help Frank @Trampa!

Ok I measured 5V on the pins, jumper position is OK.

What I meant about TEMP/GROUND is : temperature sensing is OK. So TEMP wire is OK. Can I conclude GND wire is OK too. Differently said : does temperature sensing only need TEMP wire or it needs both TEMP and GND wire.

I can do FOC detection with whole sensor JST-PH off or with sensor JST-PH in but TEMP pin off. In both cases, hall sensors are not detected.

Jens told me he had to remove TEMP pin to be able to perform FOC detection. I think that is due to a FOC detection bug of the VESC-Tool software : it resets motor temperature sensor type to NTC before detection, even if properly set before. QSMOTOR mid drive temperature probe is a KTY83/122 and it gives a temperature of more than 100°C if motor temperature sensor type is set to NTC. It makes the whole detection procedure fail, and then VESC makes rainbow flashes until motor temperature sensor type is properly set again.

Yet, Jens succeeded in detecting his motor sensors, what I can not…

The wizard would rest everything back to default before detection, so you can unplug the temp probe if that causes issues. The temp probe is basically a NTC, PTC, KTY resistor sitting in between TEMP and GND. So by default the temp probe is only wired to TEMP and GND.

Is the motor spinning during the sensor detection procedure?

Yes with sensor JST-PH unplugged or with sensor JST-PH plugged but TEMP pin out, FOC detection makes motor spinning.

But in the last case I get a hall sensor error for both motors.

Oh yes I see you have to choose NO when you’re asked before detection if you want to reset VESCs to their initial state.

I switched to FW5.1, after testing FW5.2 and 5.3, and with FW5.1 I detect sensors on one of the two motors !

@Trampa how can it be possible?

Did you try the very latest beta? That has a major upgrade for a better motor detection.

Motor has 0.0uH inductance. That can’t be right!

1 Like

Thanks for your help!

Yes it didn’t work. 5.3, 5.2, 5.1 : only got hall sensors detected with 5.1 (but for only one motor).

Yes I was suprised by that… Is Inductance affected by hall sensors? Other values are similar for both motors. What does it mean?

I killed my Amass AS150… It worked about 10 times but now it sparks everytimes. I ordered new AS150 male connectors to be able to perform further investigations. :sneezing_face: