Flux linkage fail.

Anyone help a super frustrated guy who’s about to take a hammer to his diy setup and bin the lot?
Totally new to diy esk8, but know super basics.
Never used the Vesc tool before.

Ok, I was setting up my motors(racestar 140kv 5065) in the Vesc tool and the first time it ran fine in motor detection. Was success. Then I had issue pairing remotes. Eventually got one to pair(vx2).Then the motors wouldn’t spin, just made a low powered thrum and barely move the wheel. Ran detection again, but now it’s constantly saying Flux linkage detection failed. Why is this and how can I remedy it?:man_shrugging:t2:

1 Like

Have no fear human, we are here to help!

  1. what esc are you using?

  2. do you have any extensions/adapters between phase or sensor wires?

  3. if you swap sensor wires left to right, does the issue follow the motor or the esc port?

A quick motor check can be done via this method:


Hey bro! Im the guy that linked you here from facebook.

Lets help him out so he doesnt go back into facebook DIY land


oh lord


Check you battery voltage cutoff settings, it may not be the culprit but it’s happened to me before.


Hi, thanks for the info. I’ll give those tests a go soon.
1.I’m using a new fsesc 4.20dual plus.
2.I’ve got bullets for the phase wires, which I’ve already tried to re-solder, thinking I could’ve had a bad connection. And I had to splice the sensor wires from a 5 pin to a 6pin adapter.
3. I don’t see how this would do anything as both motors are acting the same when I run motor detection, high pitch whine, low thrum, small movement, then failed message. I’ll try take a video if that helps…

1 Like

Are you using the uart port or the ppm cable with the remote?

I had problems with flux linkage detection once, and reflashing the bootloader and firmware fixed it for me on a Makerx ESC. Not sure if the issue was due to me having some bad settings that I somehow set and afterwards couldn’t find (don’t think so, but who knows maybe i forgot to hit the read settings button once and wrote something incorrect). Or maybe it was just the usual makerx bootloader problem (they ship their ESCs without the correct bootloader installed). Reflashing bootloader and firmware fixed it for me, that’s like a full reset.

1 Like

1 Like

Using the uart. Didn’t come with anything to mount to the ppm… :thinking:

Is that possible to do with fsesc? I am still quite green when it comes to the terminology used with Vesc tools etc. Figured it would be more straightforward, but seems my luck these things is always hurdle after hurdle. Shit works in the end but it’s always the scenic route, that ain’t too scenic.

Make sure you are uploading the correct firmware and bootloader. Uploading an incorrect one for your hardware will probably brick your VESC.

With that said, yes, it’s possible to do on every VESC. To reflash the bootloader go to the firmware / bootloader tab, select the right version of the bootloader (If you see multiple, you either need 4x or generic for your flispky 4.20, but I don’t know which you need, sorry). After you uploaded the bootloader, wait for a bit and then reboot the ESC. Then to reinstall the firmware, go to the firmware / included files tab, select the correct hardware version (sorry I dont know which HW your flispky is), click on the VESC_default.bin on the right side and upload the firmware. Do not switch off your ESC until the lights on it go off and then come back on.

With all of this said, reinstalling the firmware should be enough for you I think, I don’t think you need to do the bootloader. There probably are other ways to reset the ESC too, I am not a vesc tool expert either. I am just telling you what worked for me.

I’ve heard of weirdness with motor detections ran AFTER the uart remote is setup with that remote.

Try running motor detection with the remote set to no input/not plugged in and see if it’s back to normal for my sanity’s sake.

1 Like

Tried putting app setting to ‘no app’, if that’s what you meant… And unhooked the uart. Tried uninstalling and reinstalling the Vesc tool to see if I could recreate the first success. Nada… :man_facepalming:t2:

Oh you bloody legend… Totally disregarded this earlier, thinking, I haven’t tinkered with any settings. Went to the voltage cutoff and was at 34 or something. Set to defaults and I got 1 motor spinning in detection. So that’s a start. Gotta figure out why the other one isn’t spinning…

1 Like

Just swapped 2 phase wires around and success with both. My faith in self ability for diy had been restored again! Cheers folks. :joy: :+1: It’s always something so simple one overlooks in frustration huh… :thinking: DSC_0061|281x500


Huzzah! @JoeyZ5 with the save!


Mhhh. AFAIK has the flipsky 4.2 a build in ppm cable…
You should reinstall firmware on the vescs and do the motor detection WITHOUT the remote plugged in. That should work…then plug in the reciever to ppm, and start calibrating the remote. Reinstalling vesc tool on your pc doesnt change anything
Welcome btw.

1 Like

Nah I think I may have found the fault. The battery was at 23.5v :man_facepalming:t2: don’t know how that happened seeing as before my refit, 6 or so weeks ago, it was at 38v or so. Hasn’t shorted as far as I know seeing as all cells are charging again now, and seems to be balancing out OK. Time will tell… :man_shrugging:t2: :sweat_smile:

1 Like