Flipsky VX1 / Focbox Unity signal issues - fluctuations, full acceleration and braking - advice needed

Hi, I just posted my 2018/2019 build here.
I have a Flipsky VX1 remote I just installed on a Focbox Unity, to replace the Nano-X after breaking a charging port.
I’m having a pretty serious issue where if I leave the board/remote turned on for a few minutes, the motors randomly spin up as if false signals are being sent from the reciever. Obviously very dangerous if this decides to happen while riding, so Im sidelined until I figure it out.

I would really appreciate the advice from the forum on potential root cause before I end up buying more components, I’m self thought on electronics and not an expert, so get out of depth relatively quickly. I’ve searched here and other forums on this, but I dont want to derail them as they are old or not close enough.

I have some pics and vids to show it better. Again, thanks for those that take the time to help.

Current pic of wiring. I repinned the 7-pin to feed into the Unity’s 3-pin PPM plug for “Signal/5V/Ground”, and have double wiring diagrams and connection. You can see I wired the battery “Voltage” signal to a 2-pin JST output of battery on the Unity.

The video below shows the issue best. It is a screen recording on my phone of the Unity app, plus a little video in the corner that shows me trying to focus on the Unity “Signal” LED or VX1 remote. You will hear the wheels spin up in the sound. I’m not sure if the video attachment works so here’s a Google Drive link to video also.

  • 0 seconds - thats me giving the controller a full run of throttle/brake. I dont touch the throttle after this.
  • 5 seconds - These signal fluctuations of -45%/-61%/etc are not normal, and just happen to be mostly braking so the wheels dont spin. If things were behaving OK, this fluctuation would hover around +2%/-2%
  • 27 seconds - You can hear the first blip of the motors here after a positive jump to around 18%.
  • 35-57 seconds - All the time here Im not touching the remote and it is powered on by the board. You can clearly hear the motors spin up here several times plus several long positive signals. Also in the small circle video, it is hard to see, but the Unity’s “Signal” LED is constantly flashing or fully on with these fluctuations.
  • 59s-1:03mins - thats me again giving full throttle/brake.
  • 1:05-1:22mins - Same issues happening again.
  • 1:24min - you can see I turn off the controller here, and it does not seem to have any effect on the continuous erratic fluctuations.
  • 1:34min - you can hear a final blip of the motor here again with the remote powered off.

Thanks for reading this far. Apologies for any noob mistakes. Do I need a new controller? Any recommendations for a reliable controller?

1 Like

Aside from the USB port breaking, did the Nano x give you any weirdness like this?

Did you re-run input (remote) calibration/config when you got the new one?

Do you see the remote dropping signal or showing full strength when this happens?

What is your deadband input percentage set at? This controls how large a spot in the middle of your remote throttle gives “dead” or no feedback.

1 Like

Tried flashing VESC fw (latest), and re-doing motor, battery and input configs - including setting deadband and full throttle/brake calibration?

Thanks for the replies!
Aside from the USB port breaking, did the Nano x give you any weirdness like this?
Great qn, didnt want to make the original post too long. I had two issues, that I used to think were human error, now Im not so sure:

  • one day I turned on the board, and 1-2 mins later on the street I turned on the Nano-X remote. The wheels spun up to full acceleration, the remote on or off didnt do anything. I had to power off/on the board to reset it. I thought it was a one off where maybe I started the Nano-X with the throttle full on.
  • Had one fall on the board once after accelerating up a hill. Again, thought it was human error where I gave the Nano-X a jolt with my thumb (as its not the most ergonomic), and then I started losing balance. But with latest symptoms not so sure.

If I had to say, I dont know what caused the first one above, and the second one was human error. But if its setting off warning signals in your opinion, please let me know.

  • Final issue I dont like, is recently when I charged the board with a charge only BMS, I have to redo the motor setup on the Focbox.

Did you re-run input (remote) calibration/config when you got the new one?
Yes, Ive done it several times. And again, if you check out the video above, the % bar only jumps from +2% to -2% max when it is normal. When this issue starts happening, and I login to the app, the % bar is going crazy as in the video.

Do you see the remote dropping signal or showing full strength when this happens?
OK, so the indicators I have are (a) the % bar in the app as per the video above, and (b) the “Signal” LED on the Unity, which I also try to show in the little circle in the video above.
In terms of (a) the %bar is fluctuating erratically as per the video, and it is not like that when normal.
In terms of (b) the signal light is almost always flickering a little, even when its “normal” and fluctuating between +2%/-2%. But I do see the signal light stay on a lot more when it is acting erratically.

What is your deadband input percentage set at? This controls how large a spot in the middle of your remote throttle gives “dead” or no feedback.
I had to check just now, but the Unity app doesnt have this setting. I understand what it is, but I dont think it will fix the issue. In the video above, the +100%/-100% represent the full range of the remote (from approx. 0.92ms to 1.92ms). When the board is behaving “normal” and Im not touching the remote it is at most + or -2%, but when the issue is present (as per the video) it is jumping to -60% or +60% or more. Finally, even with the issue present, if I move the remote throttle, it does have an effect on the signal, but it doesnt stop the issue.

Tried flashing VESC fw (latest), and re-doing motor, battery and input configs - including setting deadband and full throttle/brake calibration?
Tried most of these several times including inspecting connections. I have not tried flashing with the firmware again. It currently has 23.46 which I believe is latest. I have not tried deadband settings but I cant seem to find them in the Unity app. I will check again now.

Nano-x is infamous around here for performing terribly and/or oddly. I myself am one of those folks. Apparently you need to throttle up and down on the Nano x remote to program the failsafe EVERY SINGLE TIME or it will go bananas like you experienced.

Here’s a fun gif of my first board and ride ever with the Nano x remote:

So we’ll toss the Nano-X for a minute since it is already not a strong data point.

I thought the flipsky remotes screen maybe had some vertical bars that showed remote connection strength like on cellular devices. I could be wrong.

Is this the same case if you never turn on the remote to begin with? I.e. Will the unity still show jumpy accel and braking after being turned on with the remote off the whole time?

Unfortunately this is a known problem with the unity. It doesn’t correlate to being fully charged or anything, I’ve had it forget it’s settings while stopping for a beer once. It’s super annoying and is one reason I changed to vesc official FW and not the unity 23.46 branch. For all other cases, I prefer 23.46 FW because it has been more stable for me ride wise. Pros and cons :confused:

Now as for what to do next… I’d check the wiring on that ppm cable super duper well. Continuity checks while unplugged to make sure there are no breakages, 5v measure on the positive rail, all connections are being made and solder points on the remote receiver board are in good shape. I’d try unplugging the one positive wire that tells you battery voltage (going in to V on the remote receiver) as well just to see if any magic happens.

Keep us posted and good luck!

OK, firstly, your response is magic and has made me realise why I enjoyed the build (and community) in the first place. You’ve got some nuggets of info below (unrelated to my issue, but on the Unity and Nano-X) that have cleared up a lot of small doubts in my mind. I don’t hang out with an eboarder community here, so I have a backlog of issues in my brain until Im talking with someone who speaks the language.
I reflashed it today with 23.46 and same difference, issue still starts happening after a while.

To your points @Venom121212:

  • Agreed on discarding the Nano-X comments, but a breath of fresh air to have someone with experience acknowledge known issues.
  • The Flipsky VX1 has a single led for signal that is either solid or flashing slow/fast. I’ve checked this, and it is always a solid light (i.e. good signal) with or without issue. Ive done a sanity check by walking away from the board to see what a bad signal/no signal looks like.
  • Yes, I checked today and its the same case if I never turned on the remote, or had it on and then turned it off when the issue starts. The Focbox Unity app continues to show the signal bouncing positive and negative way beyond an expect 2-3%. I will say that it seems to be mostly negative when the issue starts happening, which hides it as it is a braking effect, and then after a while it gets worse and fluctuates in both directions to an extent that it is engaging and accelerating the motors.
  • Again, kudos for clarifying this simple known issue. It really doesnt bother me, and the Unity is such an incredible build with its own FW and the app.

Regardless of this post, I think the writing is on the wall and thanks for the checklist:

  • recheck PPM cabling with meter for continuity and 5V power
  • open controller and check all solder points and cable connections
  • eliminate the Voltage wire from the equation

I have two original Focboxes that I can use to try and eliminate if its the Unity versus controller, but involves some reassembly and firmware setup, whch all takes time! I will probably go the lazy option before I get to this point and reach out to Flipsky. Interesting side note, I actually visited the guys/girls at Flipsky back in 2019 outside Shenzhen, when working on a startup. Very humbling experience and people that are definitely punching above their weight and hungry for business. I do like the ergonomics and simplicity of the VX1, so I might give them a second chance.

Im open to suggestions on any similar controllers that I could consider if I am going to fork out for another one, and Flipsky dont cut me any deal?

1 Like

I have built several boards (5-6?) with VX1s and so far no problems for the ones that worked…but one had a DoA receiver. I realized you can actually just order the receiver on its own, paired it and bam, working like a charm. However I would strongly suggest to just ditch the pins and solder high quality silicone wires directly to the receiver…I wouldn’t trust simple pins with something as critical as the throttle.

Good luck and welcome!

1 Like

Good advice, and agreed on how critical this needs to be given what its controlling. Also, I dont like the right angle turn between the reciever and 7-pin connector.
Just to help me speed this up, would you mind confirming the following:

  • no need to modify the remote in any way?
  • solder direct to the reciever for my 3 PPM cables with some high qual. silicon wires?
  • What gauge do you recommend for this wire?
  • Cover individually with heatshrink I assume?
  • keep my 3-pin JST for the Focbox side of the connection (or buy a new connector or solder direct there too?)
1 Like
  • No modifications to the remote, at all
  • Exactly
  • I use AWG 26
  • I shrinkwrap the whole thing, keeping solder points tidy and getting the tip of the cables through the holes if possible
  • I’ve had no trouble with the JST on the ESC side, I usually keep that one (a lot tighter)

Cheers and let us know how it goes!

What I would have done from this point…

-check for loose pin connections

-Disconnect the voltage measurement wire from unity. (Do you really need it anyway?)

-connect the receiver over UART instead of PPM and see if that helps.

If the issue now still remains while your remote is off, you likely have a bad receiver.

1 Like


  • I like the simplicity of the 4 leds on the Flipsky VX1 to show battery charge. (and it can also switch to show the remote battery charge). Its definitely more practical than having to open the app everytime to connect and check battery level (which is the only other charge indicator I have). But of course, not at the cost of it interfering with the controller!
  • Annoyingly this means buying an 8-pin JST for the unity, as the VX1 comes with a 7-pin for UART. I thought I read somewhere that UART is not recommended for Flipsky VX1 to Focbox Unity, but I cant find the reference now. Can you (or anyone) confirm the Flipsky VX1 and Focbox Unity can be wired up via UART? If it can, I will buy some more parts and test that out also I guess.

Thanks for the additional comments.

You can plug the 7pin connector to the unity. Just make sure you have the pinout correctly.

I also read that people use PPM instead. I dont know what the issue would be using uart. I have been using vx1 over UART all the time with various escs without issues.

Im putting a unity in my board now and will run UART. If any issue will appear with this configuration I will answer myself here later.

Doh! Cant believe I didnt try this, Ill check it out when I open it up. Thanks for the info. This is definitely an easy additional sanity check. It’s on the list.

I will come back with results here.

1 Like

Come back - I summon thee !

Having the same issue, so . . .