Dual motor setup - intermittent single motor only acceleration

My build has a Flipsky Dual FSESC6.6 Plus as VESC along with a MTB kit with 8’’ Pneumatic Tires and Dual Belt-Drive 2 x 2000W 6354 Out-runner Motors.

I’m experiencing an issue where sometimes only one motor spins. I can feel it when riding and it’s also visible with the wheels spinning freely. I took a video [1] where one can see this happening.

Do you know what can cause this problem, could be a defect in the VESC?

[1] (https://www.dropbox.com/s/buczd8keullwg7s/one_wheel_spinning.mp4?dl=0)

1 Like

… would also like to add a couple of issues:

VESC Tool 2.02 is reporting firmware mismatch across the can bus, although the versions are identical and updated to 4.1 FW. This also happens intermittently.

Also I’m also having random disconnects on the VESC Tool. Here are a couple of examples from the log:

Hi, newb here so dont take this as a fact but i think i’ve the same setup (only difference is my motors are 2 x 2000W 6354 Out-runner Motors and i have 2 singles FSESCS 4.2 in can bus) and i have very similar issue, just less evident: sometimes one of the 2 motors responds later than the other, maybe less than 1 second later. I dont feel it when riding tough and I believe and hope this is due to one of the belts being tighter compared to the other. Let’s wait for someone else to chime in here!

1 Like

The latest firmware was very unstable for me on the FSESC6.6 dual… @mattsdominion also stuck with VESC tool 1.28 and the corresponding firmware 3.65.

Also, check your temperature readings. Are you getting cutoff on one motor due to faulty readings? Interference from the phase wires may cause temperature readings to jump up and down. Monitor realtime data in the VESC tool and pop the throttle - see if temperature jumps (10C or more, even 100). Make sure to try this for both motors.

The FSESC 6.6 seems to be very susceptible to interference.

OK, that’s already some hope…


Sorry if it’s a dumb question but it seems only 4.1 is available on the VESC Tool. Do I have to install an older version of the VESC Tool in order to access older fw?

Yes, you will need the corresponding tool version.

I incorrectly said firmware 1.28 - I meant tool 1.28 and firmware 3.65 (corrected the above post).

The archive page here does not have 1.28, I’ll find you a link.

It’s a flipsky problem.

4 Likes

Thanks @agentdev.
Managed to revert to a previous version of VESC Tool in order to be able to try 3.66 (FS responded that they use and have tested 3.56 and 3.66) .

I’m afraid the behaviour is the same. Please take a look at the video which shows basically the same as the first one:

Looking more like a problem in the FSESC…

1 Like

Have you performed hall sensor detection for the corresponding ESC? Any bad temperature readings with realtime streaming?

Ah yes, thanks for the reminder :slight_smile:
My motors are uncensored, guess that is not possible to do?

I would be tempted to try the new HFI FOC mode… it requires the latest tool and firmware. This supposedly detects motor position fairly well without having hall sensors, but I have yet to give it a shot.

VESC-Tool 2.0 and Firmware 4.0 - The beginning of a new era - (SERIOUS)

2 Likes

I tried it because my startup from standstill completely sucks. Didn’t work though. I followed the tutorial in order to adjust the parameters but my plot was always a mess and the end result was infinite cogging.

So far my experience with an under $100 Chinese ESC from my previous build has been much better and totally flawless.

Did you run motor detection with the belts removed? The FSESC works great in FOC mode, but that is usually with hall sensors.

1 Like

I liked the idea and, to be honest, had some hope this might fix the problem but I could reproduce it again without the belts :frowning:

There are too many good VESC manufacturers to be paying out the ass for Flipsky shit that may or may not work out of the box, and may or may not throw you off the board for no given reason.

2 Likes

Speaking about that, I only know Trampa HW as an alternative but it’s bloody expensive. Could you share some good alternatives? Up until now have been delighted with my cheap chinese 50A ESC :slight_smile:

2 Likes

The ZESC that started on this forum is incredibly robust, however also around 50a constant, currently out of stock. Makerx has their 4.12s and V6 VESCs for about half of what flipsky sells them for. Shaman is working on a diy V6 for >$40 and Jeff Wu is bringing back an upgrades v4 focbox and a V6 focbox (both called neoboxes). Maytech 6.8FOC are an option under $100USD aswell per esc. If you cant find something you like out of those, then I don’t know what to say.

1 Like

It seems that out of those that are not a work in progress, the Maytech is the only one that could handle at least 100A. However, the price is similar to the dual FSVESC as each single one from Maytech costs over a hundred dollars…

1 Like

None of them can handle 100 battery amps per side, and you don’t need 100 battery amps, meepo hub drives use 10a per motor and can still get up to 32mph, unless you weigh 150kg, 30-50A per side is enough to get you moving quickly as the max current is really only used on acceleration or up a large incline. I wouldn’t trust the flipsky enough to go quickly but I would trust any of the other ESCs more than flipsky. The makerx dual 4.12 is $120usd, it comes with a heatsink and the solder joints aren’t all cold.

1 Like

I designed my MTB build for 50A on each side, so 100A in total.I think that that is a reasonable requirement and for less than that I would have stick to my chinese ESC that always worked so well…

From your list, this is what I could gather, correct me if there’s something wrong:

ZESC - out of stock
Makerx 6.6 - Continuous 30A (60A dual setup)
Shaman - work in progress
Jeff Wu - work in progress
Maytech 6.8 FOC - Continuous 50A; $115.99

The Maytech could be an option from me, but also a bit expensive. With a case and anti-spark switch it costs 2 x $165!