esk8.news esk8 calc donate now

DieBieMS Troubleshooting

So i’ve finally gotten around to hooking up the DieBieMS to the battery and it’s not working properly!

When I power it on, the dbms screen comes up, followed by a battery with a cross through it, then it just says bye and turns off.

When i plug into computer, the same happens but the screen just says ‘bye’ forever.

Voltage in is reading 34 which is correct…

Any gurus able to help?

Do you have the balance wires in when powering it on?

@Wraith Yep.

I dont think I can run the config tool on a Mac. This is an issue

Got my hands on a PC but still have no idea how to open the config tool… this is a nightmare!

Install the tool and look at th RT data from the Diebie. Best way to tell if its setup ok.

Right so ive got the tool installed, but it wont connect to the bms at all, telling me to make sure bms is on and powered

you need battery/dc-supply connected to the main terminals in order for it to work. Wont work on the USB alone

Its all hooked up properly, JTAG on the other forum has said I need to install drivers on the computer to make it work…

Drivers installed and Im connected! Phew!

For anyone else with the same problem, you need to google CP2104 drivers and install!

Why not?

https://github.com/rpasichnyk/DieBieMS-Tool/releases/download/v0.27/DieBieMSToolV0.27.macOS.zip

Yeah i found that after I went and bought a PC :rofl:

Im not the sharpest tool in the shed when it comes to technology

2 Likes

I think the preset settings on the BMS is 12S so if you’re running 10S thats the reason it wont work

1 Like

Yep, correct. Got it connected and it was set to 12s. Changed the settings and reflashed now its good as gold.

2 Likes

So I spent the last 3 hours trying to work out how github works trying to fined and install DieBieMS Tool and iv got as fare as downloading I’m un Ziping it but I can’t fined any exe files to install it.

Any hints to how to do this?

I can’t remember but I feel your pain. When I get home later tonight I can look into it, if nobody has already solved it for you

1 Like

@Darkie02 If i remember correctly, this link helped, you need to get to the releases section, not the files section. Its a different zip

1 Like

Swoped to a Mac as I a link that worked thanks

I get a led flash green ones in the middle of the diebiems if I press the power button or when I first connect a USB but can not connect the tool and no other signs of life out of it. What should I see happaning?

@Darkie02 have you got the drivers installed?

1 Like

I guess not will try see if I can work out how to do that thanks

so installed the Drivers and restarted Mac still nothing more then a quick flash of a Green LED on the board when pressing the power button or plugging in the USB (one the usb in power button dose nothing)

Can I confirm the normally open switch goes between black and red? I was guessing from the photo above

Do you have the screen hooked up?