Davega problems or questions

Okay cool. I’ll try it again out on a ride where there isn’t another bluetooth device around

I obviously can’t bring the module closer to the davega itself since both are mounted haha

My Davega recently started having a problem. V1.0 unit and 1.0 firmware I think.

Started when the back wheel locked up from a loose drive chain and threw me off into the dirt. Got back on the board and the davega works for half a second then boot loops and occasionally just shows a white screen. Sometimes it will work seemingly fine until the wheels turn. The little green flashing pixel in the top mide sometimes is red, is that some sort of data notification?

All my settings have been lost and mileage reset. The uart cable looks fine and is securely plugged in on both ends. Not sure what caused this but it losing memory seems weird to me since it retains everything when you turn the esc off.

@janpom would it be possible to configure the davega in a way so it would stay connected to WiFi when it’s charging, and would it be possible to get an API to call for voltage ?, Wanna intergrade it into my smarthome

I unfortunately can’t see a good way to do it with a plug-in. It could of course be done with a firmware update but I’m afraid the use case is too rare. This is unlikely to make it on the DAVEGA backlog, sorry.

1 Like

Sorry for the delayed response. This somehow slipped under my radar. I know there have been flash memory issues before the firmware v4. From your description it seems there might be a hardware problem as well but it’s hard to tell what it could be. I would recommend that you upgrade to the latest firmware and set up automated data backups. Please report back should things still not work correctly after the update.

https://davega.eu/install-v5

1 Like

@janpom here’s video of the stuttering / slow updates on my davega - I mentioned this a while back, finally got video. If feels worse than before, but maybe I just didn’t notice.

I kept playing with it - the Davega almost never updates if I’m accelerating. Once I let off the throttle, it jumps. Although in this video it also doesn’t update the entire time I’m braking.

Any ideas?

Edit:
Sorry, I realized I’m not giving you much info. I’ll confirm what firmware it’s running tonight. It’s not the latest.

That looks as though the connection with the VESC is dropping off. It’s impossible to make out from your video but I suppose you’re getting red blinks on the top of the screen (instead of green blinks). Can you please confirm?

If that’s the case, you may want to check that the connectors are plugged in properly. Securing them with hot glue or silicone is a good idea. You’ll also want to check the cable is not pinched anywhere.

There could also be some interference. If the former does not help, try re-routing the cable (even just temporarily on a bench) and see if that changes anything.

1 Like

Can someone tell me why I’m not getting any battery or range readings?

1 Like

29.7V sounds like a completely depleted battery so that’s probably why. What’s your battery setup?

2 Likes

Yes, I believe this is true. It’s very difficult to get good video at speed, but watching it in high quality format it looks like red blinks towards the top.

I didn’t think to try to recreate this on the bench. I’ll try that next.

I checked the cable at the unit and secured.

It is bundled with two 5v power cables for headlights and run through a grommet, so maybe it’s getting pinched or getting interference there.

After securing both ends of the cable the problem persists in the quick run i just did. I also updated to the latest firmware just to be sure.

I’ll try to adjust the cable and run on the bench.

2 Likes

@janpom Heya

Just got the DaVega hooked up to a uSplit to make it work alongside my data trackers, and it seems to be having trouble connecting to the VESC.

Any ideas?

I tried both flips of the tx/rx, and both DaVega and uSplit are latest firmware

If you plug DAVEGA in the VESC directly, does it work?

1 Like

It ended up being a usplit issue, got it fixed and it’s working now

2 Likes

I have noticed my backlight is flickering or turning off completely from time to time.
It’s just the backlight, the lcd is still working and updating values when it happens.
I don’t think it’s a loose connection as vibration doesn’t seem to cause or fix it.
Is this a faulty display/ hardware or could this be caused by long wires? I have a bit more than 1m of wire between the vesc and the davega.
I haven’t found anything in the davega threads with the search function

I don’t have any other reports of this particular issue so it’s hard to tell. It does sound like a faulty display.

Is that a new unit or did it only start happening after some use?

I think I saw it flickering a few times while I was bench testing when I got it but I didn’t think much of it since I didn’t had proper connections while doing it.

It has increased in frequency over time tho.

Okay, thanks for the info. I’ll PM you about it.

Troubleshooting update:

Any other suggestions? Updates are visibly slow and same behavior as before where the unit does not update while the throttle is being held. I am sad :frowning:

1 Like

I’m sorry about the trouble. This looks more like an ESC issue than a DAVEGA issue. Do you have any other telemetry device that you could test with the same port on the ESC? Metr Pro (not CAN) or Robogotchi?

1 Like

I have both Metr Pro and Robogotchi. I’ve been running the Robo for awhile now, but it’s on a different port.


I’ll have to look if I can swap the pins between the two (different) connectors. I’ll give it a try!