esk8.news esk8 calc donate now

Can't connect to board to the Vesc tool, also no COM ports

So I’ve scoured the internet for 2 days for an answer with no luck. I cant auto connect to the vesc tool. I’ve tried different computers and cables. I read it could be something to do with COM ports, none of my computers have any COM ports (this appears to be a windows 10 thing) so I’ve installed various software that adds virtual COM ports again with no luck.
I have a brand new stormcore and the switch is glowing green. the message I get is ‘Could not autoconnect. Make sure that the USB cable is plugged in and that the VESC is powered.’
I also tried the android app vesc too but nothing comes up when scanning on bluetooth.
I’m close to just giving up and sending it to someone to repair it or just sell what I have and buy a board, so if anyone knows of someone in Spain who does repair I would appreciate it.

First of all, Hi

Let’s get a noob mistake out of the way. Is the stormcore in a build or just laying around? It actually needs external power from a battery.

Is the Stormcore brand new from Lacroix or second hand from someone?

Since you’re saying it’s brand new, I highly doubt it’s broken and needs repair. In the worst case scenario, with a new unit, you have a corrupted firmware that is pretty simple to reflash with a tool

3 Likes

Hi, Thanks for helping,

Yes its hooked up to the battery (fully charged) and motors. It’s a new one directly from Lacroix. Well that’s good news, hopefully it just need re-flashing. Do you know of some noob friendly instructions/ tutorial on how to do this?
Thanks again

I know of a noob friendly Lacroix support senior tech that’ll get you back to success.
Just email Charles and he’ll walk you through a small troubleshooting to pinpoint the problem and resolution.
cdw@lacroixboards.com

1 Like

Thank you very much

did you check in connection tab on refresh and then connect? sometimes the COM ports are a bit buggy, this one fixed it everytime for me

Are you using Windows 10? Mine doesn’t show any COM ports (greyed out) and I couldn’t find any drivers for COM ports that worked on my computers

Do you 3d print? I have noticed that some programs steal the correct ports. Especially 3d slicers. Make sure all programs are closed except Vesc tool. But if it’s not working on the app my guess would be that it just needs to be reflashed.:joy::joy: I am no expert at Vesc tool though. I would talk to Charles and maybe while you are waiting for a response check out the official Vesc channel on YouTube. Also Benjamin Vedders personal channel. Sometime it’s just something silly you have over looked. The official Vesc Project page also has some gems in the forums on there. Usually have to dig for them though. Best of luck!