Can't connect from Android to Focbox Unity

I tried my luck on the builders forum unity official support, but all I could hear was the wind whispering :frowning:, trying my luck here.

I can’t connect from Android to Focbox Unity. Now, before spending hours on rebuilding the APK and trying to hack that … trying my luck here.
Android app tried from Google Play and APK from GITHUB (1.2.1 in the about screen, CHANGELOG indicates 1.3 though) and also from Enertion site. Unity firmware: 23.44 (updated when first connected through Windows Focbox Tool).
Any idea ? I tried to downgrade to 23.43 firmware through windows but then connecting from Android , it told me that the firmware was too old or something (I didn’t try with the 23.43 APK though)
This is what I get now with the 23.44 (latest) when trying to connect from Android, also showing you that reading and connecting from Windows works perfectly fine:

Any insights will be highly appreciated !

Since I have another Unity, I’ve tested it.
Regardless the firmware, I am able to connect via Bluetooth perfectly fine, no issues.
Appears to be that the Bluetooth module of the first Unity is fucked :frowning: Anyone had not so good experience with the BT module on Unity as well ?


1 Like

Damn :frowning:
What did you do ? How did u progress ? Did they replace you the BT module ? Was it helpful ?

Well… Another option that would make more sense even tho the part might be covered is to just buy a metr module for the unity… The app is useless except for wireless setup… Where as metr offers the same plus telemetry recording.

Question is, how much do you have to play with configurations in runtime ? I mean even to test all kind of values and limits etc … Or it isn’t so bad to set it up on the first time and that’s it , and as u said, use metr module or so later on … WDYT ? It sucks though that a product worth around 300$ not working as expected :frowning:

First board?? If so for me personally I know what my general settings are and what I like… Once it’s set theres usually not much to tinker with after… Yeah wireless makes it helpful to make changes or in my case my remote was on the fritz and was able to do calibration on the fly vs having to plug in directly like I had in the past with a similar issue.

1 Like

First DIY board, yes. Can external HM10 module help to workaround this?


Don’t touch the HM10. Old tech. :yum: You can’t do firmware updates with HM10 and the support for it slowly fading away. Cool kids use NRF51/2 modules nowadays.
Wait for a week for Enertions BLE update and If its not fixed by then contact support and get a new replacement module.

1 Like