Can the OG Enertion Focbox use the VX1 remote and a Metr Pro blutooth module

Hey guys, like I said in the title, I’ve got an OG Enertion Focbox and a VX1 remote as well as a Metr Pro module that I was hoping to get all working. (I bough some of these parts apart from each other. My understanding is that the VX1 remote needs to connect to the Tx and Rx however the Focbox only has a single uart. I can’t really figure out what the remote needs the uart for but I’m hoping I can maybe just connect the flipsky module to a different plug and leave the uart for the Metr Pro. Wondering if anyone else has dealt with this or has some advice. Thanks in advance

1 Like

That METR needs a UART port so either use 2 FocBoxes connected by CAN and plug the VX1 into the second UART port or use the VX1 in PWM mode


second this, its easier and faster


I third this

1 Like

Thanks guys, I’m glad to know i can still use the remote and metr, out of curiosity do you know what functionality I would loose by running the VX1 in pwm mode. I tried to look up some videos on the remote

practically none, u still need to wire the single wire to battV+ to get the battery indicator displaying correct led light

the only thing u can ONLY use in uart mode is the “hold brake and press function button for reverse mode”, but if u use smart reverse in vesctool u don’t even need that anymore.

Sweet!!! That is awesome to hear!! Unrelated to my initial question, I’ve just built a new 12s battery to replace the 10S I had for my board and I’m using a new vesc. Do you have any advice on where to look for advice on how to configure the vesc correctly?

PPM/pwm is the way to go.

UART is for slaves

Always download the latest vesctool version, unless u know what u doing

The vesctool setup wizard does a good enough job to get the basic parameters setup correctly, include motor detection and also ppm mapping.

Afterwards there are a few things to tweak based on ur setup, like duty cycle limit start, battery and motor current / regen, smart reverse (or the variants of that)… etc. There are many things to tweak depending on what u want to achieve, it’s a lot of learn at first, but u will get uses to it eventually

Thanks for the direction. I did all of this 3 years ago but clearly I’ve forgotten all of it lol.

hey guys, so I got everything connected today and was going to try to configure the esc. I’d like a quick sanity check that I’m not going to f’ up my vesc by doing something wrong. I’ve got it plugged in and it’s been detected but when I go to firmware and select the “410 & 411 & 412” option it doesn’t seem like the selected firmware file changes. I saw a video where someone also went to the bootloader page and appeared to update that as well. Just wondering if I should go through those steps as well.

well I tried uploading but it didn’t take, I then went to the bootloader tab and tried that followed by running the firmware upload. still didn’t take. Should I try to find and older version of the tool or am I missing something in the order of operations?

i think u need to update to fw5 before going to fw6? i don’t remember if that’s esc specific or a general thing.

@xsynatic u still got the fw5 vesctool?

FW 5.2

FW 5.3

So I’ve been trying all sort of tools going back to even pre 1.0 tool and none of them will work. I’ll vig both of those a shot though
I’ve read that there have been some issues with the newer firmware causing issue with the old Focbox 4.12 hardware but that was super old information from backin '19 or '20 maybe thats all be cleaned up now. Thanks guys I’m really hoping get out and ride yet today lol

I’ve tried to update the bootloader using the 3.00.exe followed by the 412 firmware but after it uploads it disconnects and never reconnects I wait 15-20 seconds and power cycle the vesc only to be greeted by the same message that the firmware is not compatible and its still on 2.18

@jaykup help

at this point am I better off trying to flash the firmware some other way?

I have an stm32 that I can use to connect and flash firmware that way however I’m not sure what firmware I should be flashing… I don’t want to mess up the vesc

Progress so far, I was able to flash the ackmaniac firmware 3.103 using the st-link. The only thing that makes me a little nervous is that the hardware says 410 not 412. I’m not sure if its worth trying to keep jumping firmware versions now or if I should just stay here…