Xmatic app questions

Hey guys, I got the right firmware to use the programmable modes in the app, thanks again to the people who sent me the zip files👍🏻. My question now is for the modes, can I just leave the motor and battery settings and only charge the speed? This changes the erpm number, I just want to make sure I don’t need to match the motor and battery settings to the erpm it said to match the speed requested.

I think you’re fine, as long as you watch your ERPM limits so you don’t damage your stuff.

On a second note do you happen to have the ackmaniac 3.102 files? I’m currently using the Mac versions and would like a windows zip.

Pm me your email address I will forward you the one sent to me.

1 Like

Also with 10km/h you can pull 100 000A… ok ok not that much :joy: but always adjust your battery and motor settings so that they fit to your motors, your brake strength and the battery pack.

Example here are my basic settings, and I change the speed, it automatically changes the erpm. Is it ok to run this way? Only changing the speed?

Yeah I know but I think he was asking if he could only just limit the ERPM to get a different max speed while leaving motor + battery settings the same configed to his setup (like photo he just sent)

did anybody made a custom charge curve for HGLG2 Lions in the app yet?

Are there more people that suddenly get the notification that the Ackmaniac firmware 3.103 isn’t compatible when trying to change driving modes?

I’ve had the firmware for a while and now suddenly I get the message :astonished:

The app just updated 3 days ago to include the newest fw 3.58

firmware 3.103 was never supported tho? i had to flash 3.102 in order to use xmatic

Not sure, I use 3.102 as well.

I’m probably delirious then… :sweat_smile:
How do I downgrade to 3.102? On his dropbox it’s not available

So strange, so I downgraded to 3.102 (thanks @Alpacaslapper for sending me this version) but now my Xmatic app also tells me that this version is not compatible. Note: I only get this message when I try to load/write motor settings

Interesting, that’s the reason why I had to downgrade. It wouldn’t let me write modes to the vesc. Have you tried the latest vesc tool? Supposedly it works now

Just got my Bluetooth module and running on my phone, my watch app of xmatic doesn’t seem to sync (Apple Watch 2) Anything I’m doing wrong?

Xmatic app sees the BKB bluetooth module (“firmware vesc v4.0” and the green bluetooth icon in the stats tab) but no data…suggestions? This was working just before I updated the FOCBoxes (its connected to the slave ESC)

Ppm and uart selected? Baud rate 9600?

Just UART for both. Master runs a VX1 at 11250 baud or what ever the default is, slave runs BKB module at 9600 baud

I was using Xmatic with my vesc4.12 and working good… I bought the vesc6 and no connection … any sugestion? I did PPm and Uart selection and 115200 bps… I’m a single drive…

1 Like

Select again the bluetooth from the settings of the app…reset your phone…It should work… Not with all the futures, but at least battery, speed, distances, etc…