vesc tool wont connect to vesc

i cant get any of my vescs to connect to the tool. what is flippin going on?

Can you try a few different cables?

i tried several cables, batteries and vescs

What’s the error the vesc tool is giving you?

1 Like

could not auto connect. make sure the vesc is plugged in and powered on.

Try a different pc

Edit: might want to first check that the right com port is selected. Also helps to go to the connection tap, than disconnect, refresh, connect

Are you trying to connect via the connection tab or the ride toolbar? If via the connection tab, try to bar on the right.

In connections tab, check the list of COMM devices. Plug in/out the vesc and see if something in the list changes.

Not sure if you have previously programmed it on that pc already, sometimes the vesc tool requires you to use the usb port you first initialized the vesc with.

that was it. in restarted my pc and went through that list you gave. now it works. thanks. wtf?


giphy (11)


now my flipskt 6.6 says invalid serial port. the lights come on and then it flashes red and turns off

this is a day of booshit. i wpuld have never suspected my laptop to be the problem. oh well

There are quite a few applications on a PC that can mess up with your COM ports. To name a few of the usual culprits in my world: Ultimaker Cura (worst offender), ADB, Android Studio, PuTTY…
They tend to grab the serial ports for their own use and not let any other app access them.
Also sometimes after multiple plugging/unplugging attempts of the USB cable, the port driver is in a limbo state and just gives up on you…
Closing all those apps before VescTool’ing helps a lot. (or rebooting, as you found out…)


Cura got me fucked up for a while as I didn’t wanna close it. By the time I realize I programmed it on an old was laptop

1 Like

I have a similar issue. With one VESC the fourth cable was able to make a connection. But with my Stormcore not even the original included cable works. And I only have three cables to test with. I restartet my PC and none of the programms are opened. I refreshed “connections” thousand times. I have no way to connect to my stormcore. Even over the app it doesn´t work.