VESC settings for Hoyt Puck

I recently got the Hoyt Puck. I like it a lot so far. One issue I have with it though is that it brakes too hard. It has caught me off guards a number of times when I only wanted to slow down slightly.

When using the VESC Tool to create the PPM setup for the Hoyt Puck, I noticed that its response to the wheel knob is non-linear. It reacts more aggressively to braking than to adding throttle. In other words, moving the wheel backwards makes a more difference in the PPM signal from neutral than moving the wheel forward by the same distance.

I guess that kind of makes sense since you want to be sure you get enough braking power when braking in emergency and at the same time your thumb is positioned such that you cannot immediately move the wheel all the way towards yourself.

Nevertheless, the brakes are too sensitive to my liking. Does anybody else have the same experience? Have you adjusted your VESC settings for softer brakes?



all the cool kids are spell checkers

have you tried the braking curves in the VESC tool?


The standard throttle settings are 0.1sec for negativ ramping and 0.3sec for positive ramping. If braking is too aggressiv and direct, maybe switch Negative ramping to 0.3 as well.


Corrected. :blush:

I haven’t yet. I guess I’m wondering if someone has already figured out the perfect setup. :slight_smile:


There is/was some discussion, today, in the n00b thread about brake and throttle curves…

1 Like

Play w either your curve or neg ramp. I have mine set at 0.3 w no curve but I like it this way. Yes, I’m also using hoyt.

1 Like

Hi, i am having a similar issue, except mine wont run at all with any weight on the deck the motor will just shudder, but will run fine with no weight on it. i have ran motor detection and setup ppm for the remote, not sure if there is anything else i need to do with this as i used to run the wand remote.

1 Like

What motors? Sensored/unsensored? Is it just a problem when you’re starting off? If you give the board a gentle push, do you get going?

You may want to try redoing the PPM setup.

Thanks for the speedy response, i got 118KV trampa can running sensors, with trampa vesc 6+,
starting off it will shudder with forward and smart reverse, and push nothing at all. Its acting as if it needs more current to move. i have run ppm setup 3 times and same thing, set min and max settings with the remote on mode 3 as well. is there any additional settings i need to input for a ppm remote apart from setting min and max values ? :slight_smile:


Probably not unless you have severely limited your motor/battery amps and/or motor RPM.

Best if you could post screenshots of your PPM settings so that we can check that there’s nothing obviously wrong.

Can you still use the wand remote and check if all is working as expected?


i have narrowed it down to a issue with vesc tool settings i have put the wand back on and same issue, i shall have a play with them, if i still get issues i shall let you know, thanks so far dude :slight_smile:

1 Like

I would double-check the max motor current and max battery current settings in that case.

1 Like

Whats the verdict on your settings I like mine at .40 but still testing it out

I ended up with the default VESC settings and just got used to the puck behavior. It feels very natural now. I can control my speed very precisely. I love my Hoyt Puck.

One thing to note though is that my new board gearing doesn’t allow for aggressive acceleration/deceleration even if going full throttle on the remote. That’s different from my previous board which would throw me off if I started on full throttle.



Board with plenty of braking power. Any less ramp down and i’d fly


Very timely revival of this thread. I have never had a remote that was as sensitive to braking as the Hoyt. This will help me out tons.

Thanks guys!

1 Like

I just got my Hoyt puck and formerly had the VX2 from flipsky. I noticed that the “Throw” on the throttle itself was shorter, and because of that decreased range of motion, I made the following adjustments:

Input deadband down to 5% from 15%, because I felt like I was moving the throttle 1/3 of max range before actually registering amps per live feedback. Hated that.

Also dialed down the throttle curve to -5% for a bit less jump (6380 motors, 16/36T setup, 50A per 2 torque6 esc’s)

Braking down to -10 or -15%, one of the two to account for the braking. Have yet to address negative ramping time. Might up that soon if I don’t like these settings.