Vesc low output power

I’m using a flipsky 75100 for an 6000w e scooter build (I’ve only got one of 2 controllers at the moment), but I’m weirdly getting readings of 45 amps, and only 200w. It’s weird, because that would mean that the voltage to the motor is 5v, even when the battery im using is at 68v. I’ve been screwing around with the settings in vesc tool for most of the day, and I can’t seem to get past 200w on my 3000w motor.

If anyone has any clue as to what’s preventing it from reaching that power, or if there is some setting I’ve missed, please let me know. Thanks! :slight_smile:

Pictures of motors connections and all the settings plz
Also what kind of motor did you choose on detection

1 Like

I selected the 6kg hub motor option
motor config.xml (9.7 KB)

I have a bluetooth module on uart 2, and a flipsky tft screen hooked up to the comm port.

What kind of battery are you using ? (Series count)


Should be set lower. Unless this is the voltage where you want to start reducing power.

its a 16S 8P 38AH battery. peak voltage is 67.2.
I’ve just set them to the calculated 16S limits, and nothing has changed. It’s weird, because there is no way that it’s drawing 45amps and only that powerful.

What speed is this at?

1 Like

Weird, also is this a bench test ? Or are you actually riding it

1 Like


I am stopping it from moving by just holding it back with one hand.

Did you go through detection, yes to defaults. And then settings the S count of your battery in the wizard?

Vescs can do weird shit sometimes

Strange it says speed is 0 while you are drawing power

Electric motors don’t produce power at zero speed (neither do gas engines for that matter).

Power is speed * torque.

That 200W is being dissipated as heat inside the motor.

Motor controller steps down the voltage and regulates current through the motor, so yes, the motor is only seeing 5V because if it saw the full 68V it would melt and catch fire.

I suspect you also have sluggish acceleration, but that a completely different can of worms.


Some background info on the VESC-Tool settings.

I said no to defaults because the vesc i use has no phase filtering, and yes I put the 16 is in the setup.

I was holding it back with my hand.

My motor is set to 45A and so is my battery. the weird part is that there is no way that is is drawing 45 amps and I can hold it back with my hand. The battery voltage was at 68v, so it should be able to deliver 3000w, but somehow its stuck at 200w, but still draws 45amps??

Not sure what’s up with these units. They were designed by some guy as a hobby project and then copied by flipsky… till very recently flipsky didn’t even have acess to the firmware sources. It was the community that somehow organised the source files, so that firmwares can be compiled.

Would I be better off contacting flipsky?

Load default parameters, run a detection, then switch off phase filters.

I’ve already done that maybe 10 times…
I’ll give it another try though