VESC (FSESC dual 4.20) caught fire

So, I am still in shock by what happened. But I will try to explain what happened so you guys can help me out with what could be the cause of it.

I recently got my FSESC dual 4.20. I hooked it up to my battery made by a professional builder with a bestech high discharge BMS. I then started the motor config in VESC tool. I use the 1.13 version. I did the motor detection in the setup Foc tab. Not in the motor wizard. However one time it said that I did not have the latest firmware, even though I had 3.57 on both the master and the slave.

It did the test and then I got some values. I did not like the values, so I rerun the tests. Nothing happend when I pressed run detection, even after pressing multiple times. So I ran the motor wizard, which makes you do it on both the master and slave on the vesc. Not both at the same time over can bus.

Master side worked fine and I got the values. When I started the detection on the slave side however, it cut off in the middle of it and the bms cut off the battery. So I had to press the switch and then press it again to give power to the vesc.

This is when shit got so fucking wrong. When I pressed the e-switch, something on the underside of my VESC started burning, like a damn firecracker. It kept going on for like a second and I was then left with a big soot on my desk as well as a probably completely unsuable piece of electronics on my desk. As someone with quite a limited income, this literally burned 150$ of my money in front of me.

Here is a pic:

I am quite devastated by this and I would love your input.

1 Like

I could be wrong but I believe I’ve read about killing canbus escs by turning one off before the other. @b264 has knowledge relative to this I believe.


Yes, on older revisions if you turn on one before or after the other with the can cable and/or can bus turned on it will blow the IC’s.

1 Like

This was bought very recently, so I would assume it is one of the newer revisions.

1 Like

Have a link will probably help narrow versions down?

Also would follow up with MFG to see if they will replace before trying anything else too drastic.

This is the one I have:

That’s the old model mate, the new one is a “plus”

1 Like

Oh well, I see. Then I have the older model

How is one turned on before or after the other when they are both connected to the same battery without a splitter?

1 Like

There’s a button to switch from single to dual. I assume the only way to ruin them is to switch it over while the esc is powered up?

1 Like

I don’t think the new plus version even has a can on/off switch.

It has a can switch though.

It has to be said though, things get assembled badly, things break quick… it’s just the nature of mass production in a sweatshop environment.

If you pull that esc apart you might fight “Help me” written in teenager blood on the inside.

Contact flipsky, tell them it was a dud and start the RMA process, they are pretty decent with it all.


Fuck I think I might have done this. Could this be the reason it ignited? :fire::fire_engine::fireworks:

1 Like

Unfortunately that’s almost certainly what happened if you think it. Unlucky my friend.

Ask Flipsky for help.

1 Like

These are pics of the top of the VESC:

1 Like

This is the CAN switch…


I realize now it is in the “OFF” position. So the switch might be the problem and what caused everything.


I’m sorry for your VESC-loss and good luck with FS. Being from SE as well, just curious who your pro batt builder is?

1 Like

Frederic, from electricboardsolutions. @EboardSolutions . But I am pretty certain that it is nothing wrong with the battery. I tried plugging it in to my other vesc, from maytech. It went fine without any fires :smiley::fire: