VESC 4.12 hangs until rebooted

first time build (and rider aswell), after a cumbersome build I face a problem which im not able to find any definitive result when searching for.

I´m running the Turnigy SK8-ESC V4.12 on 3.58fw and a Turnigy SK8 6374-192KV Sensored motor, detection worked (although first time it set it as sensorless, another try found the hall-sensors.). I have setup the motor and input and everything seems fine, tried riding the board short distances (in my apartment :)), and it works well for some time. approx. 10min.

But then suddenly the VESC cuts out completely, no acceleration and no break (so not the voltage, 10s lipo 5Ah, as breaking should still work with low voltage, battery sits at ~37V currently).
Just rebooting the board by power-cycle clears everything and I can ride again.

I´ve repeated this a few times with the same result, and its not in a high current draw situation or any particular situation.
The last time I removed the covers to connect the VESC without reboot to find any error-codes in vesc-tool, but the computer wont even detect the VESC anymore (on linux, running dmesg or lsusb shows nothing), the LED is a steady blue and does not react on the PPM remote (ie not blinking green on signal, also no red blinks when throttling up).
So software-wise its seems to be completely halted by this stage.
I´m running the input as ‘PPM and UART’ and have connected a ESP32 MCU on the UART to serve a Wifi AP with stats (until I finish my remote with oled).
This is the only addition to a pretty basic setup, I´m currently polling getVescValues at 100ms and I don´t feel like that should be too frequent or cause a crash since also running the nunchuck would require higher frequency (also its currently solder on so I need to desolder to test without, therefor I´m just looking for input now before destructive troubleshooting).

So has any of you experienced the board completely hung like this?, any idea how to troubleshoot when I´m not able to communicate with the board until reboot? heat-issues perhaps? still feel it should do a graceful shutdown no matter what error it encounters so the board should normally be detected no matter what.

1 Like

Also noticed some peculiarities,

  • in the experiments tab and also the manual motorcontrols (or keyboard controlled), the motor only clicks even going through sweeps of current or dutycycle, never starts spinning, not even with a little friendly push, this was under zero load, ie on the bench.
  • breaking hard seems to be one reason for the vesc to hang, motor set to -60A and battery regen -7A, Im unable to recreate this on the bench since I cant put a forward torque that would generate the same stopping-power as when riding.

Ever figure it out? I have same problem

Same here @Deodand

1 Like

take a video of the issue.

Youtube is easiest

For me it’s just the motors wont spin on keyboard control - Enertion Hubs/Fw 5.1 > Unity. and using Metr Pro

(it used to work back in older unity firmware however as time went on uphraded software it worked less until it just ticks)

1 Like

I’ve been having this problem a lot lately. The arrow keys functionality seems to be extremely flaky lately, like there is some kind of bug or race condition happening that causes them to just not work a lot of the time.

Try restarting the ESC and the tool.