Trampa NRF Connection Trouble

I have a Trampa wand, and the Trampa receiver module. My goal is to pair it to a Flipsky 75/200. When following NRF pairing in VESC Tool, the remote never seems to pair. When trying to pair using bluetooth on android, I get a “Could not read firmware version” error. I heard I should update the NRF receiver, so when going into SWD programming in VESC Tool, there is no option for “Trampa BLE” as Trampa instructions state to use. There is only “BLE Sparkfun Mini”, Which I have tried with no success. I have also swapped the RX/TX wires to see if there is any change, and there was not.

-What can I try next?
-Is “BLE Sparkfun Mini” the right firmware?
-If not, where can I download the “Trampa BLE” file. (I cant seem to find it googling)
-How can I resolve the pairing issue, and the android connection issue?

If it helps, there is no LED light coming on, but there is a broadcast bluetooth signal so I know it does have power. I have two receivers and two remotes, and no combination of any of them work/pair as they should despite following the directions exactly.

TL;DR I cant connect to my Trampa NRF receiver, I have been trying all sorts of things for hours now.

1 Like

Does the fsesc connect via wired connection to the PC?

It does connect to the PC via wired connection. I am able to update both the FSESC and the receiver through the SWD programming port. I am not sure if the “BLE Sparkfun Mini” is the right firmware for the receiver, or why the remote will never pair when following the setup process. I follow it step by step, and in the videos I watch(Trampa), it’s instant, but when I try it always times out.

You need to flash the correct FW. The pinout needs to match. Not sure what pins other brands use. The NRF chips have plenty of general purpose pins and you can connect RX and TX to any of them. The FW specifies certain pins to be connected to RX and TX. If you flash the wrong FW, you will have no funktion.

Do you know where I can find a copy of the correct firmware for the Trampa NRF receiver? Throughout the documentation and receiver instructions included, I have always seen “BLE Trampa” firmware. Is there a github link, or perhaps a file section that you guys host?

I want to flash the correct firmware, but I do not know where to get the firmware in the first place.

Can you show me a picture of the receiver. There are two different versions. The NRF51 and the new NRF52840 based one. The new model uses the same pinout as the VESC HD built in.
All firmwares are included in VESC-Tool.

New NRF52840 reciever FW: vesc_tool/nrf52840_vesc_ble_rx26_tx25_led27.bin at master · vedderb/vesc_tool · GitHub

Looks like its the 52840 version. Ill try the new firmware you have linked shortly and update you with my findings.

The firmware works, thank you Trampa! I cant wait to get this monster build running!

The solution for anyone following this thread in the future : Flash the correct and updated firmware. It appears that these files can be found on github (GitHub - vedderb/vesc_tool: The source code for VESC Tool. See with some digging depending on what device you have. After updating/flashing the new firmware you should be good to go!

Wait, how come yours has no antenna plug?
I got the newer ones specifically to have an external antenna for good reception, now i see yours is not even soldered on?

Trampa has 3 versions. I did not know this until actually getting mine delivered. I just clicked to add a receiver with my remote when ordering and it was what I got. I will be ordering one with a external antenna soon because my ESC case is now going to be carbon fiber. (I also may have fried one in my experimentation process the other day but thats another story)


For what it’s worth, there is actually a third one with external pcb antenna : VESC Connect NRF Wireless Dongle with EXTERNAL PCB ANTENNA

Edit : Just so I don’t sounds like a broken record, AK1 mentioned 2 versions then edited after reading my post. :man_shrugging:

1 Like

Oh. I assumed they just sell the old nrf51 type (that i bought a year ago and is sitting in a drawer somewhere) for non-antenna type.

Btw, most of the bad signal situations are from the wand itself. Only really works with the back lid pointing down in the general direction of the receiver and is very susceptible to interference. Even phone in pocket with 5g on at 10cm away is dodgy.
@Trampa will a future update work on improving signal reliability in high interference areas? Or will there at least be an updated pcb version with an actual antenna? Huge range is never overkill when in some situations it can’t communicate half a meter away.

5G does not interfere at all. With the new BLE 5 receivers we can control a board located at the other end of our warehouse, even with the NRF receiver with no antenna and the receiver far down inside the enclosure. So there is enough link budget. Some phones seam to influence the throttle response when you log data via the very same receiver. We will try to improve that soon.
If anything I would suspect WiFi to have a chance to interfere. On the other hand we haven’t seen it in all the years we use the NRF chips.

the new receivers are all NRF 52840. The antenna type has a connector for an antenna and you must use an external antenna. The integrated antenna type has no antenna connector.

1 Like

It could be my watch keeping a constant connection with the phone. Although i have noticed it being worse with 5g, it could be placebo effect.

As for signal, in ideal conditions it does indeed go a decent range keeping a connection with the phone or responding to the remote when it is facing the direction of the board, but in urban environments it barely responds 3 meters away or not at all in specific areas.

To give an idea about what kind of environments i talk about, if i go into liverpool street station and i scan with my phone for bluetooth devices, it completely freezes for a good 3-4 minutes. That’s a note 20 ultra. My old note 8 would just… die. And restart

I have noticed that the crazy UK camera surveillance consumes quite some frequencies…
I think a lot of those cameras are dirty EMC emitters.
Even in Nottingham there are areas that would kill and 2.4GHz PPM remote signal.
With the Wand I can ride through these spots without any issue.
Did you log data at the moment you experienced non ideal connection?

1 Like

I can’t log data and access it in a reasonable way without a metr unfortunately. Both because of the android app not showing the log like on pc and because signal appears to be even worse with the phone connected

Hi, I have the same problem and I can’t solve it, I mean connecting a dongle. Do I need a flash firmware SWD connector? Because I can’t connect to the Dongle via Comm. Thank you

If you want I could call tomorrow to figure out what’s up with the setup. If your problem is the same, basically there is a SWD port on the NRF receiver, and a SWD port on the VESC chip(there was on my 75/200)

Plug them into each other through the SWD ports, and then in the vesctool, connect to your vesc. There will be a SWD tab where you can upload the right file from github links above.

I’ve read so much that I understand how it works. My primary esc is Tenka, to which there is no single port scheme where CLK and IO should be. (I’ve already written to the manufacturer). That’s why I used the old Flipsky esc 4.2. So I can flash. I uploaded the latest firmware, they work in Vesctool 3.01. I flashed Wand with Wand and Flipsky flash Ble Sparkful, Vesc HD and Stormcore and none work. Otherwise, thank you very much, but my English is not at such a level :smirk:

I have two trampa BT dongles version 1 and i cannot make them work with my trampa vescs. i’ve tried to invert TX and RX but still nothing. I understand i may need to flash the firmware? however it used to work some time ago