Testing a VESC Express

I just purchased a VESC Express to go with a Spintend VESC that is on a slow boat from China. I would like to confirm that the Express is working before the return window closes. I plugged it in to USB-C port to see if it lights up, nope. Checked it with a USB power meter and the current draw was 0.0004A. At this point I figure it does not draw power from USB or its dead. Any help on how to test it would be very much appreciated. I hope this thread is in the correct sub-forums because the drop down for where to put it only shows me “Esk8 Electronics-> guides, Support, & Ques”, thats it.


Normally, a VESC cannot be powered from the USB port alone.

Apply power to the + and - of the VESC and see if it lights up

1 Like

He doesn’t have a vesc yet.

He is trying to confirm if the vesc express logging module works.


I didnt find any schematic for the express, best I found in the topic is the the demo video where it comes alive using only the USB cable. That’s a beta module in there but I would surprised if the production unit would lose this functionality compared to beta.
VESC Express Demo - YouTube

You can try to ask some clarification in the vesc discord server under FIRMWARE/logging channel.

I would ask Trampa directly, and then post the results here. Then, it’s searchable for others having the same issue later.

I’ll confirm with mine tonight, but I’m 90% sure it’s not supposed to be USB powered, it’s CAN or UART. The USB C isn’t for configuring, it’s basically in case your ESCs don’t have type C or an available USB port, you can use it as a USB emulator/forwarder over CAN. I can’t remember the specific wording, but it’s something like “USB over CAN emulation”

You don’t address it directly to set it up, only through the ESC I think. I’ll power mine up in a bit and see if it responds to USB but I wouldn’t expect it to. Do you have anything else with a microcontroller like an Arduino, ESP32 board, Nucleo, etc? Or any way of getting just a 5V and GND connector?

Edit: I think I’m wrong here, Vedder’s demo shows it connecting over just USB. I must have been misinterpreting the USB feature

Edit 2: I was half right? USB does not supply power on at least some revisions (only 2 so far are from Oct '23), and power does come from CAN. But USB can be used to configure the device, just on our versions it needs supplementary power. Only tested supplying that supplementary power from the CAN connector

Thanks everyone. I had seen the demo video but I could not determine if it was attached to the VESC or computer via USB. I tried to find and join the Discord but could not find them on Discord and the join link I found does not work. I’ll try contacting Trampa if we do not determined anything here. Good idea with the Arduino, I have a “DSD TECH SH-U09C2 USB to TTL Adapter with Built-in FTDI FT232RL” which I could connect to the UART port with 3.3v, but I don’t want to try anything that could be construed as voiding it’s “warranty”.

It’s working in Vesctool only using USB-C being connected.

1 Like

Huh it’s not for me, or at least not usually. It does respond to USB when both CAN and USB are connected though

Awww crap… Thank you for checking. When did you get your VESC Express?
I just tried it on a Linux box and Windows 10, was on an M1 Macbook, still nothing on USB only.

Just to clarify, have you tried running VESC Tool on the windows or Linux machine and checking to see if it’s detected there when plugged in by USB? The only mentions that Vedder makes of lights are a blue one for Bluetooth and red for WiFi, and BT is off by default and WiFi doesn’t know any passwords so they don’t light up when powered

I also edited my post above because I was wrong about not taking power from USB

Yes. I am using VESC Tool on an M1 Macbook Pro and the Beta VESC Tool on a Win10/Linux laptop. My Macbook always asks to allow a device on USB, which it did not, thats why I checked it for current draw. This could be a false alarm on my part since .0004A is actually more than enough for some devices. I’m going to check a couple things I did not look for on Windows and Linux like com ports appearing when this device is connected.

Well, nada. No ports appeared when I connected the VESC Express. But the FTDI mentioned in post 6 gave me:
Untitled - 1 of 1 (2)

Some months ago.

1 Like

Cheers, yeah I assumed once you had a microamp current measurement you’d probably tried the software it’s supposed to run but just double checking :grin:

I’ve tried a couple of USB cables and they output power to other devices, but not the VESC Express. It only shows up for me when externally powered, in this case I just put a barrel connector on the 5V and GND in the CAN port

I got mine this week

1 Like

Update: I probed the board a bit and found a few things

  1. When just USB is connected, I got 5V on these pads of the USB connector but not at the voltage regulator on the back or at the 5V of the CAN connector
  2. When CAN is connected, no 5V on the USB
  3. No continuity between those points in either polarity, so I don’t think it’s diode protection I think it’s just not connected

So at least on my revision, power is not supplied by USB. Idk if there’s a trace that got left out or it’s intentional isolation, my guess is it’s so you can’t back-power the logic circuits on a VESC by connected USB to the VESC Express, I assume that could blow something up. But I don’t know why you’d do that by just not taking power from USB at all, a diode to block reverse current seems to make more sense, but not an expert


Thank you everyone. The help here is amazing. I will contact Trampa and see what I should do next.
Thanks again.


YOU ARE THE MAN! I used the FTDI USB->TTL device to supply the 5v and ground to the CAN connector and “It’s Alive”. USB connected and VESC Tool connected. WiFi works. GPS flashes but no data, yet… I was able to access the SD card and see a directory on it. Still seeing what I can do.

1 Like

Ayyyy good shit! Funny coincidence that you got yours just as I was setting mine up anyway, this helped me understand it too and not freak out when the lights wouldn’t show up.

When I tried to set it up I had CAN hi and low reversed because the supplied cable doesn’t use the common green and yellow coding. So even with CAN connected to a suitable VESC I couldn’t get it detected over CAN and it only showed any life with both USB and CAN attached