Sudden brake when rising throttle on VESC4.20

Hello builders! I built one drive esk8 with Flipsky 4.20 vesc, one Unlimited x Loaded sensorless hub motor and 10s1p Samsung 40T Battery pack + 60A BMS. Remote is Flipsky VX1 connected via UART. When I go more than 20 kph with 0 throttle and start pushing it to about 30%, board suddenly brakes (not full brake) for about half a second. It rare happens when I go uphill, mostly when going down or flat. How do you think what can cause such a behavior and how can I solve it? Thanks

VESC Tool settings

SOLVED: Doubling the observer gain value helped.

@bigg_daddy Did you ever find out what was the issue for you?


Btw why is this thread under “eskate mechanics”?

I have similar issue and for me I believe it has to do with the VX1 remote/reciever. (set in UART)

This same kind of issue just popped up out of nowhere for me. My board was working bombastic since recent HW upgrades, until ~300km later when it started to have these loss of torque “tugs”.

Seems to only happen at low throttle levels and the issue has gotten worse with time. Now some times I loose the ability to throttle forward all together. I just come to a free roll.
When this happens, there no response from forward throttle at all.
However, as soon as I push brake, the fault goes away. Sometimes it heals by it self… wtf :confounded:… ??

I once recover from the “no forward throttle state” by restarting the board (which i guess says the fault is in on the receiver side and not in the remote)

There are no fault codes set

so far I have:
Replaced the vescs and motors with another set but the issue still remain.
Checked Battery connections
I have no BMS
Tried sw 4.03 and beta 5.
edit*. both BLDC and FOC has the same issue

I have not been able to reproduce it on bench yet but will probably waste the remaining of the day for it.

On a side note.
I only get max 94,8 % throttle in vesc tool :face_with_raised_eyebrow:
Although the voltage out from the potentiometer in the remote at full throttle correlates to 99,9% of the input voltage (3,291V).

Have anyone else had similar issue and it turned out to be the VX1 remote/ receiver?

edit. It turned out my issue was due to a bad connection in my battery. :flushed:

So you solved your problem by resoldering a connection?

I haven’t fixed it yet but i’m 99% sure it is the root cause for me. Voltage probably goes down in voltage cut off region and this is why throttle doesnt work but brakes still do.

I don’t lose throttle, so we have different problems.
I have doubled the observer gain value, and the problem seems solved, but I am not sure because tested only once. Have to go ride more to be sure the problem is solved.

Woah woah. 10S1P 40T? They can’t actually handle 40 amps output. Batt max needs to be set to 20-25 for a single or half that for dual motor

That may be a start. Can overheat the battery quickly if it can supply that draw even for a moment.

Set motor max to 40 and battery max to 20 and test.

40T can continuously discharge at 40A rate, but i am sure the motor will not pull so much amps continuously. And I have this issue when free rolling, not when going uphill and drawing much amps.
Doubling Observer Gain helped, but I had to test it more to be sure that was the case.

Discharge graph