esk8.news esk8 calc donate now

Strange problem with motors/maybe Flipsky Vesc 4.20

Hello everyone,

Today I wired up my electronics and configured my dualFlipsky 4.20 Vesc with the Vesc tool free version.
As you can see in the video below there are 2 x 5065 BRH5065 200KV motors. Problems are:

I uploaded the newest firmware and tried looking at different settings but nothing worked. Furthermore, I connected both of the hall sensors of the motors (see picture below), but in the Vesc tool it still shows sensorless, could this be the answer to the above problems?
Vesc tool feedback:

Connection of hall sensors:

Thank you in advance for your time and help guys.
I appreciate it.

Regards,
Mad Scientist

Do you have reverse enabled? Also motors will have different resistances so one will spin up before the other, this goes away when both are on the ground so I wouldn’t be worried

2 Likes

Yes. Change UART control mode to Current with brake instead of Current with reverse

EDIT:

my mistake, this setting seems to be only possible with ppm.

MMMM love this obscure issue that took me a long time to figure out.

There’s no current no reverse brake option on UART control. The only way to do it is to go to the vesc remote tab and manually uncheck the smart reverse button. Make sure you save settings to the vesc and that should do it for you.

Also be aware that the Vx2 has a reverse on it that you can use, which is cool, but if you don’t know about it, it can be confusing. Consult the user manual because I don’t remember the exact button combo

3 Likes

For reverse: disable smart reverse under app config, vesc remote

About the motors starting at different times: it doesn’t seem severe, being sensorless, the other motor may consistently be in a position where it doesn’t track well from the start.
Does the issue mirror itself if you plug the remote on the other side?

For hall sensors: make sure pinout is: red (5v/3.3v), white temperature, green/yellow/orange/blue/any variation of 3 wires: hall pins and black as ground.

2 Likes

pull back the wheel and press the second (not power) button once, and it will be reverse.
do the same thing again for going back to forward mode

Edit: i’ve not tried what’s the max speed limit vx2 will not allow for u to do it while going one direction, but u shouldn’t be flying at 20mph and wanting to change direction anyway…

3 Likes

That’s a common problem. Turn on TC.

Thanks you all for being so helpful, I will try your advices and I will let you know how it goes.

Hey guys,

Quick update from my side:

  • first problem I had was that one motor spins sooner than the other at no-load condition (when the board is in the air). When load is applied, hence riding on the road you dont feel the difference. Hope it stays that way
  • second problem about motors going in reverse after full stop, the way to fix it is to go to Vesc tool --> connect --> Vesc remote (make sure that in “Genral” only UART is selected) --> select Current no reverse and also Smart reverse: False. IF you have 2 vescs do each one separately
  • final issue was that the Vesc tool was showing sensorless for one motor and the other Hall sensor, I checked the wiring but still it said that one of them didn’t have sensor. It doesn’t bother me since when on the ground both are running and I still get the correct speed.

QUESTION: what values do you guys use for positive and negative ramp time? Where I live its mostly flat, with some 5-10% hills?

thanks again for the help,

1 Like

Ramp times:
Urethane: 0.7s up and down
Pneumatics: 0.4 up (default) and 0.8 down.
Throttle expo i generally keep -10% acceleration and -5% brake
These values depend A LOT by the torque your motors give, how heavy you are, how heavy the board is.

The only value i can swear on is 0.7-0.8 ramp down. This is very important at speed because letting go of the throttle or any cutoff/signal issue can make you faceplant with no warning. Losing power at speed can feel so strong that many people swear their board started braking!
Also, braking immediately cancels that ramp down, and be overridden by ramp up value (in braking), so you will not keep accelerating in an emergency

Expo values again depend on the amount of power your board gives, but also on how much travel the remote has.
A vx1 (i use) is inappropriate for high power builds so for my 160 motor amps i like to keep the low end a bit more in the fine adjusting range. Then when i floor it, i know all the power is right there at the upper end.

Ramp up times depend on wheels and the total inertia of you, board and wheels. Too short and it will react before you can be ready for it, too long and you will feel like you’re missing power. Low values on longboard wheels feel way too twitchy for me

2 Likes

I think that is flat out bad advice. Suppose you’re going 40km/h, 0.7-0.8 seconds plus a reaction time of about 0.5 seconds would have you move another 15 meters before the board even starts braking.

I have my ramping at 0.1 seconds, makes much more sense. It won’t throw you of the board.

Urethane is much more slippery once it loses traction! You simply can’t adjust your body any faster to adjust for braking and the possibility that your back will slide out from under you.
It took me 2 accidents to realise that urethane slips when you need it the most, and that is when you need it to brake in that very instant.

Keep in mind it’s 0.7s to the amount of brake you input, not 0.7s to neutral and another 0.7s to brake

As for pneumatics, much lower is fine, since the back still drags when all the weight is in front, unlike urethane