esk8.news esk8 calc donate now

Still can't get flipsky VX1 to work

Day 83 of no PPM or UART input and the survivors look grim. But seriously I have a new 6.8 VESC from maytech, tried setting up the connector for UART using just TX, RX, 5v and Neg. Receiver turns on, pairs with remote, esc activity light (for 5v I assume) turns on but it will not get any signal from remote, tried switching TX and RX to no avail. If anyone knows PPM pinout for VESC I’ll try it but couldn’t figure it out from flipsky diagrams. pictures relevant.

3 Likes

Open up the metal case of the vesc, it should have the pinout of your exact vesc printed on the pcb.

1 Like

It didn’t and maytech didnt post the pinout or gerber so I’m SOL.

1 Like

Did you contact them?

Can you control it with a different remote?

I believe the VX1 requires you to set up your settings on the esc first without having it connected otherwise it malfunctions.

I dont have any other remote unfortunately, and I am able to change VESC settings but regardless of how I install the receiver the VESC doesnt seem to interpret inputs. I’m going to have to contact maytech this is ridiculous.

Contacted them tonight, I don’t know if sales reps are given pinouts for VESCs but I will try.

1 Like

This seems plasible, sometimes the RX TX get confused

1 Like

But you cant configure UART other than baudrate and I dont know the pinout for PPM using the VX1. Any suggestions?

Do you have a standard Maytech VESC? I would imagine that they are the same pinout as a regular one

I might be going insane but I don’t see a single ppm connection on that pcb. :weary:

Just checked, standard pinout.

@Kalitapaws You seem correct, haha wheres my gun.

I am pretty sure you are missing a wire, my vx1 has a lead going from V on the reciever to the possitive side of my battery

Notice how it tells you to solder the white cable to the red power cable. You are missing this connection

My bad, I didn’t think you needed that cable other than regulating battery voltage. Will install and come back, thanks for trying.

As far as I know that’s only for telling your battery voltage on the remote’s leds. I may be wrong there though.

1 Like

That is correct. The Vbatt connector is just for LED voltage gauge on the remote.

I still don’t understand why I cant get this to work though.

1 Like

I’ve had this same problem with 2 different VX1 remotes now. They have both worked for about a month and then stopped working. They will connect but no input is sent.
So far Flipsky support hasn’t been helpful

Love u my man.

But this is misinformation.
This pin is completely unnecessary to make that piece of shit work