Spintend remote speed

I’m using the spintend ubox and remote. The display on the remote will only ever read max of 9mph.
I’ve set the correct wheel, pulley size and voltage both in vesc tool and on the remote it’s self.

Obviously not that big of a deal but I would like to get it working if I can.

Any ideas of how to correct it would be really appreciated.

1 Like

Try changing between mph and kmh just in case that resets something.

Did you set the motor poles correctly?

1 Like

Tried changing mph to kph and back but still the same.

I’m not actually sure it’s a 6355 Chinese Outrunner. I left the poles at 14 but I guess I’ll need to open the motor and have a look.

Had the same problem myself.
The remote setting is pole pairs, (not poles) so for a 14 pole moter that’s 7 pairs.

Took me a day of working through settings to notice so hopefully this helps someone out.


Thanks for the tip, problem solved.


Where is that changed in the VESC tool? Under Setup-Motor Poles or Motor General-Motor Poles?

You have to change it in the remotes own settings (not via vesc tool).