[SOLVED] Detection failed w/ makerX HV200 + 80100 motor

Hi, I got a noob question for ya. I’ve tried to get detection working on an 80100 130Kv motor on 20s and can’t get past the first step. Every thread I could find about detection was about flux linkage fail or bad sensors, so I figured I’d ask here.

My multimeter is too dumb to measure in mOhm territory but the motor spins smoothly when free and acts like a strong brake with the phase wires touching. The brake behavior is the same regardless of which wires I use, so the phases are, at worst, fucked up symmetrically.

I’ve tried FOC and BLDC wizards, each one sensored and sensorless. During RL measurement the motor clicks and does a quarter turn or something, and VESC tool gives me this:

BLDC detection is silent and it just says “bad detection result”.

Motor settings currently are:

  • current +/-150 motor, 420A abs
  • voltage 85V max, 12V min, 65V/60V cutoff start/end (battery is at 84V right now)
  • eRPM +/-77k max
    all other VESC settings are stock

Detection was successful with fw 5.3! It’s possible that the MakerX factory firmware is not compatible with either VESC tool 3.0 or 3.1, although it got slightly further along in the sequence with stock firmware and tool 3.1. Woulda imagined 5.2 firmware works with the old tool but whaddo I know?


I went through the motor detection wizard and selected small or medium outrunner (can’t recall which), but this failed to detect my 80100 50kv motor. Went back through the wizard with the next size up outrunner and everything passed detection ok. Latest non-beta firmware/vesc tool version (5.3).

IIRC there’s a warning in the tool stating the motor or VESC might blow if you choose a too large motor size, so I deliberately choose the 700g outrunner option knowing that my motor was almost 2kg. The next size up was the one that worked.


Thanks for posting your solution! Maybe edit the title with your motor type and [solved] for future reference :slight_smile:

1 Like

Well that’s what worked for me, might not work for the OP though :wink:.

Another simple check might be to short the different combinations of the phase wires (while disconnected from the ESC) and try spinning the motor by hand to feel for an expected increase in resistance. If there’s no noticeable change then there’s likely something up with the phase wiring in the motor.

@Flyboy 80100 at 20s is a pretty serious setup. EFoil/ESurfboard?


Yes, I’ve been using the 2000g setting for an 1800g motor. The next up is 6000g. As i mentioned before the motor passes the hand/short test fine. I’m running a single motor setup, so the one powertrain I do have is pretty beefy.

I did try getting the latest vesc tool version, and now the motor spun up, but still failed to detect the flux linkage. I can still try updating the firmware on the ESC itself, but that’s an improvement.

1 Like


Try setting battery cutoffs to like 40v just for the detection, or select 16s during the foc wizard.

Which ESC is it?
Is it running 5.3?
Is the battery connected through an XT90 or some temporary setup like alligator clips?


MakerX HV200, running stock firmware and connected through an XT90 and loopkey. The motor is connected with an XT60 for each phase lol. Should be 120A rated.

I’ll try those settings tweaks when I get home tonight, thanks

What version of Vesc tool are you running on?

I just changed to 3.01 this morning, which gave me the improved progress

I’d have to check what firmware version is on the makerX but 3.01 did give me the “older firmware” warning

Cool, I have a similar setup. HV 200, 18s and 80100 130kv. I’ll give it a shot tonight and see if I have any issues. Been meaning to test it anyway.

Alright, voltage cutoffs did nothing, setting to 16s made it halt during the detection spinup and do a big BRRRR noise.

Updating to 5.3 fixed it. Great success!


I started testing my HV200 with an 8080 160kv motor. It comes with 100/250 firmware… which isn’t quite right. That’s for a battery shunt design, not a phase shunt design like the HV200. I wonder if that’s why you (and @Chricious) had some issues.

I compiled new firmware based on the 100/250 but it defines phase shunts and disables phase filters. Here are the motor detection results using the 750g preset (I ran these 2x ea)


The 100/250 5.3 with phase filters off is pretty close, but Lq-Ld is still low. 5.2 had a different way it measured motors, but it still looks pretty far off. With phase filters on 5.3 is waay off.

I also ran a foc_openloop test at 80A. It ran for 9 min before it thermal throttled, which is pretty damn good. VESC 6 barely manages 2 minutes on that test, and throttles a lot more aggressively.

If you want to give it a try:

MakerX_HV200_5.3_jaykup.bin (384.0 KB)
hw_hv200.h (8.3 KB)

1 Like

Thanks for the firmware, had no problems with detection and all the values were pretty close to what they were before. Can’t tell you how much better the thermals are exactly but I did a ride with harder pulls than usual and the motor wasn’t hotter than usual. Didn’t fix the vesc tool connection issue, but the damage was probably already done there.

Could I ask for a favor by compiling it with the ADC indexes switched so I can get around my broken ADC1? I tried learning the process but I have to admit defeat for now.
hw_hv200_ADCswap.h (8.3 KB)

1 Like

Sure, give this a try

MakerX_HV200_5.3_jaykup_adc_swap.bin (384.0 KB)

1 Like

Worked like a charm! Much obliged.

1 Like